summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2024-03-28 11:40:07 +0330
committerMohammadreza Abdollahzadeh2024-03-28 11:40:07 +0330
commitefb5cfee0872bdea7d47a7e0601fe4f59b51c946 (patch)
tree54891d3ae5c98fb4584243e18d3cc3b3f4da086c /PKGBUILD
downloadaur-gnome-shell-extension-window-thumbnails-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffeddf43bc11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+pkgname=gnome-shell-extension-window-thumbnails-git
+pkgver=r38.a885f32
+pkgrel=1
+pkgdesc="A GNOME Shell extension that allows the creation of scaled-down window clones for use as Picture-in-Picture (PIP) thumbnails (Github version)."
+arch=('any')
+url="https://github.com/G-dH/window-thumbnails"
+license=('GPL3')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+depends=('gnome-shell')
+makedepends=('git')
+install="${pkgname%-git}.install"
+source=("${pkgname%-git}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ make zip
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/window-thumbnails@G-dH.github.com"
+ bsdtar -xf "window-thumbnails@G-dH.github.com.zip" \
+ -C "${pkgdir}/usr/share/gnome-shell/extensions/window-thumbnails@G-dH.github.com"
+}
+# vim:set ts=4 sw=4 et: