summarylogtreecommitdiffstats
path: root/0001-install-headers.patch
diff options
context:
space:
mode:
authorMatt Coffin2019-06-14 16:25:43 -0600
committerMatt Coffin2019-06-14 16:25:43 -0600
commit6538f8961df47bb0b24f5561f182c9a65b7a51b7 (patch)
tree665198810ad368249a564676dec2d3678b7feefe /0001-install-headers.patch
parent73802dac3065393c013354936a4c39154d24a6a7 (diff)
downloadaur-wsa-git.tar.gz
Install headers along with library
Diffstat (limited to '0001-install-headers.patch')
-rw-r--r--0001-install-headers.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/0001-install-headers.patch b/0001-install-headers.patch
new file mode 100644
index 000000000000..7e2f4879f04a
--- /dev/null
+++ b/0001-install-headers.patch
@@ -0,0 +1,19 @@
+diff --git a/wayland/CMakeLists.txt b/wayland/CMakeLists.txt
+index 531b67e..8053174 100755
+--- a/wayland/CMakeLists.txt
++++ b/wayland/CMakeLists.txt
+@@ -42,9 +42,12 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-error=deprecated-declarations -Wno-depr
+ set(SOURCES src/wsa_wayland.c)
+
+ add_library(amdgpu_wsa_wayland SHARED ${SOURCES})
++set_target_properties(amdgpu_wsa_wayland PROPERTIES PUBLIC_HEADER "../inc/wsa.h")
+
+ target_include_directories ( amdgpu_wsa_wayland PUBLIC ${WAYLAND_INCLUDE_DIRS} )
+ target_link_libraries ( amdgpu_wsa_wayland PUBLIC ${WAYLAND_LDFLAGS} )
+
+-install(TARGETS amdgpu_wsa_wayland DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-
++install(TARGETS amdgpu_wsa_wayland
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++)