summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIwan Timmer2020-09-02 16:53:54 +0200
committerIwan Timmer2020-09-02 16:53:54 +0200
commit2009157b08d4714f116935234366df7ce313e81a (patch)
treeb671a34d063bc1b14393086b55573afc2bb3a761
parenteceaee6322894a5e79cafe8a99329b5add9333dc (diff)
downloadaur-2009157b08d4714f116935234366df7ce313e81a.tar.gz
Add cpu-features and sdbus-cpp submodules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b49168f3e51..7a1bd12e906f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = anbox-git
- pkgver = r1096.ea2b7a3
+ pkgver = r1240.c1e7550
pkgrel = 1
epoch = 1
url = http://anbox.io/
@@ -17,6 +17,8 @@ pkgbase = anbox-git
makedepends = python2
source = git+https://github.com/anbox/anbox.git
source = git+https://github.com/anbox/anbox-modules.git
+ source = git+https://github.com/google/cpu_features.git
+ source = git+https://github.com/Kistler-Group/sdbus-cpp.git
source = anbox-container-manager.service
source = anbox-session-manager.service
source = 99-anbox.rules
@@ -26,6 +28,8 @@ pkgbase = anbox-git
source = anbox-bridge.netdev
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 5be94b63dc30d141f15ca7d1be6e3e81f26ef33f844614975537562f5d08236c
sha256sums = 1f22dbb5a3ca6925bbf62899cd0f0bbaa0b77c879adcdd12ff9d43adfa61b1d8
sha256sums = 210eb93342228168f7bb632c8b93d9bfda6f53f62459a6b74987fa1e17530475
diff --git a/PKGBUILD b/PKGBUILD
index b3196f94a713..24f69a750d78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('anbox-git' 'anbox-modules-dkms-git')
_pkgname=anbox
-pkgver=r1096.ea2b7a3
+pkgver=r1240.c1e7550
pkgrel=1
epoch=1
arch=('x86_64')
@@ -11,6 +11,8 @@ license=('GPL3')
makedepends=('cmake' 'git' 'glm' 'lxc' 'sdl2_image' 'protobuf' 'boost' 'properties-cpp' 'gtest' 'python2')
source=("git+https://github.com/anbox/anbox.git"
"git+https://github.com/anbox/anbox-modules.git"
+ "git+https://github.com/google/cpu_features.git"
+ "git+https://github.com/Kistler-Group/sdbus-cpp.git"
'anbox-container-manager.service'
'anbox-session-manager.service'
'99-anbox.rules'
@@ -20,6 +22,8 @@ source=("git+https://github.com/anbox/anbox.git"
'anbox-bridge.netdev')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'5be94b63dc30d141f15ca7d1be6e3e81f26ef33f844614975537562f5d08236c'
'1f22dbb5a3ca6925bbf62899cd0f0bbaa0b77c879adcdd12ff9d43adfa61b1d8'
'210eb93342228168f7bb632c8b93d9bfda6f53f62459a6b74987fa1e17530475'
@@ -42,6 +46,11 @@ prepare() {
# Don't build tests
truncate -s 0 cmake/FindGMock.cmake
truncate -s 0 tests/CMakeLists.txt
+
+ git submodule init
+ git config submodule.external/cpu_features.url $srcdir/cpu_features
+ git config submodule.external/sdbus-cpp.url $srcdir/sdbus-cpp
+ git submodule update
}
build() {