summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaha6622020-05-25 23:01:56 -0400
committerhaha6622020-05-25 23:01:56 -0400
commit0dc89e305459ab0a33055f42c314cd2814e40eae (patch)
tree33711bfffe17dbd69270995752108c8245dae53d
downloadaur-arch-texdoc-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24d843da6436
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = arch-texdoc-git
+ pkgdesc = Drop-in replacement of texdoc for Arch Linux using online documents
+ pkgver = r3.5fe70bf
+ pkgrel = 1
+ url = https://github.com/haha662/arch-texdoc
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ source = arch-texdoc-git::git+https://github.com/haha662/arch-texdoc.git
+ sha256sums = SKIP
+
+pkgname = arch-texdoc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26a1018f00f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: haha662 <haha662 at outlook dot com>
+
+pkgname=arch-texdoc-git
+pkgver=r3.5fe70bf
+pkgrel=1
+pkgdesc="Drop-in replacement of texdoc for Arch Linux using online documents"
+arch=("any")
+url="https://github.com/haha662/arch-texdoc"
+license=("MIT")
+depends=("python" "xdg-utils")
+makedepends=("git")
+source=("$pkgname::git+https://github.com/haha662/arch-texdoc.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm755 arch-texdoc.py "${pkgdir}/usr/bin/arch-texdoc"
+}