summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:11:06 +0800
committerFelix Yan2015-07-23 20:11:06 +0800
commit381febf79c3277281812f39e4ccf722069d7e093 (patch)
tree757090bc29ef4ecd632982e71785153f020152ea
downloadaur-arpoison.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
3 files changed, 50 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..25b87749e01e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = arpoison
+ pkgdesc = The UNIX arp cache update utility
+ pkgver = 0.7
+ pkgrel = 1
+ url = http://www.arpoison.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libnet
+ source = http://www.arpoison.net/arpoison-0.7.tar.gz
+
+pkgname = arpoison
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26adcdc15663
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = arpoison
+ pkgdesc = The UNIX arp cache update utility
+ pkgver = 0.7
+ pkgrel = 1
+ url = http://www.arpoison.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libnet
+ source = http://www.arpoison.net/arpoison-0.7.tar.gz
+ md5sums = 0e86186eb18c9aabf78afa9706b40530
+
+pkgname = arpoison
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0be61ddff1d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Zhang Li <msfxzi at sina.com>
+
+pkgname=arpoison
+pkgver=0.7
+pkgrel=1
+pkgdesc="The UNIX arp cache update utility"
+arch=(i686 x86_64)
+url="http://www.arpoison.net"
+license=('GPL')
+depends=('libnet')
+source=("http://www.arpoison.net/$pkgname-$pkgver.tar.gz")
+md5sums=('0e86186eb18c9aabf78afa9706b40530')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname-$pkgver/arpoison" "$pkgdir/usr/bin/arpoison"
+}
+