summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImperatorStorm2023-05-03 12:21:21 -0700
committerImperatorStorm2023-05-03 12:21:21 -0700
commit0ae586ef92d799944554f0d2482b502be73a7855 (patch)
treeb2b309a8aee7419295b738f33a1075486b38bdf8
parent8f3a87e0548fbade6dceff06597d0be8900025f4 (diff)
downloadaur-0ae586ef92d799944554f0d2482b502be73a7855.tar.gz
Fix `aseprite` compilation with GCC 13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b567e66ed5d6..17714d4b8eb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aseprite
pkgdesc = Create animated sprites and pixel art
pkgver = 1.2.40
- pkgrel = 5
+ pkgrel = 6
url = https://www.aseprite.org/
arch = x86_64
license = custom
@@ -35,6 +35,8 @@ pkgbase = aseprite
noextract = skia-m102.tar.gz
source = https://github.com/aseprite/aseprite/releases/download/v1.2.40/Aseprite-v1.2.40-Source.zip
source = skia-m102.tar.gz::https://github.com/aseprite/skia/archive/refs/tags/m102-861e4743af.tar.gz
+ source = IXWebSocket-GCC13pt1.patch::https://patch-diff.githubusercontent.com/raw/machinezone/IXWebSocket/pull/389.patch
+ source = IXWebSocket-GCC13pt2.patch::https://patch-diff.githubusercontent.com/raw/machinezone/IXWebSocket/pull/443.patch
source = desktop.patch
source = shared-fmt.patch
source = shared-libarchive.patch
@@ -43,6 +45,8 @@ pkgbase = aseprite
source = optional-pixman.patch
sha256sums = cd67eaf34ee19ae5584f9052f3b385dcfa41232f38016baf08723b987ae583fb
sha256sums = 8d76c1ad3693e1fc019eb14d806082148eb4ed7d601474aeeaae601b05a9b3ad
+ sha256sums = 540bdd2985ec1295137deab99b95cb484934ab5d6d3b080fbc21d15e50a5e429
+ sha256sums = 5c188f30ebf15013f346ef2868d6cfeb84f7ee8ac68f837fee6269aabfa4ae59
sha256sums = 8b14e36939e930de581e95abf0591645aa0fcfd47161cf88b062917dbaaef7f9
sha256sums = 821f1354dbbc0bb3fa700e63037ed3c89b0d32bd2ab253450f91eeacd7d47c06
sha256sums = d7f2f8c43d24382453273ed17b1c0e05928980a36ad0b7c988da3aa0fe32de53
diff --git a/PKGBUILD b/PKGBUILD
index 2b444654ecf8..d74df0c6d76c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgname=aseprite
pkgver=1.2.40
_skiaver=m102
_skiahash=861e4743af
-pkgrel=5
+pkgrel=6
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64')
url="https://www.aseprite.org/"
@@ -41,6 +41,8 @@ makedepends=(# "Meta" dependencies
source=("https://github.com/aseprite/aseprite/releases/download/v$pkgver/Aseprite-v$pkgver-Source.zip"
# Which branch a given build of Aseprite requires is noted in its `INSTALL.md`
"skia-$_skiaver.tar.gz::https://github.com/aseprite/skia/archive/refs/tags/$_skiaver-$_skiahash.tar.gz"
+ IXWebSocket-GCC13pt1.patch::https://patch-diff.githubusercontent.com/raw/machinezone/IXWebSocket/pull/389.patch
+ IXWebSocket-GCC13pt2.patch::https://patch-diff.githubusercontent.com/raw/machinezone/IXWebSocket/pull/443.patch
desktop.patch
shared-fmt.patch
# Based on https://patch-diff.githubusercontent.com/raw/aseprite/aseprite/pull/2535.patch
@@ -53,6 +55,8 @@ noextract=("Aseprite-v$pkgver-Source.zip"
"skia-$_skiaver.tar.gz") # Don't extract Aseprite or skia sources at the root
sha256sums=('cd67eaf34ee19ae5584f9052f3b385dcfa41232f38016baf08723b987ae583fb'
'8d76c1ad3693e1fc019eb14d806082148eb4ed7d601474aeeaae601b05a9b3ad'
+ '540bdd2985ec1295137deab99b95cb484934ab5d6d3b080fbc21d15e50a5e429'
+ '5c188f30ebf15013f346ef2868d6cfeb84f7ee8ac68f837fee6269aabfa4ae59'
'8b14e36939e930de581e95abf0591645aa0fcfd47161cf88b062917dbaaef7f9'
'821f1354dbbc0bb3fa700e63037ed3c89b0d32bd2ab253450f91eeacd7d47c06'
'd7f2f8c43d24382453273ed17b1c0e05928980a36ad0b7c988da3aa0fe32de53'
@@ -77,6 +81,8 @@ prepare() {
# Their "FindSkia" module forcefully tries to use Skia's FreeType and HarfBuzz,
# but we don't clone those because we use the shared ones. Avoid overwriting the settings instead.
env -C aseprite patch -tp1 <shared-skia-deps.patch
+ env -C aseprite/third_party/IXWebSocket patch -tp1 <IXWebSocket-GCC13pt1.patch
+ env -C aseprite/third_party/IXWebSocket patch -tp1 <IXWebSocket-GCC13pt2.patch
}
build() {