summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrouhannb2020-03-13 13:42:30 -0400
committerrouhannb2020-03-13 13:42:30 -0400
commit3bc48e49e0adf90644b435d07fc32ad55050d7df (patch)
treece320b057fb75863795cadf2ad8909398479b6a1
parent9ab6b40eb34e083b3e91bcbbafb73acd11bec1d1 (diff)
downloadaur-3bc48e49e0adf90644b435d07fc32ad55050d7df.tar.gz
Use static libjpeg
Using libjpeg-turbo on Aseprite gives the error “Wrong JPEG library version: library is 62, caller expects 80.” I’m not sure if there is any way to use a shared library right now, so I took the easy way out and just used the static library compiled with Aseprite. Additionally, I changed the hack for using Python 2 with depot_tools to something less messy.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fa15dd8f5f..07f0b788482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aseprite
pkgdesc = Create animated sprites and pixel art
pkgver = 1.2.17
- pkgrel = 1
+ pkgrel = 2
url = http://www.aseprite.org/
arch = x86_64
license = custom
@@ -14,7 +14,6 @@ pkgbase = aseprite
depends = giflib
depends = zlib
depends = libpng
- depends = libjpeg-turbo
depends = tinyxml
depends = freetype2
depends = harfbuzz
diff --git a/PKGBUILD b/PKGBUILD
index b444115dbdb..ccaf7f7db3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@
pkgname=aseprite
pkgver=1.2.17
-pkgrel=1
+pkgrel=2
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64')
url="http://www.aseprite.org/"
license=('custom')
-depends=('cmark' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2'
+depends=('cmark' 'curl' 'giflib' 'zlib' 'libpng' 'tinyxml' 'freetype2'
'harfbuzz' 'nettle' 'fontconfig' 'libxcursor' 'hicolor-icon-theme')
makedepends=('cmake' 'ninja' 'git' 'python2')
conflicts=("aseprite-git" "aseprite-gpl" "skia-git")
@@ -135,22 +135,19 @@ prepare() {
chmod u=rwx,g=rx,o=rx --verbose gn
mv --verbose gn skia/bin/gn
cp --verbose skia/bin/gn skia/buildtools/linux64/gn
-
- # Skia assumes python is linked to python2, not python3
- mkdir --parents --verbose binsub
- cd binsub
- ln --force --symbolic --verbose /usr/bin/python2 python
}
build() {
cd "${srcdir}"
# Build skia
- _skiapath="${srcdir}/binsub:${srcdir}/depot_tools:${PATH}"
+ _skiapath="${srcdir}/depot_tools:${PATH}"
cd skia
- PATH="${_skiapath}" gn gen out/Release-x64 --args="is_debug=false is_official_build=true \
- skia_use_system_expat=false skia_use_system_icu=false skia_use_system_libjpeg_turbo=false \
- skia_use_system_libpng=false skia_use_system_libwebp=false skia_use_system_zlib=false"
+ # Bypass the gn script, which uses `python` and expects Python 2
+ PATH="${_skiapath}" PYTHONDONTWRITEBYTECODE=1 python2 "$(which gn.py)" gen out/Release-x64 \
+ --args="is_debug=false is_official_build=true skia_use_system_expat=false \
+ skia_use_system_icu=false skia_use_system_libjpeg_turbo=false skia_use_system_libpng=false \
+ skia_use_system_libwebp=false skia_use_system_zlib=false"
PATH="${_skiapath}" ninja -C out/Release-x64 skia modules
# Build aseprite
@@ -161,7 +158,6 @@ build() {
-DWITH_WEBP_SUPPORT=ON \
-DUSE_SHARED_CURL=ON \
-DUSE_SHARED_GIFLIB=ON \
- -DUSE_SHARED_JPEGLIB=ON \
-DUSE_SHARED_HARFBUZZ=ON \
-DUSE_SHARED_ZLIB=ON \
-DUSE_SHARED_LIBPNG=ON \