summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImperatorStorm2023-05-03 12:39:37 -0700
committerImperatorStorm2023-05-03 12:40:07 -0700
commitbf5e8bec21452d88a415f23b81ccc52c8a97f63e (patch)
treec58ecd542be4506306cd8aae701bb3afa9bf9171
parent0ae586ef92d799944554f0d2482b502be73a7855 (diff)
downloadaur-bf5e8bec21452d88a415f23b81ccc52c8a97f63e.tar.gz
Screw it, upstream uses `clang`, `gcc>=13` is broken, using `clang`.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17714d4b8eb1..b8ae987af4b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aseprite
pkgdesc = Create animated sprites and pixel art
pkgver = 1.2.40
- pkgrel = 6
+ pkgrel = 7
url = https://www.aseprite.org/
arch = x86_64
license = custom
@@ -12,6 +12,7 @@ pkgbase = aseprite
makedepends = libxi
makedepends = gn
makedepends = harfbuzz-icu
+ makedepends = clang
depends = cmark
depends = libcurl.so
depends = libgif.so
diff --git a/PKGBUILD b/PKGBUILD
index d74df0c6d76c..784082437e00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgname=aseprite
pkgver=1.2.40
_skiaver=m102
_skiahash=861e4743af
-pkgrel=6
+pkgrel=7
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64')
url="https://www.aseprite.org/"
@@ -36,7 +36,8 @@ makedepends=(# "Meta" dependencies
# Skia
gn harfbuzz-icu
# TODO: Benchmark clang v gcc
- # clang
+ # Fuck it, compiling with GCC>=13 is broken and I'm not gonna write a patch to fix it
+ clang
)
source=("https://github.com/aseprite/aseprite/releases/download/v$pkgver/Aseprite-v$pkgver-Source.zip"
# Which branch a given build of Aseprite requires is noted in its `INSTALL.md`
@@ -88,6 +89,10 @@ prepare() {
build() {
echo Building Skia...
local _skiadir="$PWD/skia/obj"
+ export CXX=clang++
+ export CC=clang
+ export AR=ar
+ export NM=nm
# Flags can be found by running `gn args --list "$_skiadir"` from skia's directory.
# (Pipe the output somewhere, there's a LOT of args.)
#
@@ -127,10 +132,18 @@ skia_enable_{particles,skparagraph,sktext}=false)"
}
check() {
+ export CXX=clang++
+ export CC=clang
+ export AR=ar
+ export NM=nm
env -C build ctest --output-on-failure
}
package() {
+ export CXX=clang++
+ export CC=clang
+ export AR=ar
+ export NM=nm
# Now the fun part: components of e.g. `libwebp` get installed as well,
# since we've had to compile it. But we don't want them.
# So, install normally, and then cherry-pick Aseprite's files out of that.