summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasya Novikov2016-04-05 21:27:00 +0300
committerVasya Novikov2016-04-05 21:27:00 +0300
commit408b67b89679f46876c988b1081ed7cea84bb39c (patch)
tree6bc12236097f91c1bc457cdd5f78ebeeb5184e34
downloadaur-408b67b89679f46876c988b1081ed7cea84bb39c.tar.gz
initial commit for the git version of bambam
Successfully builds and runs locally.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
-rw-r--r--bambam.desktop8
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6063d7a36ebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bambam-git
+ pkgdesc = A simple baby keyboard masher application.
+ pkgver = r45.e3680c3
+ pkgrel = 1
+ url = https://github.com/porridge/bambam
+ arch = any
+ license = GPLv3
+ depends = python2
+ depends = python2-pygame
+ source = git+https://github.com/porridge/bambam.git
+ source = bambam.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = bambam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd77e40a325d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Vasya Novikov <vnnn91@yandex.ru> (replace "nnn" with a single "n")
+
+pkgname=bambam-git
+pkgver=r45.e3680c3
+pkgrel=1
+pkgdesc="A simple baby keyboard masher application."
+arch=('any')
+url="https://github.com/porridge/bambam"
+license=('GPLv3')
+depends=('python2' 'python2-pygame')
+source=("git+https://github.com/porridge/bambam.git"
+ bambam.desktop)
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/bambam"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/bambam"
+
+ # allow bambam to be executed from a symlink
+ # remove these lines if/after a corresponding PR gets merged to master
+ sed -i -e 's/normpath/realpath/' bambam.py
+}
+
+package() {
+ cd "${srcdir}/bambam"
+
+ mkdir -p "${pkgdir}/usr/share/icons"
+ cp icon.gif "${pkgdir}/usr/share/icons/bambam.gif"
+
+ mkdir -p "${pkgdir}/usr/share/games/bambam"
+ cp -R bambam.py data "${pkgdir}/usr/share/games/bambam/"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp "${srcdir}/bambam.desktop" "${pkgdir}/usr/share/applications/"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln --symbolic "../share/games/bambam/bambam.py" "${pkgdir}/usr/bin/bambam"
+}
diff --git a/bambam.desktop b/bambam.desktop
new file mode 100644
index 000000000000..2e255ac921cf
--- /dev/null
+++ b/bambam.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=BamBam
+Comment=A simple baby keyboard masher
+Exec=bambam -d -u
+Icon=bambam
+Terminal=false
+Type=Application
+Categories=Game