summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTankMissile2020-07-01 06:53:50 -0400
committerTankMissile2020-07-01 06:53:50 -0400
commit3adadeccca2a4eaab6645b6af817ad9887bd12a8 (patch)
treebd67a3204108876ea9878553db3d0f1731dd5edc
parentf1586775849591fcbb5816955ed2f2c08c5ca4ea (diff)
downloadaur-3adadeccca2a4eaab6645b6af817ad9887bd12a8.tar.gz
PKGBUILD and changelog cleanup.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
-rw-r--r--bcache-tools.changelog14
3 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12955dd07dba..6c1ebed24175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = bcache-tools
- pkgdesc = Userspace tools for bcache until bcache merges with either dm or md
+ pkgdesc = Userspace tools for bcache until bcache merges with either dm or md.
pkgver = 1.1
pkgrel = 1
url = http://bcache.evilpiepirate.org/
diff --git a/PKGBUILD b/PKGBUILD
index 679e1dcf1701..b136ecf14229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,37 +6,35 @@
pkgname=bcache-tools
pkgver=1.1
pkgrel=1
-pkgdesc="Userspace tools for bcache until bcache merges with either dm or md"
changelog=bcache-tools.changelog
-arch=("i686" "x86_64")
+pkgdesc="Userspace tools for bcache until bcache merges with either dm or md."
url="http://bcache.evilpiepirate.org/"
+arch=("i686" "x86_64")
license=("GPL")
depends=("util-linux")
-install="${pkgname}.install"
+install="$pkgname.install"
source=("https://git.kernel.org/pub/scm/linux/kernel/git/colyli/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz"
"initcpio-dracut-arch.patch")
sha256sums=("d1c92274ae03b414dd1a05277bf89dd2a8395496c692e3b143d9e6112d3421f8"
"fea3ddfcef7aaac6cc6dd0c5497bc5f69f799d4f9f286e978ebd4b9326347f9c")
prepare() {
- cd "${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/initcpio-dracut-arch.patch"
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/initcpio-dracut-arch.patch"
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
make
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
install -d \
- "${pkgdir}/usr/bin" \
- "${pkgdir}/usr/lib/udev/rules.d" \
- "${pkgdir}/usr/share/man/man8" \
- "${pkgdir}/usr/lib/initcpio/install"
+ "$pkgdir/usr/bin" \
+ "$pkgdir/usr/lib/udev/rules.d" \
+ "$pkgdir/usr/share/man/man8" \
+ "$pkgdir/usr/lib/initcpio/install"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/bcache-tools.changelog b/bcache-tools.changelog
index da4e1d83c3cc..a5ced564a793 100644
--- a/bcache-tools.changelog
+++ b/bcache-tools.changelog
@@ -1,10 +1,12 @@
2013-01-07
- * Added dependency on util-linux
- * Fixed up now-unecessary patches due to initcpio udev hook being applied upstream
- * Added warning on update to change mkinitcpio.conf to use bcache rule instead of the now-defunct bcache_udev
- * Fixed minor packaging issues that caused namcap to complain
+ * Added dependency on util-linux.
+ * Fixed up now-unecessary patches due to initcpio udev hook being applied upstream.
+ * Added warning on update to change mkinitcpio.conf to use bcache rule instead of the now-defunct bcache_udev.
+ * Fixed minor packaging issues that caused namcap to complain.
2014-01-06
- * Initial version based off of bcache-tools-git package
+ * Initial version based off of bcache-tools-git package.
+
2020-03-07
- * Removed crc64.patch as it is no longer needed.
+ * Removed crc64.patch as it's no longer needed.
+ * Added dracut support.