summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTankMissile2020-03-03 22:37:10 -0500
committerTankMissile2020-03-03 22:37:10 -0500
commite859fcba98884bc46d1cc5b7e440e8c1bc7b2cdc (patch)
tree745a75b74c95a4f9296e6f5d546be6775ca54bb2
parent1a509f9c6e189db1e938c91c25437442b97e55ff (diff)
downloadaur-e859fcba98884bc46d1cc5b7e440e8c1bc7b2cdc.tar.gz
Fixed initcpio-arch.patch to include dracut module.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--initcpio-arch.patch5
3 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 963bdcf47a99..dafba4b553f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = bcache-tools
source = initcpio-arch.patch
sha256sums = d56923936f37287efc57a46315679102ef2c86cd0be5874590320acd48c1201c
sha256sums = 2536e1ea76b32b4ee4543524c64f488ccc0fe037256ce9d5c5029e873161de7e
- sha256sums = bbde2580952b60e061d335a867219146348e8c7208bdebade463675a6585a87e
+ sha256sums = a905ac4daa69ced9aa9422c9d7f20f40f6226510998be2a890d105aa22ab60de
pkgname = bcache-tools
diff --git a/PKGBUILD b/PKGBUILD
index a35e5cd4a15c..01328fdffa96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ source=("https://github.com/g2p/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.g
'initcpio-arch.patch')
sha256sums=('d56923936f37287efc57a46315679102ef2c86cd0be5874590320acd48c1201c'
'2536e1ea76b32b4ee4543524c64f488ccc0fe037256ce9d5c5029e873161de7e'
- 'bbde2580952b60e061d335a867219146348e8c7208bdebade463675a6585a87e')
+ 'a905ac4daa69ced9aa9422c9d7f20f40f6226510998be2a890d105aa22ab60de')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/initcpio-arch.patch b/initcpio-arch.patch
index 218389f75e11..19f65cdf7fa0 100644
--- a/initcpio-arch.patch
+++ b/initcpio-arch.patch
@@ -2,8 +2,8 @@ diff --git a/Makefile b/Makefile
index 8e38d9a..2db4c82 100644
--- a/Makefile
+++ b/Makefile
-@@ -8,13 +8,11 @@ CFLAGS+=-O2 -Wall -g
- all: make-bcache probe-bcache bcache-super-show
+@@ -8,13 +8,12 @@ CFLAGS+=-O2 -Wall -g
+ all: make-bcache probe-bcache bcache-super-show bcache-register
install: make-bcache probe-bcache bcache-super-show
- $(INSTALL) -m0755 make-bcache bcache-super-show $(DESTDIR)${PREFIX}/sbin/
@@ -15,6 +15,7 @@ index 8e38d9a..2db4c82 100644
$(INSTALL) -m0644 -- *.8 $(DESTDIR)${PREFIX}/share/man/man8/
- $(INSTALL) -D -m0755 initramfs/hook $(DESTDIR)/usr/share/initramfs-tools/hooks/bcache
$(INSTALL) -D -m0755 initcpio/install $(DESTDIR)/usr/lib/initcpio/install/bcache
+ $(INSTALL) -D -m0755 dracut/module-setup.sh $(DESTDIR)$(DRACUTLIBDIR)/modules.d/90bcache/module-setup.sh
# $(INSTALL) -m0755 bcache-test $(DESTDIR)${PREFIX}/sbin/
clean: