summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTankMissile2020-03-07 23:55:33 -0500
committerTankMissile2020-03-07 23:55:33 -0500
commitf1586775849591fcbb5816955ed2f2c08c5ca4ea (patch)
tree618c8250bfe9151e693b430f46d787928e7375ac
parentc28b2e52ba575e4b42b41f5e61f709ceb7a554a9 (diff)
downloadaur-f1586775849591fcbb5816955ed2f2c08c5ca4ea.tar.gz
Updated version to 1.1.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--bcache-tools.changelog2
-rw-r--r--initcpio-dracut-arch.patch (renamed from initcpio-arch.patch)6
4 files changed, 21 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f49e14e10caf..12955dd07dba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bcache-tools
pkgdesc = Userspace tools for bcache until bcache merges with either dm or md
- pkgver = 1.0.8
- pkgrel = 4
+ pkgver = 1.1
+ pkgrel = 1
url = http://bcache.evilpiepirate.org/
install = bcache-tools.install
changelog = bcache-tools.changelog
@@ -9,12 +9,10 @@ pkgbase = bcache-tools
arch = x86_64
license = GPL
depends = util-linux
- source = https://github.com/g2p/bcache-tools/archive/v1.0.8/bcache-tools-1.0.8.tar.gz
- source = crc64.patch
- source = initcpio-arch.patch
- sha256sums = d56923936f37287efc57a46315679102ef2c86cd0be5874590320acd48c1201c
- sha256sums = 2536e1ea76b32b4ee4543524c64f488ccc0fe037256ce9d5c5029e873161de7e
- sha256sums = 29f0825272e58f092307b6bfa1d472a12e7a8c4e0f8ae8584a4492d7bed3e07d
+ source = https://git.kernel.org/pub/scm/linux/kernel/git/colyli/bcache-tools.git/snapshot/bcache-tools-1.1.tar.gz
+ source = initcpio-dracut-arch.patch
+ sha256sums = d1c92274ae03b414dd1a05277bf89dd2a8395496c692e3b143d9e6112d3421f8
+ sha256sums = fea3ddfcef7aaac6cc6dd0c5497bc5f69f799d4f9f286e978ebd4b9326347f9c
pkgname = bcache-tools
diff --git a/PKGBUILD b/PKGBUILD
index 89c5b3647279..679e1dcf1701 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,23 @@
# Contributor: Mikeserv
pkgname=bcache-tools
-pkgver=1.0.8
-pkgrel=4
+pkgver=1.1
+pkgrel=1
pkgdesc="Userspace tools for bcache until bcache merges with either dm or md"
changelog=bcache-tools.changelog
-arch=('i686' 'x86_64')
+arch=("i686" "x86_64")
url="http://bcache.evilpiepirate.org/"
-license=('GPL')
-depends=('util-linux')
+license=("GPL")
+depends=("util-linux")
install="${pkgname}.install"
-source=("https://github.com/g2p/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
- 'crc64.patch'
- 'initcpio-arch.patch')
-sha256sums=('d56923936f37287efc57a46315679102ef2c86cd0be5874590320acd48c1201c'
- '2536e1ea76b32b4ee4543524c64f488ccc0fe037256ce9d5c5029e873161de7e'
- '29f0825272e58f092307b6bfa1d472a12e7a8c4e0f8ae8584a4492d7bed3e07d')
+source=("https://git.kernel.org/pub/scm/linux/kernel/git/colyli/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz"
+ "initcpio-dracut-arch.patch")
+sha256sums=("d1c92274ae03b414dd1a05277bf89dd2a8395496c692e3b143d9e6112d3421f8"
+ "fea3ddfcef7aaac6cc6dd0c5497bc5f69f799d4f9f286e978ebd4b9326347f9c")
prepare() {
cd "${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/initcpio-arch.patch"
- patch -Np1 -i "${srcdir}/crc64.patch"
+ patch -Np1 -i "${srcdir}/initcpio-dracut-arch.patch"
}
build() {
diff --git a/bcache-tools.changelog b/bcache-tools.changelog
index 3f52b98f4a61..da4e1d83c3cc 100644
--- a/bcache-tools.changelog
+++ b/bcache-tools.changelog
@@ -6,3 +6,5 @@
2014-01-06
* Initial version based off of bcache-tools-git package
+2020-03-07
+ * Removed crc64.patch as it is no longer needed.
diff --git a/initcpio-arch.patch b/initcpio-dracut-arch.patch
index d8396396899b..ad7ccb8635db 100644
--- a/initcpio-arch.patch
+++ b/initcpio-dracut-arch.patch
@@ -1,12 +1,12 @@
diff --git a/Makefile b/Makefile
-index 8e38d9a..2db4c82 100644
+index 4359866..854a473 100644
--- a/Makefile
+++ b/Makefile
@@ -8,13 +8,12 @@ CFLAGS+=-O2 -Wall -g
- all: make-bcache probe-bcache bcache-super-show bcache-register
+ all: make-bcache probe-bcache bcache-super-show bcache-register bcache
install: make-bcache probe-bcache bcache-super-show
-- $(INSTALL) -m0755 make-bcache bcache-super-show $(DESTDIR)${PREFIX}/sbin/
+- $(INSTALL) -m0755 make-bcache bcache-super-show bcache $(DESTDIR)${PREFIX}/sbin/
- $(INSTALL) -m0755 probe-bcache bcache-register $(DESTDIR)$(UDEVLIBDIR)/
- $(INSTALL) -m0644 69-bcache.rules $(DESTDIR)$(UDEVLIBDIR)/rules.d/
+ $(INSTALL) -m0755 make-bcache bcache-super-show $(DESTDIR)${PREFIX}/bin/