summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:38:31 -0600
committergustawho2021-05-13 20:38:31 -0600
commit1e067eb1cf2ae717c4bba889625da9beb04599b8 (patch)
treeb4d6d3d84315de50ed0af012f9b58193bbb806ba
parent0379932cc3b392b3e41916db4f6db57e1d107a19 (diff)
downloadaur-buho-git.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b628f29b043..d1cf88e466c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = buho-git
pkgdesc = Task and Note Keeper
- pkgver = v1.2.1.r10.g610d337
+ pkgver = v1.2.2.r1.g4860995
pkgrel = 1
url = https://invent.kde.org/maui/buho
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
groups = maui-apps
license = GPL3
makedepends = git
makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ makedepends = qt5-svg
depends = ki18n
depends = qt5-webview
depends = mauikit-git
diff --git a/PKGBUILD b/PKGBUILD
index 6f3b1c7bfad2..dbcd19de6936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=buho-git
-pkgver=v1.2.1.r10.g610d337
+pkgver=v1.2.2.r1.g4860995
pkgrel=1
pkgdesc="Task and Note Keeper"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
groups=('maui-apps')
url="https://invent.kde.org/maui/buho"
license=('GPL3')
depends=('ki18n' 'qt5-webview' 'mauikit-git' 'kio' 'syntax-highlighting' 'attica' 'mauikit-filebrowsing-git')
-makedepends=('git' 'extra-cmake-modules')
+makedepends=('git' 'extra-cmake-modules' 'qt5-tools' 'qt5-svg')
provides=('buho')
conflicts=('buho')
source=("git+$url.git")
@@ -24,10 +24,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S "${pkgname%-git}"
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
} \ No newline at end of file