summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlice Gaudon2020-08-06 13:42:39 +0200
committerGitHub2020-08-06 13:42:39 +0200
commit1fbb3e981d4fe4d97f88bf34424f1f9c255ade9e (patch)
treefd6e2ccdf8081521dfc370b3b4ded1ae15e7978c
parent4bafe9ce6ef808ac02f2e40c42cab88c0674e5d6 (diff)
parent40d19efebaf9191121c4554e0dd4ba945b55e801 (diff)
downloadaur-1fbb3e981d4fe4d97f88bf34424f1f9c255ade9e.tar.gz
Merge branch 'master' into caddyfile
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 749bdc656b27..267d3e17e6ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,13 +38,16 @@ validpgpkeys=(
'29D0817A67156E4F25DC24782A349DD577D586A5' # Matthew Holt <mholt@users.noreply.github.com>
)
-pkgver() {
- cd ${_pkgname}
- git describe --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
prepare() {
sed 's|/var/www/html|/srv/http|g' -i "${srcdir}/index-${_distcommit}.html"
+
+ # Build instructions as per https://github.com/caddyserver/caddy#with-version-information-andor-plugins
+ cd "${_pkgname}/cmd/caddy/"
+ if ! test -f go.mod; then
+ go mod init caddy
+ fi
+ go get github.com/caddyserver/caddy/v2@${_tag} # Pin version
+ go mod tidy # Update go.sum
}
build() {