summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-23 20:54:50 +0200
committerPiotr Gorski2023-08-23 20:54:50 +0200
commit069ddda415c69b3538ab37fdd3e619598e24ee72 (patch)
tree469174ea19532ede19ded7984175a41e85129db9
parentd73ecb8ed99e020ee8c8b8c3662e2f4c3f4129c0 (diff)
downloadaur-cmake-git.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c31b8e173a1..575f10eebcc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cmake-git
pkgdesc = A cross-platform open-source make system
- pkgver = 3.27.0.rc4.205.gff3179cef8
- pkgrel = 2
+ pkgver = 3.27.4.645.g72beefa91b
+ pkgrel = 1
url = http://www.cmake.org/
arch = x86_64
license = custom
makedepends = qt6-base
makedepends = python-sphinx
makedepends = emacs
+ makedepends = nlohmann-json
makedepends = git
depends = curl
depends = libarchive
@@ -16,6 +17,7 @@ pkgbase = cmake-git
depends = libjsoncpp.so
depends = libuv
depends = rhash
+ depends = cppdap
optdepends = qt6-base: cmake-gui
provides = cmake
conflicts = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 45e5ce2929b0..526c7d517603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@
# This PKGBUILD is based on the official Arch cmake package.
pkgname=cmake-git
-pkgver=3.27.0.rc4.205.gff3179cef8
-pkgrel=2
+pkgver=3.27.4.645.g72beefa91b
+pkgrel=1
pkgdesc='A cross-platform open-source make system'
arch=('x86_64')
url="http://www.cmake.org/"
license=('custom')
conflicts=('cmake')
provides=('cmake')
-depends=('curl' 'libarchive' 'hicolor-icon-theme' 'jsoncpp' 'libjsoncpp.so' 'libuv' 'rhash')
-makedepends=('qt6-base' 'python-sphinx' 'emacs' 'git')
+depends=('curl' 'libarchive' 'hicolor-icon-theme' 'jsoncpp' 'libjsoncpp.so' 'libuv' 'rhash' 'cppdap')
+makedepends=('qt6-base' 'python-sphinx' 'emacs' 'nlohmann-json' 'git')
optdepends=('qt6-base: cmake-gui')
source=('git+https://gitlab.kitware.com/cmake/cmake.git'
'cmake-cppflags.patch')
@@ -48,7 +48,6 @@ build() {
--sphinx-html \
--system-libs \
--qt-gui \
- --no-system-cppdap \
--parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
make
}