summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2016-09-05 19:19:10 -0700
committerMichael Hansen2016-09-05 19:19:10 -0700
commit4574cf458fdc3df5afca6b4d6ba0ee2e9d592328 (patch)
treec5780174339b792f84b129d39b14b4c3fa4fac49
parentabe0ff3a0cea03a2b3dbf22a44253be3f676b5ee (diff)
downloadaur-4574cf458fdc3df5afca6b4d6ba0ee2e9d592328.tar.gz
Fix product_json.patch for newer builds, and update tag pattern match
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--product_json.patch12
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1dddeefe468..28453a5047e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Aug 5 00:24:47 UTC 2016
+# Tue Sep 6 02:18:44 UTC 2016
pkgbase = visual-studio-code-git
pkgdesc = Visual Studio Code for Linux, Open Source version from git
- pkgver = 1.1.0.insider.r3197.g1a7ca5a
+ pkgver = 1.1.0.insider.r4276.g2a215cc
pkgrel = 1
url = https://code.visualstudio.com/
arch = i686
@@ -22,7 +22,7 @@ pkgbase = visual-studio-code-git
source = product_json.patch
sha1sums = SKIP
sha1sums = a42e461ed586ef0fd31ff911ad662135f4f602aa
- sha1sums = 8a36a8af89af183e0fa29d9141a1bb4ae9cafd5a
+ sha1sums = 34758e925f36cabe6167198c9bd11c12b07b2052
pkgname = visual-studio-code-git
diff --git a/PKGBUILD b/PKGBUILD
index 28649ae9ae86..ce8f92c3be7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=visual-studio-code-git
pkgdesc='Visual Studio Code for Linux, Open Source version from git'
-pkgver=1.1.0.insider.r3197.g1a7ca5a
+pkgver=1.1.0.insider.r4276.g2a215cc
pkgrel=1
arch=('i686' 'x86_64')
url='https://code.visualstudio.com/'
@@ -17,7 +17,7 @@ source=("git+https://github.com/Microsoft/vscode"
'product_json.patch')
sha1sums=('SKIP'
'a42e461ed586ef0fd31ff911ad662135f4f602aa'
- '8a36a8af89af183e0fa29d9141a1bb4ae9cafd5a')
+ '34758e925f36cabe6167198c9bd11c12b07b2052')
case "$CARCH" in
i686)
@@ -34,7 +34,7 @@ esac
pkgver() {
cd "${srcdir}/vscode"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --match '?.*' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
diff --git a/product_json.patch b/product_json.patch
index eef489b7eb27..1298192c9a60 100644
--- a/product_json.patch
+++ b/product_json.patch
@@ -1,6 +1,6 @@
diff -rupN a/product.json b/product.json
---- a/product.json 2016-08-04 16:50:25.682928390 -0700
-+++ b/product.json 2016-08-04 16:53:41.000000000 -0700
+--- a/product.json 2016-09-05 17:41:16.846929056 -0700
++++ b/product.json 2016-09-05 17:39:51.536137928 -0700
@@ -1,6 +1,6 @@
{
"nameShort": "Code - OSS",
@@ -9,14 +9,14 @@ diff -rupN a/product.json b/product.json
"applicationName": "code-oss",
"dataFolderName": ".vscode-oss",
"win32MutexName": "vscodeoss",
-@@ -11,5 +11,19 @@
- "win32AppId": "{{E34003BB-9E10-4501-8C11-BE3FAA83F23F}",
+@@ -12,5 +12,19 @@
"win32AppUserModelId": "Microsoft.CodeOSS",
"darwinBundleIdentifier": "com.visualstudio.code.oss",
-- "reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new"
+ "reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
+- "urlProtocol": "code-oss"
-}
\ No newline at end of file
-+ "reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
++ "urlProtocol": "code-oss",
+ "welcomePage": "http://go.microsoft.com/fwlink/?LinkId=723048",
+ "quality": "stable",
+ "extensionsGallery": {