summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2018-04-14 10:24:31 -0700
committerMichael Hansen2018-04-14 10:24:31 -0700
commitbcf91426f9ea756654fe0457b259c521f831c664 (patch)
treed855bc1ea185dba7aa45f9dee3f44af6df5f0e04
parent1467834a9bfdf02d0b009a63be6742307a1e3122 (diff)
downloadaur-bcf91426f9ea756654fe0457b259c521f831c664.tar.gz
Update message to show both systemd and non-systemd file limit configs
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 013bb7c48b12..4268782eaf68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,9 +71,13 @@ build() {
echo
echo "*** NOTE: If the build failed due to running out of file handles (EMFILE),"
echo "*** you will need to raise your max open file limit."
- echo "*** This can be done by setting a higher limit in /etc/security/limits.conf,"
- echo "*** rebooting (or logging out and back in), and then running"
- echo "*** 'ulimit -n 10000' (or higher) before re-attempting to build this package."
+ echo "*** This can be done by:"
+ echo "*** 1) Set a higher 'nofile' limit (at least 10000) in either"
+ echo "*** /etc/systemd/system.conf.d/limits.conf (for systemd systems)"
+ echo "*** /etc/security/limits.conf (for non-systemd systems)"
+ echo "*** 2) Reboot (or log out and back in)"
+ echo "*** 3) Run 'ulimit -n' and ensure the value set above is shown before"
+ echo "*** re-attempting to build this package."
echo
exit 1
fi