summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2018-11-12 15:34:11 -0800
committerMichael Hansen2018-11-12 15:34:11 -0800
commitdfd1fda15b1ed28ae57692b342dec13f1132c524 (patch)
tree642eb364f6b0b42242aca753c54a238eb605afcf
parent6df320c1c044d291903054a2d1002ec6e6ae2244 (diff)
downloadaur-dfd1fda15b1ed28ae57692b342dec13f1132c524.tar.gz
Update product.json patches for latest version from git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--code-liveshare.patch14
-rw-r--r--product_json.patch16
4 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc7f527a2058..1bc6bcd82279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-git
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - git latest
- pkgver = 1.16.0.r18592.g02275f047b
+ pkgver = 1.16.0.r19258.g54fb49cdc5
pkgrel = 1
url = https://github.com/Microsoft/vscode
arch = i686
@@ -26,8 +26,8 @@ pkgbase = code-git
sha256sums = SKIP
sha256sums = 64aca444a714dd67da6d5b71ab8d0255e767cb265918d556b3bf8194fca0a7ef
sha256sums = df452e6f64f62081aa4a8da69a071b2c122095eea48dca409a7a851243b9ff36
- sha256sums = 90bd7da0af12f1ecd775ebf300350ed67f9ae08e7ea956269629a275ce05835c
- sha256sums = eb639e59c4075220d42390a165e2eef55c3eaa180050989c346ebcec64a0aca4
+ sha256sums = ab3b08aac7e311d9bf5a0985067f2875bb3a1a0802bfa736489941887a0f05ba
+ sha256sums = 69d5c743fad5466583eba81411792ef5f3cbb6d721de1ebd584ea4a5e2079065
pkgname = code-git
diff --git a/PKGBUILD b/PKGBUILD
index d2607150341f..cdcf83196656 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=code-git
pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - git latest'
-pkgver=1.16.0.r18592.g02275f047b
+pkgver=1.16.0.r19258.g54fb49cdc5
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/Microsoft/vscode'
@@ -22,8 +22,8 @@ source=("git+https://github.com/Microsoft/vscode"
sha256sums=('SKIP'
'64aca444a714dd67da6d5b71ab8d0255e767cb265918d556b3bf8194fca0a7ef'
'df452e6f64f62081aa4a8da69a071b2c122095eea48dca409a7a851243b9ff36'
- '90bd7da0af12f1ecd775ebf300350ed67f9ae08e7ea956269629a275ce05835c'
- 'eb639e59c4075220d42390a165e2eef55c3eaa180050989c346ebcec64a0aca4')
+ 'ab3b08aac7e311d9bf5a0985067f2875bb3a1a0802bfa736489941887a0f05ba'
+ '69d5c743fad5466583eba81411792ef5f3cbb6d721de1ebd584ea4a5e2079065')
case "$CARCH" in
i686)
diff --git a/code-liveshare.patch b/code-liveshare.patch
index eb4cb27955e0..f896ef110e20 100644
--- a/code-liveshare.patch
+++ b/code-liveshare.patch
@@ -1,15 +1,15 @@
diff -rupN a/product.json b/product.json
---- a/product.json 2018-09-13 19:02:44.091846898 -0700
-+++ b/product.json 2018-09-13 19:03:39.132442073 -0700
-@@ -18,6 +18,11 @@
- "darwinBundleIdentifier": "com.visualstudio.code.oss",
+--- a/product.json 2018-11-12 15:11:50.820948673 -0800
++++ b/product.json 2018-11-12 15:12:53.441641156 -0800
+@@ -19,7 +19,10 @@
"reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
"urlProtocol": "code-oss",
-+ "extensionAllowedProposedApi": [
+ "extensionAllowedProposedApi": [
+- "ms-vscode.references-view"
++ "ms-vscode.references-view",
+ "ms-vsliveshare.vsliveshare",
+ "ms-vscode.node-debug",
+ "ms-vscode.node-debug2"
-+ ],
+ ],
"quality": "stable",
"extensionsGallery": {
- "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
diff --git a/product_json.patch b/product_json.patch
index 29ab615b8cd9..6d6bc0d86018 100644
--- a/product_json.patch
+++ b/product_json.patch
@@ -1,12 +1,12 @@
diff -rupN a/product.json b/product.json
---- a/product.json 2018-09-13 18:58:04.308823247 -0700
-+++ b/product.json 2018-09-13 19:02:18.881574329 -0700
-@@ -17,5 +17,15 @@
- "win32ShellNameShort": "C&ode - OSS",
- "darwinBundleIdentifier": "com.visualstudio.code.oss",
- "reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
-- "urlProtocol": "code-oss"
-+ "urlProtocol": "code-oss",
+--- a/product.json 2018-11-12 15:09:13.479207928 -0800
++++ b/product.json 2018-11-12 15:10:06.309792546 -0800
+@@ -20,5 +20,15 @@
+ "urlProtocol": "code-oss",
+ "extensionAllowedProposedApi": [
+ "ms-vscode.references-view"
+- ]
++ ],
+ "quality": "stable",
+ "extensionsGallery": {
+ "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",