summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2019-10-14 14:03:06 -0700
committerMichael Hansen2019-10-14 14:03:06 -0700
commitf84f9b9f9f0e8227864b99726b575d0ddf13dbc3 (patch)
tree38c45f769c49d829307b414a58117de4e49acdeb
parent8f1d4f52cf99ca6b73f04d3a961f5858e23500c5 (diff)
downloadaur-f84f9b9f9f0e8227864b99726b575d0ddf13dbc3.tar.gz
Update to use electron 6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--code-git.sh2
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5df0b97fee57..7b36dda1f496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-git
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - git latest
- pkgver = 1.16.0.r28241.gd50852db1a
+ pkgver = 1.38.0.r1831.g3d3202804b
pkgrel = 1
url = https://github.com/microsoft/vscode
arch = i686
@@ -13,7 +13,7 @@ pkgbase = code-git
makedepends = python2
makedepends = yarn
makedepends = nodejs-lts-dubnium
- depends = electron4
+ depends = electron
depends = libsecret
depends = libx11
depends = libxkbfile
@@ -27,7 +27,7 @@ pkgbase = code-git
source = code-liveshare.diff
sha512sums = SKIP
sha512sums = a97cbc79d76d2dad2ced74d66fa57b9a0aa3d82767d420b520bbaaf007c03ac60d61134668895ab4a8bd38951974c42afc59c03105ccc892742b34fee9b2c509
- sha512sums = 249d6dc3317b996d104c6ab708ae4a63978578fd4f81cbaa2265a44a3b4f07f0c0c166757649aa2943aff8320f2f1614caa95d9c11d7e473a2043476a87d8288
+ sha512sums = 9bd93ec7ba946c005d3a12ea71ae2903593d17d3e4dcf55b4a5b612ebc82237338f0aaec59613eb77f355b0116aeb31320d0d32cd993233f140479ced44dfdbf
sha512sums = 8ec47e497287d67f37e7b669af416f43d5cdbd4574892867d7b95996ef5de53640b5bc919b06b177e1fd91cb005579d6ed0c17325117b9914ba7cf28f5f06e40
sha512sums = 0bd10ca06dea22854e47fc45d833756ee8d7bf714c88f63feef44e0b0b5da052fba3c27d001865e3389f391cd7b888d92dc0ba44029fa5c736225da3cf2f9a46
diff --git a/PKGBUILD b/PKGBUILD
index 29fbbaf106d8..282fdd74a391 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=code-git
pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - git latest'
-pkgver=1.16.0.r28241.gd50852db1a
+pkgver=1.38.0.r1831.g3d3202804b
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/microsoft/vscode'
license=('MIT')
-depends=('electron4' 'libsecret' 'libx11' 'libxkbfile' 'ripgrep')
+depends=('electron' 'libsecret' 'libx11' 'libxkbfile' 'ripgrep')
makedepends=('git' 'gulp' 'npm' 'python2' 'yarn' 'nodejs-lts-dubnium')
conflicts=('visual-studio-code-git')
provides=('visual-studio-code-git')
@@ -21,7 +21,7 @@ source=("git+https://github.com/Microsoft/vscode"
"code-liveshare.diff")
sha512sums=('SKIP'
'a97cbc79d76d2dad2ced74d66fa57b9a0aa3d82767d420b520bbaaf007c03ac60d61134668895ab4a8bd38951974c42afc59c03105ccc892742b34fee9b2c509'
- '249d6dc3317b996d104c6ab708ae4a63978578fd4f81cbaa2265a44a3b4f07f0c0c166757649aa2943aff8320f2f1614caa95d9c11d7e473a2043476a87d8288'
+ '9bd93ec7ba946c005d3a12ea71ae2903593d17d3e4dcf55b4a5b612ebc82237338f0aaec59613eb77f355b0116aeb31320d0d32cd993233f140479ced44dfdbf'
'8ec47e497287d67f37e7b669af416f43d5cdbd4574892867d7b95996ef5de53640b5bc919b06b177e1fd91cb005579d6ed0c17325117b9914ba7cf28f5f06e40'
'0bd10ca06dea22854e47fc45d833756ee8d7bf714c88f63feef44e0b0b5da052fba3c27d001865e3389f391cd7b888d92dc0ba44029fa5c736225da3cf2f9a46')
@@ -42,7 +42,7 @@ case "$CARCH" in
esac
if [ -z "$mem_limit" ]; then
- mem_limit=4096
+ mem_limit=6144
fi
pkgver() {
@@ -67,7 +67,7 @@ prepare() {
patch -p1 -i "${srcdir}/code-liveshare.diff"
# Build native modules for system electron
- local _target=$(</usr/lib/electron4/version)
+ local _target=$(</usr/lib/electron/version)
sed -i "s/^target .*/target \"${_target//v/}\"/" .yarnrc
# Patch appdata and desktop file
@@ -77,6 +77,7 @@ prepare() {
s|@@NAME@@|code-git|g
s|@@ICON@@|code-git|g
s|@@LICENSE@@|MIT|g
+ s|@@URLPROTOCOL@@|vscode|g
s|inode/directory;||' resources/linux/code.{appdata.xml,desktop}
# Fix bin path
diff --git a/code-git.sh b/code-git.sh
index da38c4c476a0..a5525422fe25 100644
--- a/code-git.sh
+++ b/code-git.sh
@@ -1,3 +1,3 @@
#!/bin/bash
-ELECTRON_RUN_AS_NODE=1 exec electron4 /usr/lib/code-git/out/cli.js /usr/lib/code-git/code-git.js "$@"
+ELECTRON_RUN_AS_NODE=1 exec electron /usr/lib/code-git/out/cli.js /usr/lib/code-git/code-git.js "$@"