summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2025-01-17 10:54:53 +0100
committerUffe Jakobsen2025-01-17 10:54:53 +0100
commit3a43ae7a8152d1050257ca4968042a51d4f3790d (patch)
tree2ee9cbc3efbbfbbb8c8892fb53edb1e848a13fbf
parentd3fc87873c5d28cb0392bed07f3baee8144fa659 (diff)
downloadaur-codelite-git.tar.gz
Refresh patch
-rw-r--r--codelite-fsw-symlink.patch234
1 files changed, 10 insertions, 224 deletions
diff --git a/codelite-fsw-symlink.patch b/codelite-fsw-symlink.patch
index af86e312901c..7241de0c7dfa 100644
--- a/codelite-fsw-symlink.patch
+++ b/codelite-fsw-symlink.patch
@@ -1,227 +1,13 @@
-diff --git CodeLite/CMakeLists.txt CodeLite/CMakeLists.txt
-index 33243ea84..6fdb06be9 100644
---- CodeLite/CMakeLists.txt
-+++ CodeLite/CMakeLists.txt
-@@ -33,6 +33,8 @@ target_include_directories(
- libcodelite
- PUBLIC "${CL_SRC_ROOT}/sdk/wxsqlite3/include" "${CL_SRC_ROOT}/CodeLite" "${CL_SRC_ROOT}/CodeLite/ssh"
- "${CL_SRC_ROOT}/PCH"
-+ "${CL_SRC_ROOT}/Interfaces"
-+ "${CL_SRC_ROOT}/Plugin"
- PRIVATE "${CL_SRC_ROOT}/submodules/asio/asio/include" "${CL_SRC_ROOT}/submodules/websocketpp")
- # Macros
- if(WIN32)
-diff --git CodeLite/clFilesCollector.cpp CodeLite/clFilesCollector.cpp
-index 9ac968545..bdaa006f4 100644
---- CodeLite/clFilesCollector.cpp
-+++ CodeLite/clFilesCollector.cpp
-@@ -2,6 +2,7 @@
-
- #include "file_logger.h"
- #include "fileutils.h"
-+#include "globals.h"
-
- #include <queue>
- #include <unordered_set>
-@@ -110,19 +111,19 @@ size_t clFilesScanner::Scan(const wxString& rootFolder, std::vector<wxString>& f
- filename.MakeLower();
- #endif
- bool isDirectory = wxFileName::DirExists(fullpath);
-- // Use FileUtils::RealPath() here to cope with symlinks on Linux
-+ // Use CLRealPath() here to cope with symlinks on Linux
- bool isExcludeDir =
- isDirectory &&
- (
- #if defined(__FreeBSD__)
-- ((FileUtils::IsSymlink(fullpath) && excludeFolders.count(FileUtils::RealPath(fullpath)))
-+ ((FileUtils::IsSymlink(fullpath) && excludeFolders.count(CLRealPath(fullpath)))
- #else
-- (excludeFolders.count(FileUtils::RealPath(fullpath))
-+ (excludeFolders.count(CLRealPath(fullpath))
- #endif
- || IsRelPathContainedInSpec(rootFolder, fullpath, excludeFolders)));
- if (isDirectory && !isExcludeDir) {
- // Traverse into this folder
-- wxString realPath = FileUtils::RealPath(fullpath);
-+ wxString realPath = CLRealPath(fullpath);
- if (Visited.insert(realPath).second) {
- Q.push(fullpath);
- }
-@@ -153,8 +154,8 @@ size_t clFilesScanner::Scan(const wxString& rootFolder, const wxString& filespec
- std::queue<wxString> Q;
- std::unordered_set<wxString> Visited;
-
-- Q.push(FileUtils::RealPath(rootFolder));
-- Visited.insert(FileUtils::RealPath(rootFolder));
-+ Q.push(CLRealPath(rootFolder));
-+ Visited.insert(CLRealPath(rootFolder));
-
- size_t nCount = 0;
- while (!Q.empty()) {
-@@ -174,11 +175,11 @@ size_t clFilesScanner::Scan(const wxString& rootFolder, const wxString& filespec
- fullpath << dir.GetNameWithSep() << filename;
- bool isDirectory = wxFileName::DirExists(fullpath);
- bool isFile = !isDirectory;
-- // Use FileUtils::RealPath() here to cope with symlinks on Linux
-+ // Use CLRealPath() here to cope with symlinks on Linux
- if (isDirectory /* a folder */ &&
- !FileUtils::WildMatch(excludeFoldersSpecArr, filename) /* does not match the exclude folder spec */) {
- // Traverse into this folder
-- wxString real_path = FileUtils::RealPath(fullpath);
-+ wxString real_path = CLRealPath(fullpath);
- if (Visited.count(real_path) == 0) {
- Visited.insert(real_path);
- Q.push(fullpath);
-@@ -259,8 +260,8 @@ void clFilesScanner::ScanWithCallbacks(const wxString& rootFolder, std::function
- std::vector<wxString> Q;
- std::unordered_set<wxString> Visited;
-
-- Q.push_back(FileUtils::RealPath(rootFolder));
-- Visited.insert(FileUtils::RealPath(rootFolder));
-+ Q.push_back(CLRealPath(rootFolder));
-+ Visited.insert(CLRealPath(rootFolder));
-
- while (!Q.empty()) {
- wxString dirpath = Q.front();
-@@ -299,7 +300,7 @@ void clFilesScanner::ScanWithCallbacks(const wxString& rootFolder, std::function
-
- if (on_folder_cb && on_folder_cb(fullpath)) {
- // Traverse into this folder
-- wxString real_path = FileUtils::RealPath(fullpath);
-+ wxString real_path = CLRealPath(fullpath);
- if (Visited.insert(real_path).second) {
- Q.push_back(fullpath);
- }
-diff --git LiteEditor/mainbook.cpp LiteEditor/mainbook.cpp
-index 6db5cb238..b5e7566f0 100644
---- LiteEditor/mainbook.cpp
-+++ LiteEditor/mainbook.cpp
-@@ -451,7 +451,7 @@ int MainBook::FindEditorIndexByFullPath(const wxString& fullpath)
- {
- #ifdef __WXGTK__
- // On gtk either fileName or the editor filepath (or both) may be (or their paths contain) symlinks
-- wxString fileNameDest = CLRealPath(fullpath);
-+ wxString fileNameDest = CLRealPath(fullpath, true);
- #endif
-
- for (size_t i = 0; i < m_book->GetPageCount(); ++i) {
-@@ -485,7 +485,7 @@ int MainBook::FindEditorIndexByFullPath(const wxString& fullpath)
-
- #if defined(__WXGTK__)
- // Try again, dereferencing the editor fpath
-- wxString editorDest = CLRealPath(unixStyleFile);
-+ wxString editorDest = CLRealPath(unixStyleFile, true);
- if (editorDest.Cmp(fullpath) == 0 || editorDest.Cmp(fileNameDest) == 0) {
- return i;
- }
-@@ -513,8 +513,9 @@ wxWindow* MainBook::FindPage(const wxString& text)
- return editor;
- }
-
-- if (m_book->GetPageText(i) == text)
-+ if (m_book->GetPageText(i) == text) {
- return m_book->GetPage(i);
-+ }
+diff --git Plugin/macromanager.cpp Plugin/macromanager.cpp
+index a9fe02969..b38b2ee5f 100644
+--- Plugin/macromanager.cpp
++++ Plugin/macromanager.cpp
+@@ -256,7 +256,7 @@ wxString MacroManager::DoExpand(const wxString& expression, IManager* manager, c
+ wspName = clWorkspaceManager::Get().GetWorkspace()->GetName();
}
- return NULL;
- }
-@@ -621,6 +622,13 @@ clEditor* MainBook::OpenFile(const wxString& file_name,
- const wxString& tooltip /* wxEmptyString */)
- {
- wxFileName fileName(CLRealPath(file_name));
-+
-+ if (fileName.IsRelative()) {
-+ if (clWorkspaceManager::Get().IsWorkspaceOpened()) {
-+ wxFileName wsPath = clWorkspaceManager::Get().GetWorkspace()->GetDir();
-+ fileName.MakeAbsolute(wsPath.GetFullPath());
-+ }
-+ }
- fileName.MakeAbsolute();
-
- #ifdef __WXMSW__
-@@ -1737,7 +1745,7 @@ WelcomePage* MainBook::GetWelcomePage(bool createIfMissing)
-
- clEditor* MainBook::OpenFileAsync(const wxString& file_name, std::function<void(IEditor*)>&& callback)
- {
-- wxString real_path = CLRealPath(file_name);
-+ wxString real_path = CLRealPath(file_name, true);
- auto editor = FindEditor(real_path);
- if (editor) {
- push_callback(std::move(callback), real_path);
-@@ -1748,7 +1756,7 @@ clEditor* MainBook::OpenFileAsync(const wxString& file_name, std::function<void(
- m_book->SetSelection(index);
- }
- } else {
-- editor = OpenFile(real_path);
-+ editor = OpenFile(file_name);
- if (editor) {
- push_callback(std::move(callback), real_path);
- }
-@@ -1813,11 +1821,12 @@ void MainBook::OnIdle(wxIdleEvent& event)
- auto editor = GetActiveEditor();
- CHECK_PTR_RET(editor);
-
-- execute_callbacks_for_file(CLRealPath(editor->GetFileName().GetFullPath()));
-+ execute_callbacks_for_file(CLRealPath(editor->GetFileName().GetFullPath(), true));
- }
-
- void MainBook::OnEditorModified(clCommandEvent& event) { event.Skip(); }
-
- void MainBook::OnEditorSaved(clCommandEvent& event) { event.Skip(); }
-
--void MainBook::OnSessionLoaded(clCommandEvent& event) { event.Skip(); }
-\ No newline at end of file
-+void MainBook::OnSessionLoaded(clCommandEvent& event) { event.Skip(); }
-+
-diff --git Plugin/globals.cpp Plugin/globals.cpp
-index 100970911..6e336cb94 100644
---- Plugin/globals.cpp
-+++ Plugin/globals.cpp
-@@ -104,6 +104,8 @@
- #include "SFTPBrowserDlg.h"
- #endif
-
-+static const char* pEnv_CL_RealPath = getenv("CL_REALPATH");
-+
- const wxEventType wxEVT_COMMAND_CL_INTERNAL_0_ARGS = ::wxNewEventType();
- const wxEventType wxEVT_COMMAND_CL_INTERNAL_1_ARGS = ::wxNewEventType();
-
-@@ -928,7 +930,7 @@ wxFileName wxReadLink(const wxFileName& filename)
- if (wxIsFileSymlink(filename)) {
- #if defined(__WXGTK__)
- // Use 'realpath' on Linux, otherwise this breaks on relative symlinks, and (untested) on symlinks-to-symlinks
-- return wxFileName(CLRealPath(filename.GetFullPath()));
-+ return wxFileName(CLRealPath(filename.GetFullPath(), true));
-
- #else // OSX
- wxFileName realFileName;
-@@ -948,10 +950,14 @@ wxFileName wxReadLink(const wxFileName& filename)
- #endif
- }
-
--wxString CLRealPath(const wxString& filepath) // This is readlink on steroids: it also makes-absolute, and dereferences
-+wxString CLRealPath(const wxString& filepath, bool force) // This is readlink on steroids: it also makes-absolute, and dereferences
- // any symlinked dirs in the path
- {
-- return FileUtils::RealPath(filepath);
-+ if (force || pEnv_CL_RealPath) {
-+ return FileUtils::RealPath(filepath);
-+ } else {
-+ return filepath;
-+ }
- }
- int wxStringToInt(const wxString& str, int defval, int minval, int maxval)
-diff --git Plugin/globals.h Plugin/globals.h
-index 3748406c9..19383391d 100644
---- Plugin/globals.h
-+++ Plugin/globals.h
-@@ -336,7 +336,7 @@ WXDLLIMPEXP_SDK wxFileName wxReadLink(const wxFileName& filename);
- /**
- * @brief makes-absolute filepath, and dereferences it and any symlinked dirs in the path
- */
--WXDLLIMPEXP_SDK wxString CLRealPath(const wxString& filepath);
-+WXDLLIMPEXP_SDK wxString CLRealPath(const wxString& filepath, bool force=false);
+- wxString wspRealPath = FileUtils::RealPath(wspPath);
++ wxString wspRealPath = FileUtils::RealPath(wspPath, true);
- /**
- * @brief convert string to integer using range validation and default value
+ size_t retries = 0;
+ wxString dummyname, dummfullname;