summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilydjwg2024-05-09 11:41:34 +0800
committerlilydjwg2024-05-09 11:41:34 +0800
commit4d564208ee1ff0e96b12bcf53cb6d1af0e858dc7 (patch)
treee9c41edc4e8a74181ed1b100bd0508571c4d122c
parent399d26c15c686fc268e4545e16367683d654b55e (diff)
downloadaur-collectd.tar.gz
fix nut plugin build
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ee27e3b2d29..1ebdf9645938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,6 +59,8 @@ prepare() {
build() {
cd ${pkgname}-${pkgver}
+ # fix nut plugin build
+ export CFLAGS="$CFLAGS -Wno-incompatible-pointer-types"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -67,7 +69,7 @@ build() {
--disable-werror \
--with-perl-bindings='INSTALLDIRS=vendor' \
- make all
+ make all V=1
}
package() {