summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-15 13:11:09 -0800
committerxiota2023-11-15 13:11:09 -0800
commit19b7ea1e7399eab5aa319b0d0ab0f2c608ca8c73 (patch)
tree5bf55ffbab811af8d2bd098dd3ec18279f993d9a
parentb0a6a20a120afe9ae6e2a1376e05812a8f3b834f (diff)
downloadaur-corepdf-git.tar.gz
4.5.0.r0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD64
3 files changed, 58 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe901848bebb..f4881f78821f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = corepdf-git
- pkgdesc = A PDF viewer from the CoreApps family.
- pkgver = 2.8.0.r1.96ed219
+ pkgdesc = A PDF viewer from the C Suite
+ pkgver = 4.5.0.r0.g6b0653a
pkgrel = 1
- url = https://gitlab.com/cubocore
- arch = any
- groups = coreapps-git
+ url = https://gitlab.com/cubocore/coreapps/corepdf
+ arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = git
- depends = libcprime-git
+ makedepends = cmake
+ depends = libcprime
depends = poppler-qt5
- provides = corepdf
+ provides = corepdf=4.5.0
conflicts = corepdf
- source = git+https://gitlab.com/cubocore/corepdf.git
+ source = corepdf::git+https://gitlab.com/cubocore/coreapps/corepdf.git
md5sums = SKIP
pkgname = corepdf-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 77e726bec81e..576dd9e43a94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,57 @@
-_pkgname=corepdf
-pkgname=${_pkgname}-git
-pkgver=2.8.0.r1.96ed219
+# Maintainer:
+
+_pkgname="corepdf"
+pkgname="$_pkgname-git"
+pkgver=4.5.0.r0.g6b0653a
pkgrel=1
-pkgdesc="A PDF viewer from the CoreApps family."
-arch=('any')
-url="https://gitlab.com/cubocore"
+pkgdesc="A PDF viewer from the C Suite"
+url="https://gitlab.com/cubocore/coreapps/corepdf"
license=('GPL3')
-depends=('libcprime-git' 'poppler-qt5')
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-groups=('coreapps-git')
-source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+arch=('x86_64' 'aarch64')
+
+depends=(
+ libcprime
+ poppler-qt5
+)
+makedepends=(
+ git
+ cmake
+)
+
+provides=("$_pkgname=${pkgver%%.r*}")
+conflicts=("$_pkgname")
+
+_pkgsrc="$_pkgname"
+source=("$_pkgsrc"::"git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${_pkgname}"
- printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$_pkgsrc"
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
+pkgver() (
+ cd "$_pkgsrc"
+ local _pkgver=$(
+ git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' 2>/dev/null \
+ | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ )
+
+ echo "${_pkgver:?}"
+)
+
build() {
- cd "$srcdir/${_pkgname}"
- qmake-qt5 ${_pkgname}.pro
- make
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -Wno-dev
+ )
+
+ cmake "${_cmake_options[@]}"
+ cmake --build build
}
package() {
- cd "$srcdir/${_pkgname}"
- make INSTALL_ROOT=${pkgdir} install
+ DESTDIR="${pkgdir:?}" cmake --install build
}