summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4881f78821f..5541a7f033a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = corepdf-git
pkgdesc = A PDF viewer from the C Suite
- pkgver = 4.5.0.r0.g6b0653a
+ pkgver = 4.5.0.r10.g8a42dc9
pkgrel = 1
url = https://gitlab.com/cubocore/coreapps/corepdf
arch = x86_64
arch = aarch64
- license = GPL3
+ license = GPL-3.0-only
makedepends = git
makedepends = cmake
depends = libcprime
@@ -13,6 +13,6 @@ pkgbase = corepdf-git
provides = corepdf=4.5.0
conflicts = corepdf
source = corepdf::git+https://gitlab.com/cubocore/coreapps/corepdf.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = corepdf-git
diff --git a/PKGBUILD b/PKGBUILD
index 576dd9e43a94..98ecf7643d90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_pkgname="corepdf"
pkgname="$_pkgname-git"
-pkgver=4.5.0.r0.g6b0653a
+pkgver=4.5.0.r10.g8a42dc9
pkgrel=1
pkgdesc="A PDF viewer from the C Suite"
url="https://gitlab.com/cubocore/coreapps/corepdf"
-license=('GPL3')
+license=('GPL-3.0-only')
arch=('x86_64' 'aarch64')
depends=(
@@ -23,23 +23,14 @@ conflicts=("$_pkgname")
_pkgsrc="$_pkgname"
source=("$_pkgsrc"::"git+$url.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgsrc"
- printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' 2> /dev/null \
+ | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
-pkgver() (
- cd "$_pkgsrc"
- local _pkgver=$(
- git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' 2>/dev/null \
- | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
- )
-
- echo "${_pkgver:?}"
-)
-
build() {
local _cmake_options=(
-B build
@@ -53,5 +44,5 @@ build() {
}
package() {
- DESTDIR="${pkgdir:?}" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}