summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregoire Lodi2018-04-08 17:08:08 +0200
committerGregoire Lodi2018-04-08 17:08:08 +0200
commit7cd9e7802f88e2dcbf08022b540c2f1983d9fa61 (patch)
tree71f1f42e6bdfdde6304863a3a9b7b5b600c0c065
downloadaur-decodify.tar.gz
Added decodify
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3691484615ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = decodify
+ pkgdesc = It can detect and decode encoded strings, recursively.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/UltimateHackers/Decodify
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2
+ source = decodify::git+https://github.com/UltimateHackers/Decodify.git
+ md5sums = SKIP
+
+pkgname = decodify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8c2e9a207b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Gregoire Lodi <gregoire.lodi@gmail.com>
+
+pkgname=decodify
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="It can detect and decode encoded strings, recursively."
+arch=("i686" "x86_64")
+url="https://github.com/UltimateHackers/Decodify"
+license=("GPL")
+makedepends=("python2")
+source=("$pkgname"::"git+${url}.git")
+noextract=()
+md5sums=("SKIP")
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm 755 "dcode" "${pkgdir}/usr/bin/decodify"
+}