summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2023-08-08 20:31:09 -0400
committerAllen Wild2023-08-08 20:31:09 -0400
commit0e906f881ce6474509c0c5a3ad1a901a348fd39d (patch)
tree3fdfc6726d72013e92116dc37ed11c891a2391d0
parent7c2b29e0df95ef1f412b08db95f9a685e0b79096 (diff)
downloadaur-dislocker-noruby.tar.gz
version 0.7.3-2: depend on mbedtls2
We need the older version of the library, which is still in [extra] at least. Also remove no-ruby.patch from the AUR repo and fetch it from github, since it's been accepted upstream (but there hasn't been a release yet).
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--no-ruby.patch24
4 files changed, 17 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c649646fc442..5f355cd8da9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dislocker-noruby
pkgdesc = Read/write BitLocker-encrypted volumes (no ruby bindings/dependency)
pkgver = 0.7.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Aorimn/dislocker
arch = i686
arch = x86_64
@@ -9,15 +9,14 @@ pkgbase = dislocker-noruby
makedepends = make
makedepends = cmake
depends = fuse
- depends = mbedtls
+ depends = mbedtls2
optdepends = ntfs-3g: NTFS file system support
provides = dislocker
conflicts = dislocker
conflicts = dislocker-git
- source = https://github.com/Aorimn/dislocker/archive/v0.7.3.tar.gz
- source = no-ruby.patch
+ source = dislocker-noruby-0.7.3.tar.gz::https://github.com/Aorimn/dislocker/archive/v0.7.3.tar.gz
+ source = no-ruby.patch::https://github.com/Aorimn/dislocker/commit/05cd96b1890d3bd4c6ea472edcc2e7b329e4e2e4.patch
sha256sums = 8d5275577c44f2bd87f6e05dd61971a71c0e56a9cbedf000bd38deadd8b6c1e6
- sha256sums = 2ec0b679a914544eda264fb9d2f2c1c618df411b16b9c1605d0ddb12623a340e
+ sha256sums = 6c911d7ba4c66ec1e97f63caed3e84be75188c7ff5fbcf6b834047068aec8952
pkgname = dislocker-noruby
-
diff --git a/.gitignore b/.gitignore
index 2a9e3dd7ab39..f60efa19d9bf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.pkg.tar.*
+/no-ruby.patch
/pkg/
/src/
diff --git a/PKGBUILD b/PKGBUILD
index e1a978aba663..c6ccee9dfc2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,20 @@
_name=dislocker
pkgname=${_name}-noruby
pkgver=0.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Read/write BitLocker-encrypted volumes (no ruby bindings/dependency)"
arch=('i686' 'x86_64')
url="https://github.com/Aorimn/dislocker"
license=('GPL2')
-depends=('fuse' 'mbedtls')
+depends=('fuse' 'mbedtls2')
makedepends=('make' 'cmake')
provides=('dislocker')
conflicts=('dislocker' 'dislocker-git')
optdepends=('ntfs-3g: NTFS file system support')
-source=($url/archive/v$pkgver.tar.gz
- no-ruby.patch)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "no-ruby.patch::${url}/commit/05cd96b1890d3bd4c6ea472edcc2e7b329e4e2e4.patch")
sha256sums=('8d5275577c44f2bd87f6e05dd61971a71c0e56a9cbedf000bd38deadd8b6c1e6'
- '2ec0b679a914544eda264fb9d2f2c1c618df411b16b9c1605d0ddb12623a340e')
+ '6c911d7ba4c66ec1e97f63caed3e84be75188c7ff5fbcf6b834047068aec8952')
prepare() {
cd "$srcdir/$_name-$pkgver"
@@ -28,16 +28,18 @@ prepare() {
build() {
cd "$srcdir/$_name-$pkgver"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S. -Bbuild \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-Dlibdir=/usr/lib \
-DWITH_RUBY=OFF \
- .
- make
+ -DPOLARSSL_INCLUDE_DIRS=/usr/include/mbedtls2 \
+ -DPOLARSSL_LIBRARIES=/usr/lib/mbedtls2/libmbedcrypto.so
+ cmake --build build
}
package() {
cd "$srcdir/$_name-$pkgver"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 README.md ${pkgdir}/usr/share/doc/${_name}/README
install -Dm644 CHANGELOG.md ${pkgdir}/usr/share/doc/${_name}/CHANGELOG
diff --git a/no-ruby.patch b/no-ruby.patch
deleted file mode 100644
index 7766bbc4f631..000000000000
--- a/no-ruby.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- dislocker-0.7.3/src/CMakeLists.txt.orig
-+++ dislocker-0.7.3/src/CMakeLists.txt
-@@ -129,12 +129,15 @@
- return ()
- endif()
-
--find_package (Ruby)
--if(RUBY_FOUND AND RUBY_INCLUDE_DIRS AND RUBY_LIBRARY)
-- include_directories (${RUBY_INCLUDE_DIRS})
-- set (LIB ${LIB} ${RUBY_LIBRARY})
-- add_definitions (-D_HAVE_RUBY=${RUBY_VERSION_STRING})
-- set (SOURCES ${SOURCES} ruby.c)
-+option (WITH_RUBY "Enable Ruby bindings" ON)
-+if (WITH_RUBY)
-+ find_package (Ruby)
-+ if(RUBY_FOUND AND RUBY_INCLUDE_DIRS AND RUBY_LIBRARY)
-+ include_directories (${RUBY_INCLUDE_DIRS})
-+ set (LIB ${LIB} ${RUBY_LIBRARY})
-+ add_definitions (-D_HAVE_RUBY=${RUBY_VERSION_STRING})
-+ set (SOURCES ${SOURCES} ruby.c)
-+ endif()
- endif()
-
- find_package (FUSE)