summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoffeinFlummi2015-08-26 08:20:03 +0200
committerKoffeinFlummi2015-08-26 08:36:20 +0200
commit9422aa554b054304de2565c53d892d500474dea1 (patch)
tree2954f18edb878c4517c2c1a2a18636aaf2cb115e
downloadaur-dunst-service.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
-rw-r--r--dunst.service13
4 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba734c638bd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dunst-service
+ pkgdesc = A systemd service file for Dunst, the notification daemon.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/knopwob/dunst
+ arch = any
+ license = GPL2
+ depends = dunst
+ source = dunst.service
+ sha256sums = 10077cf4cf374fa17ca53a8bf6bc0bb672da6c3ad91f1b3c2d03e07c65506b07
+
+pkgname = dunst-service
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c5134b8b9e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..143e32f39f00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Felix Wiegand <koffeinflummi@gmail.com>
+
+pkgname="dunst-service"
+pkgver=1.0
+pkgrel=1
+pkgdesc="A systemd service file for Dunst, the notification daemon."
+arch=('any')
+url="https://github.com/knopwob/dunst"
+license=('GPL2')
+depends=('dunst')
+source=('dunst.service')
+sha256sums=('10077cf4cf374fa17ca53a8bf6bc0bb672da6c3ad91f1b3c2d03e07c65506b07')
+
+package() {
+ install -Dm644 $srcdir/dunst.service $pkgdir/usr/lib/systemd/system/dunst.service
+}
diff --git a/dunst.service b/dunst.service
new file mode 100644
index 000000000000..819cca69e98f
--- /dev/null
+++ b/dunst.service
@@ -0,0 +1,13 @@
+[Unit]
+Description = lightweight and customizable notification daemon
+Requires = graphical.target
+After = graphical.target
+
+[Service]
+Type = simple
+Restart = always
+RestartSec = 1
+ExecStart = /usr/bin/dunst
+
+[Install]
+WantedBy = user-programs.target