summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2024-04-29 21:26:57 +0200
committerTobias Borgert2024-04-29 21:26:57 +0200
commit10a50c4978efcf6a1c148cc5456abe00af1a6f8a (patch)
treeec0256fb53f02c08718e1370e86b6b63dfdbda1b
parent95e4b81cce706d19cf23026de06351237048672f (diff)
downloadaur-ecal.tar.gz
Update to v5.13.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--termcolor-gcc13.patch21
3 files changed, 7 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91162da294be..d265b64de66f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.12.4
+ pkgver = 5.13.0
pkgrel = 1
url = https://github.com/eclipse-ecal/ecal
arch = x86_64
@@ -25,9 +25,7 @@ pkgbase = ecal
depends = yaml-cpp
backup = etc/ecal/ecal.ini
backup = etc/ecal/ecaltime.ini
- source = ecal-5.12.4.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.12.4/ecal-fat-source.tar.gz
- source = termcolor-gcc13.patch
- sha256sums = 7a535a3f57c3890c6f45281609ac4d1521eb98b30ca169d76b6013265cf29d25
- sha256sums = df919e327f89688914e620a508facee6288528af815df1d581606375ece1a5b9
+ source = ecal-5.13.0.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v5.13.0/ecal-fat-source.tar.gz
+ sha256sums = 42444743f97a4e42b182e2ec0483459a3306a13c46a4af0b7bc113463850f924
pkgname = ecal
diff --git a/PKGBUILD b/PKGBUILD
index 5d82b50a9fb5..c6627108e4b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Borgert <tobias (dot) borgert (at) gmail (dot) com>
pkgname=ecal
-pkgver=5.12.4
+pkgver=5.13.0
pkgrel=1
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
@@ -10,13 +10,12 @@ license=('Apache')
depends=('curl' 'protobuf' 'python' 'python-protobuf' 'qt5-base' 'qwt' 'hdf5' 'yaml-cpp')
makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'patchelf' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=()
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz" "termcolor-gcc13.patch")
-sha256sums=('7a535a3f57c3890c6f45281609ac4d1521eb98b30ca169d76b6013265cf29d25'
- 'df919e327f89688914e620a508facee6288528af815df1d581606375ece1a5b9')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eclipse-ecal/ecal/releases/download/v${pkgver}/ecal-fat-source.tar.gz")
+sha256sums=('42444743f97a4e42b182e2ec0483459a3306a13c46a4af0b7bc113463850f924')
backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
prepare() {
- patch --forward --strip=1 --input="termcolor-gcc13.patch"
+ :
}
build() {
diff --git a/termcolor-gcc13.patch b/termcolor-gcc13.patch
deleted file mode 100644
index b801733735c3..000000000000
--- a/termcolor-gcc13.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Subject: [PATCH] GCC13 compatibility: Explicitly include cstdint
-
-See https://gcc.gnu.org/gcc-13/porting_to.html
----
-Index: ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp
-IDEA additional info:
-Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
-<+>UTF-8
-===================================================================
-diff --git a/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp b/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp
---- a/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp (revision b3cb0f365f8435588df7a6b12a82b2ac5fc1fe95)
-+++ b/ecal/thirdparty/termcolor/include/termcolor/termcolor.hpp (date 1683614533931)
-@@ -13,6 +13,7 @@
- #define TERMCOLOR_HPP_
-
- #include <iostream>
-+#include <cstdint>
-
- // Detect target's platform and set some macros in order to wrap platform
- // specific code this library depends on.
-