aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Schuck2017-12-06 14:28:57 +0100
committerJörg Schuck2017-12-06 14:28:57 +0100
commit500050a67075b27b5d3f74cfc8424fb221e9328e (patch)
tree61fe56cffadf1a6048172625e41725f5c9564dc9
parent087455dff7ee4352eeeb332b65bccc2ca66f5be5 (diff)
downloadaur-500050a67075b27b5d3f74cfc8424fb221e9328e.tar.gz
Versioning.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--makefile_1.6.patch22
3 files changed, 31 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f61545d28c9f..58c6cac17b78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Dec 3 12:09:18 UTC 2017
+# Wed Dec 6 13:28:58 UTC 2017
pkgbase = enchant1.6
pkgdesc = A wrapper library for generic spell checking
pkgver = 1.6.1
@@ -15,7 +15,9 @@ pkgbase = enchant1.6
depends = libvoikko
depends = glib2
source = git+https://github.com/AbiWord/enchant.git#commit=7c0ec265a89808893a692f6205f2555f30198444
+ source = makefile_1.6.patch
sha256sums = SKIP
+ sha256sums = ed2a2be438e6b251a6d512a75936346fcda5f40dbe0967e571e542e4cb611b81
pkgname = enchant1.6
diff --git a/PKGBUILD b/PKGBUILD
index a6c3b915d606..cd21a61107a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,12 @@ license=('LGPL')
depends=('aspell' 'hunspell' 'hspell' 'libvoikko' 'glib2')
makedepends=('git')
_commit=7c0ec265a89808893a692f6205f2555f30198444 # tags/enchant-1-6-1
-source=("git+https://github.com/AbiWord/enchant.git#commit=$_commit")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/AbiWord/enchant.git#commit=$_commit"
+ "makefile_1.6.patch"
+)
+sha256sums=('SKIP'
+ 'ed2a2be438e6b251a6d512a75936346fcda5f40dbe0967e571e542e4cb611b81')
pkgver() {
cd $_pkgname
diff --git a/makefile_1.6.patch b/makefile_1.6.patch
new file mode 100644
index 000000000000..55151c5fc9f7
--- /dev/null
+++ b/makefile_1.6.patch
@@ -0,0 +1,22 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 17cf8c2..9db81f8 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,6 +1,7 @@
+ SUBDIRS=. aspell ispell uspell myspell hspell applespell voikko zemberek
+
+-AM_CPPFLAGS=-I$(top_srcdir) $(ENCHANT_CFLAGS) $(CC_WARN_CFLAGS) -DENCHANT_GLOBAL_MODULE_DIR=\"$(libdir)/enchant\" -DENCHANT_GLOBAL_ORDERING=\"$(datadir)/enchant\" -D_ENCHANT_BUILD=1 -DENCHANT_VERSION_STRING=\"@ENCHANT_MAJOR_VERSION@.@ENCHANT_MINOR_VERSION@.@ENCHANT_MICRO_VERSION@\"
++AM_CPPFLAGS=-I$(top_srcdir) $(ENCHANT_CFLAGS) $(CC_WARN_CFLAGS) -DENCHANT_GLOBAL_MODULE_DIR=\"$(libdir)/enchant1.6\" -DENCHANT_GLOBAL_ORDERING=\"$(datadir)/enchant1.6\"
++-D_ENCHANT_BUILD=1 -DENCHANT_VERSION_STRING=\"@ENCHANT_MAJOR_VERSION@.@ENCHANT_MINOR_VERSION@.@ENCHANT_MICRO_VERSION@\"
+
+ lib_LTLIBRARIES = libenchant.la
+
+@@ -16,7 +17,7 @@ endif
+ libenchant_la_DEPENDENCIES = @ENCHANT_WIN32_RESOURCE@
+ libenchant_la_SOURCES = enchant.c pwl.c enchant.h pwl.h
+
+-libenchant_includedir = $(includedir)/enchant
++libenchant_includedir = $(includedir)/enchant1.6
+ libenchant_include_HEADERS = enchant.h enchant-provider.h enchant++.h
+
+ if WITH_APPLESPELL