aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Schuck2017-12-03 12:19:40 +0100
committerJörg Schuck2017-12-03 12:19:40 +0100
commitf25fa1dc32cccc2d98ee5993ea3ecdcabdeeb679 (patch)
treeffabe3bab20af52d064f9d4b2aaa84f01850826a
downloadaur-f25fa1dc32cccc2d98ee5993ea3ecdcabdeeb679.tar.gz
Initial commit with the original PKGBUILD.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--Gruntfile.js84
-rw-r--r--PKGBUILD42
-rw-r--r--README.md35
-rw-r--r--package-lock.json454
-rw-r--r--package.json37
7 files changed, 674 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c48acc8139a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Dec 3 11:19:41 UTC 2017
+pkgbase = enchant
+ pkgdesc = A wrapper library for generic spell checking
+ pkgver = 1.6.1
+ pkgrel = 2
+ url = https://abiword.github.io/enchant/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = aspell
+ depends = hunspell
+ depends = hspell
+ depends = libvoikko
+ depends = glib2
+ source = git+https://github.com/AbiWord/enchant.git#commit=7c0ec265a89808893a692f6205f2555f30198444
+ sha256sums = SKIP
+
+pkgname = enchant
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d87b1d267ea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+node_modules/*
diff --git a/Gruntfile.js b/Gruntfile.js
new file mode 100644
index 000000000000..452b0b99cf22
--- /dev/null
+++ b/Gruntfile.js
@@ -0,0 +1,84 @@
+'strict-mode';
+module.exports = function (grunt) {
+ var config = {
+ pkg: grunt.file.readJSON("package.json"),
+ gta: {
+ options: {
+ stdout: true,
+ stderr: true,
+ },
+ hook: {
+ // Adjust this git command to only add the files needed.
+ command: 'add package.json README.md .gitignore Gruntfile.js PKGBUILD .SRCINFO',
+ },
+ tag: {
+ command: 'tag v<%= pkg.version %> -sm "Releasing v<%= pkg.version %>"',
+ },
+ archive: {
+ // Adjust this command to only archive what is needed. It currently adds
+ // all files.
+ command: 'archive --format="tar.gz" --prefix="<%= pkg.name %>-v<%= pkg.version %>/" --output="<%= pkg.name %>-v<%= pkg.version %>.tgz" HEAD -- ./',
+ },
+ init: {
+ command: 'init',
+ },
+ origin: {
+ command: 'remote add origin vcs:/~/enchant-aur.git',
+ },
+ },
+ githooks: {
+ all: {
+ // Adjust this hook to execute all needed grunt tasks.
+ 'pre-commit': "shell:hook gta:hook",
+ }
+ },
+ bump: {
+ options: {
+ files: ['package.json'],
+ updateConfigs: ['pkg'],
+ commit: true,
+ commitFiles: ['package.json'],
+ createTag: false,
+ push: false,
+ prereleaseName: 'prev',
+ },
+ },
+ shell:{
+ options: {
+ stderr: false
+ },
+ hook: {
+ command: [
+ 'folder="$(pwd)"',
+ 'gitroot=$(git rev-parse --show-toplevel)',
+ 'cd "${gitroot}"',
+ 'updpkgsums',
+ 'mksrcinfo',
+ 'cd "${folder}"'
+ ].join('&&')
+ },
+ },
+ };
+
+ // Loading the configuration.
+ grunt.initConfig(config);
+
+ // Loading the modules:
+ grunt.loadNpmTasks('grunt-git-them-all');
+ grunt.loadNpmTasks('grunt-githooks');
+ grunt.loadNpmTasks('grunt-bump');
+ grunt.loadNpmTasks('grunt-shell');
+
+ // Registering the default task.
+ grunt.registerTask('default', ['githooks:all']);
+ grunt.registerTask('hooks', ['githooks:all']);
+ grunt.registerTask('init', ['gta:init', 'gta:origin']);
+ grunt.registerTask('archive', ['gta:archive']);
+ grunt.registerTask('release', ['bump:patch', 'gta:tag', 'gta:archive']);
+ grunt.registerTask('releaseminor', ['bump:minor', 'gta:tag', 'gta:archive']);
+ grunt.registerTask('releasemajor', ['bump:major', 'gta:tag', 'gta:archive']);
+ grunt.registerTask('prerelease', ['bump:prerelease', 'gta:tag', 'gta:archive']);
+ grunt.registerTask('prepatch', ['bump:prepatch', 'gta:tag', 'gta:archive']);
+ grunt.registerTask('preminor', ['bump:preminor', 'gta:tag', 'gta:archive']);
+ grunt.registerTask('premajor', ['bump:premajor', 'gta:tag', 'gta:archive']);
+};
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bae480ef5820
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=enchant
+pkgver=1.6.1
+pkgrel=2
+pkgdesc="A wrapper library for generic spell checking"
+arch=('i686' 'x86_64')
+url="https://abiword.github.io/enchant/"
+license=('LGPL')
+depends=('aspell' 'hunspell' 'hspell' 'libvoikko' 'glib2')
+makedepends=('git')
+_commit=7c0ec265a89808893a692f6205f2555f30198444 # tags/enchant-1-6-1
+source=("git+https://github.com/AbiWord/enchant.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^enchant-//;s/-/\./g'
+}
+
+prepare() {
+ cd $pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr \
+ --disable-static \
+ --disable-ispell \
+ --with-myspell-dir=/usr/share/myspell
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5abbe099f54f
--- /dev/null
+++ b/README.md
@@ -0,0 +1,35 @@
+# Enchant Aur
+
+A wrapper library for generic spell checking.
+
+* Uses the following third party elements:
+ * Building the packages is enhanced and partially automated by [grunt][]
+
+## Getting started
+
+The following commands are needed to get a certain degree of automation into
+the process:
+
+* Install npm : **npm Install**
+* Make sure that the Gruntfile.js contains other needed tasks.
+* Only if you start this as a fresh project: Initialize the git environment.
+ This includes adding the defined repository as origin: **grunt init**.
+* Install the grunt hooks into the local repo: **grunt hooks**
+
+## Building the package:
+
+The following commands have you covered:
+* Just building a tar package: grunt archive
+* Tagging the current HEAD commit with the version information from the
+ package.json and archiving it into a tar package:
+ * grunt prerelease : Bumps the version to the next prerelease (prev) version.
+ * grunt prepatch : Bumps the version to the next prerelease patch version (increases the patch number)
+ * grunt preminor: Bumps the version to the next prereleae minor version.
+ * grunt premajor : Bumps the version to the next prerelease major version.
+ * grunt release: Bumps the version to the next proper patch version.
+ * grunt releaseminor: Bumps the version to the next proper minor version.
+ * grunt releasemajor: Bumps the version to the next proper major version.
+
+## Changelog
+
+[Grunt]: http://gruntjs.com/ "Grunt Task Runner"
diff --git a/package-lock.json b/package-lock.json
new file mode 100644
index 000000000000..434ce2748fae
--- /dev/null
+++ b/package-lock.json
@@ -0,0 +1,454 @@
+{
+ "name": "enchant-aur",
+ "version": "1.6.1-2",
+ "lockfileVersion": 1,
+ "requires": true,
+ "dependencies": {
+ "abbrev": {
+ "version": "1.1.1",
+ "resolved": "https://registry.npmjs.org/abbrev/-/abbrev-1.1.1.tgz",
+ "integrity": "sha512-nne9/IiQ/hzIhY6pdDnbBtz7DjPTKrY00P/zvPSm5pOFkl6xuGrGnXn/VtTNNfNtAfZ9/1RtehkszU9qcTii0Q==",
+ "dev": true
+ },
+ "amdefine": {
+ "version": "1.0.1",
+ "resolved": "https://registry.npmjs.org/amdefine/-/amdefine-1.0.1.tgz",
+ "integrity": "sha1-SlKCrBZHKek2Gbz9OtFR+BfOkfU=",
+ "dev": true
+ },
+ "ansi-styles": {
+ "version": "1.0.0",
+ "resolved": "https://registry.npmjs.org/ansi-styles/-/ansi-styles-1.0.0.tgz",
+ "integrity": "sha1-yxAt8cVvUSPquLZ817mAJ6AnkXg=",
+ "dev": true
+ },
+ "argparse": {
+ "version": "0.1.16",
+ "resolved": "https://registry.npmjs.org/argparse/-/argparse-0.1.16.tgz",
+ "integrity": "sha1-z9AeD7uj1srtBJ+9dY1A9lGW9Xw=",
+ "dev": true,
+ "requires": {
+ "underscore": "1.7.0",
+ "underscore.string": "2.4.0"
+ },
+ "dependencies": {
+ "underscore.string": {
+ "version": "2.4.0",
+ "resolved": "https://registry.npmjs.org/underscore.string/-/underscore.string-2.4.0.tgz",
+ "integrity": "sha1-jN2PusTi0uoefi6Al8QvRCKA+Fs=",
+ "dev": true
+ }
+ }
+ },
+ "async": {
+ "version": "0.1.22",
+ "resolved": "https://registry.npmjs.org/async/-/async-0.1.22.tgz",
+ "integrity": "sha1-D8GqoIig4+8Ovi2IMbqw3PiEUGE=",
+ "dev": true
+ },
+ "chalk": {
+ "version": "0.4.0",
+ "resolved": "https://registry.npmjs.org/chalk/-/chalk-0.4.0.tgz",
+ "integrity": "sha1-UZmj3c0MHv4jvAjBsCewYXbgxk8=",
+ "dev": true,
+ "requires": {
+ "ansi-styles": "1.0.0",
+ "has-color": "0.1.7",
+ "strip-ansi": "0.1.1"
+ }
+ },
+ "coffee-script": {
+ "version": "1.3.3",
+ "resolved": "https://registry.npmjs.org/coffee-script/-/coffee-script-1.3.3.tgz",
+ "integrity": "sha1-FQ1rTLUiiUNp7+1qIQHCC8f0pPQ=",
+ "dev": true
+ },
+ "colors": {
+ "version": "0.6.2",
+ "resolved": "https://registry.npmjs.org/colors/-/colors-0.6.2.tgz",
+ "integrity": "sha1-JCP+ZnisDF2uiFLl0OW+CMmXq8w=",
+ "dev": true
+ },
+ "dateformat": {
+ "version": "1.0.2-1.2.3",
+ "resolved": "https://registry.npmjs.org/dateformat/-/dateformat-1.0.2-1.2.3.tgz",
+ "integrity": "sha1-sCIMAt6YYXQztyhRz0fePfLNvuk=",
+ "dev": true
+ },
+ "esprima": {
+ "version": "1.0.4",
+ "resolved": "https://registry.npmjs.org/esprima/-/esprima-1.0.4.tgz",
+ "integrity": "sha1-n1V+CPw7TSbs6d00+Pv0drYlha0=",
+ "dev": true
+ },
+ "eventemitter2": {
+ "version": "0.4.14",
+ "resolved": "https://registry.npmjs.org/eventemitter2/-/eventemitter2-0.4.14.tgz",
+ "integrity": "sha1-j2G3XN4BKy6esoTUVFWDtWQ7Yas=",
+ "dev": true
+ },
+ "exit": {
+ "version": "0.1.2",
+ "resolved": "https://registry.npmjs.org/exit/-/exit-0.1.2.tgz",
+ "integrity": "sha1-BjJjj42HfMghB9MKD/8aF8uhzQw=",
+ "dev": true
+ },
+ "findup-sync": {
+ "version": "0.1.3",
+ "resolved": "https://registry.npmjs.org/findup-sync/-/findup-sync-0.1.3.tgz",
+ "integrity": "sha1-fz56l7gjksZTvwZYm9hRkOk8NoM=",
+ "dev": true,
+ "requires": {
+ "glob": "3.2.11",
+ "lodash": "2.4.2"
+ },
+ "dependencies": {
+ "glob": {
+ "version": "3.2.11",
+ "resolved": "https://registry.npmjs.org/glob/-/glob-3.2.11.tgz",
+ "integrity": "sha1-Spc/Y1uRkPcV0QmH1cAP0oFevj0=",
+ "dev": true,
+ "requires": {
+ "inherits": "2.0.3",
+ "minimatch": "0.3.0"
+ }
+ },
+ "lodash": {
+ "version": "2.4.2",
+ "resolved": "https://registry.npmjs.org/lodash/-/lodash-2.4.2.tgz",
+ "integrity": "sha1-+t2DS5aDBz2hebPq5tnA0VBT9z4=",
+ "dev": true
+ },
+ "minimatch": {
+ "version": "0.3.0",
+ "resolved": "https://registry.npmjs.org/minimatch/-/minimatch-0.3.0.tgz",
+ "integrity": "sha1-J12O2qxPG7MyZHIInnlJyDlGmd0=",
+ "dev": true,
+ "requires": {
+ "lru-cache": "2.7.3",
+ "sigmund": "1.0.1"
+ }
+ }
+ }
+ },
+ "getobject": {
+ "version": "0.1.0",
+ "resolved": "https://registry.npmjs.org/getobject/-/getobject-0.1.0.tgz",
+ "integrity": "sha1-BHpEl4n6Fg0Bj1SG7ZEyC27HiFw=",
+ "dev": true
+ },
+ "glob": {
+ "version": "3.1.21",
+ "resolved": "https://registry.npmjs.org/glob/-/glob-3.1.21.tgz",
+ "integrity": "sha1-0p4KBV3qUTj00H7UDomC6DwgZs0=",
+ "dev": true,
+ "requires": {
+ "graceful-fs": "1.2.3",
+ "inherits": "1.0.2",
+ "minimatch": "0.2.14"
+ },
+ "dependencies": {
+ "inherits": {
+ "version": "1.0.2",
+ "resolved": "https://registry.npmjs.org/inherits/-/inherits-1.0.2.tgz",
+ "integrity": "sha1-ykMJ2t7mtUzAuNJH6NfHoJdb3Js=",
+ "dev": true
+ }
+ }
+ },
+ "graceful-fs": {
+ "version": "1.2.3",
+ "resolved": "https://registry.npmjs.org/graceful-fs/-/graceful-fs-1.2.3.tgz",
+ "integrity": "sha1-FaSAaldUfLLS2/J/QuiajDRRs2Q=",
+ "dev": true
+ },
+ "grunt": {
+ "version": "0.4.5",
+ "resolved": "https://registry.npmjs.org/grunt/-/grunt-0.4.5.tgz",
+ "integrity": "sha1-VpN81RlDJK3/bSB2MYMqnWuk5/A=",
+ "dev": true,
+ "requires": {
+ "async": "0.1.22",
+ "coffee-script": "1.3.3",
+ "colors": "0.6.2",
+ "dateformat": "1.0.2-1.2.3",
+ "eventemitter2": "0.4.14",
+ "exit": "0.1.2",
+ "findup-sync": "0.1.3",
+ "getobject": "0.1.0",
+ "glob": "3.1.21",
+ "grunt-legacy-log": "0.1.3",
+ "grunt-legacy-util": "0.2.0",
+ "hooker": "0.2.3",
+ "iconv-lite": "0.2.11",
+ "js-yaml": "2.0.5",
+ "lodash": "0.9.2",
+ "minimatch": "0.2.14",
+ "nopt": "1.0.10",
+ "rimraf": "2.2.8",
+ "underscore.string": "2.2.1",
+ "which": "1.0.9"
+ }
+ },
+ "grunt-bump": {
+ "version": "0.6.0",
+ "resolved": "https://registry.npmjs.org/grunt-bump/-/grunt-bump-0.6.0.tgz",
+ "integrity": "sha1-WWYxou597dlhl81YVchgywuQ6Oo=",
+ "dev": true,
+ "requires": {
+ "semver": "4.3.6"
+ }
+ },
+ "grunt-git-them-all": {
+ "version": "0.0.13",
+ "resolved": "https://registry.npmjs.org/grunt-git-them-all/-/grunt-git-them-all-0.0.13.tgz",
+ "integrity": "sha1-2/q7+Juymt5jKT+HK75lAgYqbX8=",
+ "dev": true
+ },
+ "grunt-githooks": {
+ "version": "0.3.1",
+ "resolved": "https://registry.npmjs.org/grunt-githooks/-/grunt-githooks-0.3.1.tgz",
+ "integrity": "sha1-CBA/6Z7stQfZW1Uynlg/JKuoW38=",
+ "dev": true,
+ "requires": {
+ "handlebars": "1.0.12"
+ }
+ },
+ "grunt-legacy-log": {
+ "version": "0.1.3",
+ "resolved": "https://registry.npmjs.org/grunt-legacy-log/-/grunt-legacy-log-0.1.3.tgz",
+ "integrity": "sha1-7ClCboAwIa9ZAp+H0vnNczWgVTE=",
+ "dev": true,
+ "requires": {
+ "colors": "0.6.2",
+ "grunt-legacy-log-utils": "0.1.1",
+ "hooker": "0.2.3",
+ "lodash": "2.4.2",
+ "underscore.string": "2.3.3"
+ },
+ "dependencies": {
+ "lodash": {
+ "version": "2.4.2",
+ "resolved": "https://registry.npmjs.org/lodash/-/lodash-2.4.2.tgz",
+ "integrity": "sha1-+t2DS5aDBz2hebPq5tnA0VBT9z4=",
+ "dev": true
+ },
+ "underscore.string": {
+ "version": "2.3.3",
+ "resolved": "https://registry.npmjs.org/underscore.string/-/underscore.string-2.3.3.tgz",
+ "integrity": "sha1-ccCL9rQosRM/N+ePo6Icgvcymw0=",
+ "dev": true
+ }
+ }
+ },
+ "grunt-legacy-log-utils": {
+ "version": "0.1.1",
+ "resolved": "https://registry.npmjs.org/grunt-legacy-log-utils/-/grunt-legacy-log-utils-0.1.1.tgz",
+ "integrity": "sha1-wHBrndkGThFvNvI/5OawSGcsD34=",
+ "dev": true,
+ "requires": {
+ "colors": "0.6.2",
+ "lodash": "2.4.2",
+ "underscore.string": "2.3.3"
+ },
+ "dependencies": {
+ "lodash": {
+ "version": "2.4.2",
+ "resolved": "https://registry.npmjs.org/lodash/-/lodash-2.4.2.tgz",
+ "integrity": "sha1-+t2DS5aDBz2hebPq5tnA0VBT9z4=",
+ "dev": true
+ },
+ "underscore.string": {
+ "version": "2.3.3",
+ "resolved": "https://registry.npmjs.org/underscore.string/-/underscore.string-2.3.3.tgz",
+ "integrity": "sha1-ccCL9rQosRM/N+ePo6Icgvcymw0=",
+ "dev": true
+ }
+ }
+ },
+ "grunt-legacy-util": {
+ "version": "0.2.0",
+ "resolved": "https://registry.npmjs.org/grunt-legacy-util/-/grunt-legacy-util-0.2.0.tgz",
+ "integrity": "sha1-kzJIhNv343qf98Am3/RR2UqeVUs=",
+ "dev": true,
+ "requires": {
+ "async": "0.1.22",
+ "exit": "0.1.2",
+ "getobject": "0.1.0",
+ "hooker": "0.2.3",
+ "lodash": "0.9.2",
+ "underscore.string": "2.2.1",
+ "which": "1.0.9"
+ }
+ },
+ "grunt-shell": {
+ "version": "0.7.0",
+ "resolved": "https://registry.npmjs.org/grunt-shell/-/grunt-shell-0.7.0.tgz",
+ "integrity": "sha1-K3HlTuXlZTfTTsBr+ZfAbOW000s=",
+ "dev": true,
+ "requires": {
+ "chalk": "0.4.0"
+ }
+ },
+ "handlebars": {
+ "version": "1.0.12",
+ "resolved": "https://registry.npmjs.org/handlebars/-/handlebars-1.0.12.tgz",
+ "integrity": "sha1-GMbTRAw16RsZs/9YK5FRq0mF1Pw=",
+ "dev": true,
+ "requires": {
+ "optimist": "0.3.7",
+ "uglify-js": "2.3.6"
+ }
+ },
+ "has-color": {
+ "version": "0.1.7",
+ "resolved": "https://registry.npmjs.org/has-color/-/has-color-0.1.7.tgz",
+ "integrity": "sha1-ZxRKUmDDT8PMpnfQQdr1L+e3iy8=",
+ "dev": true
+ },
+ "hooker": {
+ "version": "0.2.3",
+ "resolved": "https://registry.npmjs.org/hooker/-/hooker-0.2.3.tgz",
+ "integrity": "sha1-uDT3I8xKJCqmWWNFnfbZhMXT2Vk=",
+ "dev": true
+ },
+ "iconv-lite": {
+ "version": "0.2.11",
+ "resolved": "https://registry.npmjs.org/iconv-lite/-/iconv-lite-0.2.11.tgz",
+ "integrity": "sha1-HOYKOleGSiktEyH/RgnKS7llrcg=",
+ "dev": true
+ },
+ "inherits": {
+ "version": "2.0.3",
+ "resolved": "https://registry.npmjs.org/inherits/-/inherits-2.0.3.tgz",
+ "integrity": "sha1-Yzwsg+PaQqUC9SRmAiSA9CCCYd4=",
+ "dev": true
+ },
+ "js-yaml": {
+ "version": "2.0.5",
+ "resolved": "https://registry.npmjs.org/js-yaml/-/js-yaml-2.0.5.tgz",
+ "integrity": "sha1-olrmUJmZ6X3yeMZxnaEb0Gh3Q6g=",
+ "dev": true,
+ "requires": {
+ "argparse": "0.1.16",
+ "esprima": "1.0.4"
+ }
+ },
+ "lodash": {
+ "version": "0.9.2",
+ "resolved": "https://registry.npmjs.org/lodash/-/lodash-0.9.2.tgz",
+ "integrity": "sha1-jzSZxSRdNG1oLlsNO0B2fgnxqSw=",
+ "dev": true
+ },
+ "lru-cache": {
+ "version": "2.7.3",
+ "resolved": "https://registry.npmjs.org/lru-cache/-/lru-cache-2.7.3.tgz",
+ "integrity": "sha1-bUUk6LlV+V1PW1iFHOId1y+06VI=",
+ "dev": true
+ },
+ "minimatch": {
+ "version": "0.2.14",
+ "resolved": "https://registry.npmjs.org/minimatch/-/minimatch-0.2.14.tgz",
+ "integrity": "sha1-x054BXT2PG+aCQ6Q775u9TpqdWo=",
+ "dev": true,
+ "requires": {
+ "lru-cache": "2.7.3",
+ "sigmund": "1.0.1"
+ }
+ },
+ "nopt": {
+ "version": "1.0.10",
+ "resolved": "https://registry.npmjs.org/nopt/-/nopt-1.0.10.tgz",
+ "integrity": "sha1-bd0hvSoxQXuScn3Vhfim83YI6+4=",
+ "dev": true,
+ "requires": {
+ "abbrev": "1.1.1"
+ }
+ },
+ "optimist": {
+ "version": "0.3.7",
+ "resolved": "https://registry.npmjs.org/optimist/-/optimist-0.3.7.tgz",
+ "integrity": "sha1-yQlBrVnkJzMokjB00s8ufLxuwNk=",
+ "dev": true,
+ "requires": {
+ "wordwrap": "0.0.3"
+ }
+ },
+ "rimraf": {
+ "version": "2.2.8",
+ "resolved": "https://registry.npmjs.org/rimraf/-/rimraf-2.2.8.tgz",
+ "integrity": "sha1-5Dm+Kq7jJzIZUnMPmaiSnk/FBYI=",
+ "dev": true
+ },
+ "semver": {
+ "version": "4.3.6",
+ "resolved": "https://registry.npmjs.org/semver/-/semver-4.3.6.tgz",
+ "integrity": "sha1-MAvG4OhjdPe6YQaLWx7NV/xlMto=",
+ "dev": true
+ },
+ "sigmund": {
+ "version": "1.0.1",
+ "resolved": "https://registry.npmjs.org/sigmund/-/sigmund-1.0.1.tgz",
+ "integrity": "sha1-P/IfGYytIXX587eBhT/ZTQ0ZtZA=",
+ "dev": true
+ },
+ "source-map": {
+ "version": "0.1.43",
+ "resolved": "https://registry.npmjs.org/source-map/-/source-map-0.1.43.tgz",
+ "integrity": "sha1-wkvBRspRfBRx9drL4lcbK3+eM0Y=",
+ "dev": true,
+ "requires": {
+ "amdefine": "1.0.1"
+ }
+ },
+ "strip-ansi": {
+ "version": "0.1.1",
+ "resolved": "https://registry.npmjs.org/strip-ansi/-/strip-ansi-0.1.1.tgz",
+ "integrity": "sha1-OeipjQRNFQZgq+SmgIrPcLt7yZE=",
+ "dev": true
+ },
+ "uglify-js": {
+ "version": "2.3.6",
+ "resolved": "https://registry.npmjs.org/uglify-js/-/uglify-js-2.3.6.tgz",
+ "integrity": "sha1-+gmEdwtCi3qbKoBY9GNV0U/vIRo=",
+ "dev": true,
+ "requires": {
+ "async": "0.2.10",
+ "optimist": "0.3.7",
+ "source-map": "0.1.43"
+ },
+ "dependencies": {
+ "async": {
+ "version": "0.2.10",
+ "resolved": "https://registry.npmjs.org/async/-/async-0.2.10.tgz",
+ "integrity": "sha1-trvgsGdLnXGXCMo43owjfLUmw9E=",
+ "dev": true
+ }
+ }
+ },
+ "underscore": {
+ "version": "1.7.0",
+ "resolved": "https://registry.npmjs.org/underscore/-/underscore-1.7.0.tgz",
+ "integrity": "sha1-a7rwh3UA02vjTsqlhODbn+8DUgk=",
+ "dev": true
+ },
+ "underscore.string": {
+ "version": "2.2.1",
+ "resolved": "https://registry.npmjs.org/underscore.string/-/underscore.string-2.2.1.tgz",
+ "integrity": "sha1-18D6KvXVoaZ/QlPa7pgTLnM/Dxk=",
+ "dev": true
+ },
+ "which": {
+ "version": "1.0.9",
+ "resolved": "https://registry.npmjs.org/which/-/which-1.0.9.tgz",
+ "integrity": "sha1-RgwdoPgQED0DIam2M6+eV15kSG8=",
+ "dev": true
+ },
+ "wordwrap": {
+ "version": "0.0.3",
+ "resolved": "https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz",
+ "integrity": "sha1-o9XabNXAvAAI03I0u68b7WMFkQc=",
+ "dev": true
+ }
+ }
+}
diff --git a/package.json b/package.json
new file mode 100644
index 000000000000..f26dd1dbf2c8
--- /dev/null
+++ b/package.json
@@ -0,0 +1,37 @@
+{
+ "name": "enchant-aur",
+ "description": "A wrapper library for generic spell checking.",
+ "version": "1.6.1-2",
+ "homepage": "http://www.thedarkestcave.net/",
+ "author": {
+ "name": "Jörg Schuck",
+ "email": "joerg_schuck@web.de",
+ "url": "http://www.thedarkestcave.net/"
+ },
+ "repository": {
+ "type": "git",
+ "url": "vcs:/~/enchant-aur.git"
+ },
+ "bugs": {
+ "url": ""
+ },
+ "licenses": [
+ {
+ "type": "BSD",
+ "url": "http://www.thedarkestcave.net//blob/master/LICENSE-BSD"
+ }
+ ],
+ "engines": {
+ "node": ">= 0.8.0"
+ },
+ "scripts": {
+ "test": "grunt qunit"
+ },
+ "devDependencies": {
+ "grunt": "^0.4.5",
+ "grunt-bump": "^0.6.0",
+ "grunt-git-them-all": "^0.0.13",
+ "grunt-githooks": "^0.3.1",
+ "grunt-shell": "^0.7.0"
+ }
+}