summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2021-08-26 13:21:34 +0200
committerJoan Figueras2021-08-26 13:22:01 +0200
commit0c98b1dc61b996cbcbb86f54392661ed88183ade (patch)
tree0cfc418c6dc9d5759fd5781c5cc3fe6409394b0b
parentc25ff9f165b22de46a1a6fa507dc65e4a3f6cb06 (diff)
downloadaur-epson-perfection-v10-v100-scanner-driver-aio.tar.gz
Added epkowa.conf
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--epkowa.conf65
-rw-r--r--gt-s600.install5
4 files changed, 77 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 348c4505159f..0066997c82f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,8 @@ pkgbase = epson-perfection-v10-v100-scanner-driver-aio
conflicts = iscan-for-epson-v500-photo
conflicts = iscan-plugin-gt-s600
source = https://download2.ebz.epson.net/iscan/plugin/gt-s600/rpm/x64/iscan-gt-s600-bundle-2.30.4.x64.rpm.tar.gz
+ source = epkowa.conf
sha256sums = fe1356b1d5c40bc5ac985a5693166efb9e5049a78b412f49c385eb503eadf2c6
+ sha256sums = bdf3a9cf12f3f5c1ab2daceb801a4e334490a645a95eb5b7ec69cdc59e55a0e0
pkgname = epson-perfection-v10-v100-scanner-driver-aio
diff --git a/PKGBUILD b/PKGBUILD
index ba5de35e1673..608fb6a288bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,9 @@ license=('custom:AVASYS')
install=gt-s600.install
provides=("iscan" "iscan-for-epson-v500-photo" "iscan-plugin-gt-s600")
conflicts=("iscan" "iscan-for-epson-v500-photo" "iscan-plugin-gt-s600")
-source=("https://download2.ebz.epson.net/iscan/plugin/gt-s600/rpm/x64/iscan-gt-s600-bundle-${pkgver}.x64.rpm.tar.gz")
-sha256sums=('fe1356b1d5c40bc5ac985a5693166efb9e5049a78b412f49c385eb503eadf2c6')
+source=("https://download2.ebz.epson.net/iscan/plugin/gt-s600/rpm/x64/iscan-gt-s600-bundle-${pkgver}.x64.rpm.tar.gz" epkowa.conf)
+sha256sums=('fe1356b1d5c40bc5ac985a5693166efb9e5049a78b412f49c385eb503eadf2c6'
+ 'bdf3a9cf12f3f5c1ab2daceb801a4e334490a645a95eb5b7ec69cdc59e55a0e0')
package() {
cd "$srcdir"
@@ -30,6 +31,8 @@ package() {
mv -v "$pkgdir"/usr/sbin/* "$pkgdir"/usr/bin
rmdir "$pkgdir"/usr/sbin
+ install -m 644 -D ../epkowa.conf "$pkgdir"/etc/sane.d/epkowa.conf
+
install -m 644 -D \
"$pkgdir"/usr/share/doc/iscan-plugin-gt-s600-${_plugin%-*}/COPYING.EPSON.en.txt \
"$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
diff --git a/epkowa.conf b/epkowa.conf
new file mode 100644
index 000000000000..2bdda713de5b
--- /dev/null
+++ b/epkowa.conf
@@ -0,0 +1,65 @@
+# epkowa.conf -- sample configuration for the EPKOWA SANE backend
+# Copyright (C) 2004, 2008, 2009 Olaf Meeuwissen
+#
+# See sane-epkowa(5), sane-usb(5) and sane-scsi(5) for details.
+
+# Detect all devices supported by the backend.
+# If you don't have a SCSI device, you can comment out the "scsi"
+# keyword. Similarly for the other keywords.
+#
+usb
+scsi
+
+
+# For any USB scanner not known to the backend (yet), you may, at your
+# own peril(!!), force the backend to recognise and use it via libusb.
+# You can do so by the following configuration command:
+#
+# usb <USB vendor ID> <USB product ID>
+#
+# SEIKO EPSON's USB vendor ID is '0x04b8' (without quotes). In order
+# to find the USB product ID, use lsusb(1).
+# A sample configuration for the Epson Perfection 1650 (Epson GT-8200),
+# which has a product ID of 0x0110, would look as follows:
+#
+#usb 0x04b8 0x0110
+#usb 0x04b8 0x012d
+
+# For SCSI devices not detected, you can add an entry like:
+#
+# scsi EPSON GT-20000
+#
+# where the GT-20000 bit corresponds to the SCSI model information as
+# shown in the output of dmesg(1) or in the /var/log/kern.log file.
+
+
+# Network attached devices may be made to work by first installing the
+# (non-free) iscan-network-nt package and then adding configuration lines
+# as per information below.
+#
+# For each network attached device, you must add an entry as follows:
+#
+# net <IP-address|hostname> [port-number]
+#
+# Ask your network administrator for the device's IP address or check
+# for yourself on the panel (if it has one). The port-number is very
+# optional and defaults to 1865.
+# Note that network attached devices are not queried unless configured
+# in this file.
+#
+# Examples:
+#
+#net 192.16.136.2 1865
+#net 10.0.0.1
+#net scanner.mydomain.com
+
+
+# Some backend behaviour can be customized by using the option keyword
+# followed by an option name, as shown below.
+#
+# option <option-name>
+#
+# Currently available options:
+#
+# Makes the automatic document feeder the default document source
+#option prefer-adf
diff --git a/gt-s600.install b/gt-s600.install
index 9a9966b7b4e3..11f494c51aa6 100644
--- a/gt-s600.install
+++ b/gt-s600.install
@@ -2,6 +2,11 @@ post_install() {
echo "Running iscan-registry to register plugins and firmware with iscan"
iscan-registry -a interpreter usb 0x04b8 0x012d \
/usr/lib/iscan/libesint66 /usr/share/iscan/esfw66.bin
+ echo -e "\nIf your device is not detected, ensure you have 'epkowa' in /etc/sane.d/dll.conf and check udevadm permissions"
+}
+
+post_upgrade() {
+ echo "If your device is not detected, ensure you have 'epkowa' in /etc/sane.d/dll.conf and check udevadm permissions"
}
pre_remove() {