diff options
author | zxp19821005 | 2024-08-22 09:11:18 +0800 |
---|---|---|
committer | zxp19821005 | 2024-08-22 09:11:18 +0800 |
commit | 46b173e5317d6a682cfaa5079a8579b3b7ee6e0d (patch) | |
tree | 174703c921c8ba352dd83288a141677644865cc7 | |
parent | 1a3d25221a8a167add5f0008ab57311b473aa209 (diff) | |
download | aur-eusoft-eshelper-bin.tar.gz |
update to 2024.08.20
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | PKGBUILD | 8 | ||||
-rw-r--r-- | eusoft-eshelper.sh | 4 |
3 files changed, 10 insertions, 10 deletions
@@ -1,6 +1,6 @@ pkgbase = eusoft-eshelper-bin pkgdesc = 西班牙语助手,权威的西班牙语词典软件,西班牙语学习者必备的工具.支持学习笔记、生词本多平台同步,让你随时随地学西班牙语. - pkgver = 2024.02.27 + pkgver = 2024.08.20 pkgrel = 1 url = https://www.esdict.cn/ arch = x86_64 @@ -40,11 +40,11 @@ pkgbase = eusoft-eshelper-bin conflicts = eusoft-eshelper conflicts = eshelper options = !strip - source = eusoft-eshelper-2024.02.27.deb::https://www.eudic.net/download/eshelper.deb?v=2024-02-27 + source = eusoft-eshelper-2024.08.20.deb::https://www.eudic.net/download/eshelper.deb?v=2024-08-20 source = LICENSE.html::https://dict.eudic.net/home/privacy source = eusoft-eshelper.sh sha256sums = 59af3b48c1cda58220e303c479d8244257fb2d7c7be7d229b83f3e8dc23ee358 - sha256sums = 21e001fde21fdd190dd3fd47ca496be4bd945955d96f0987bccf059e5643b344 - sha256sums = 0ed2b777bd6eaf7986a79e6cbf63f067ff135298f9a8c6f8d9eb671b50c5ec86 + sha256sums = 89862f4074e530896863738bf9d49c03c8d0cd0f6a543d4ccc1cdc53e8f83a24 + sha256sums = ad3e35428234bc137bb85f2364bba92e7057a6074f08c17a775274995aaa44d4 pkgname = eusoft-eshelper-bin @@ -1,7 +1,7 @@ # Maintainer: zxp19821005 <zxp19821005 at 163 dot com> _pkgname=eshelper pkgname="eusoft-${_pkgname}-bin" -pkgver=2024.02.27 +pkgver=2024.08.20 pkgrel=1 pkgdesc="西班牙语助手,权威的西班牙语词典软件,西班牙语学习者必备的工具.支持学习笔记、生词本多平台同步,让你随时随地学西班牙语." arch=('x86_64') @@ -52,8 +52,8 @@ source=( "${pkgname%-bin}.sh" ) sha256sums=('59af3b48c1cda58220e303c479d8244257fb2d7c7be7d229b83f3e8dc23ee358' - '21e001fde21fdd190dd3fd47ca496be4bd945955d96f0987bccf059e5643b344' - '0ed2b777bd6eaf7986a79e6cbf63f067ff135298f9a8c6f8d9eb671b50c5ec86') + '89862f4074e530896863738bf9d49c03c8d0cd0f6a543d4ccc1cdc53e8f83a24' + 'ad3e35428234bc137bb85f2364bba92e7057a6074f08c17a775274995aaa44d4') build() { sed -e "s|@appname@|${pkgname%-bin}|g" \ -e "s|@appasar@|${_pkgname}|g" \ @@ -69,4 +69,4 @@ package() { install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications" install -Dm644 "${srcdir}/usr/share/pixmaps/com.eusoft.${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png" install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}" -} +}
\ No newline at end of file diff --git a/eusoft-eshelper.sh b/eusoft-eshelper.sh index 720635da73a6..35ef7f22811f 100644 --- a/eusoft-eshelper.sh +++ b/eusoft-eshelper.sh @@ -1,5 +1,5 @@ -#!/bin/sh -set -e +#!/bin/bash +set -o pipefail _APPDIR="/opt/@appname@" _RUNNAME="${_APPDIR}/@runname@" export PATH="${_APPDIR}:${PATH}" |