summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJernuh Zakalwe2020-08-03 12:33:44 +0200
committerJernuh Zakalwe2020-08-03 12:33:44 +0200
commit8a4b90d1d5554e9674b53d0fbfc86648ea46a42a (patch)
tree1945b293ae39920e3c5b704270e80d113aa8c7f2
parentcc288c84bcb87508c5d370f5ffde29297579962c (diff)
downloadaur-8a4b90d1d5554e9674b53d0fbfc86648ea46a42a.tar.gz
Workaround for error message about missing roots.pem removed.
File roots.pem from evelauncher directory removed because better one error message about missing this file on start of evelauncher instead a bunch of error messages about failed connections to this server later. In both setup scripts recurring messages removed.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rwxr-xr-xbuild_installer.sh13
-rwxr-xr-xbuild_lite_installer.sh17
-rw-r--r--evesetup.install21
-rw-r--r--setup.sh.in29
-rw-r--r--setup_lite.sh.in13
7 files changed, 48 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f14d446ef124..1010e58d4f51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = evesetup
pkgdesc = An inofficial EVE Online Launcher Setup Tool.
pkgver = 1747682
- pkgrel = 3
+ pkgrel = 4
url = https://forums.eveonline.com/t/eve-installing/71494
- install = evesetup.install
arch = x86_64
license = zlib/png
depends = icu
@@ -76,10 +75,10 @@ pkgbase = evesetup
sha256sums = 261da84107168979d241c60cd7adbfee0f6675464675faaefd5f6140009d54d8
sha256sums = 528fc6627e8893db5d7092194e9f3320067f2f1f4593a206aee8a5207956e563
sha256sums = d4610df883778f91e0ea5feba84720dfe814af0b9960677e3861809d70de24b2
- sha256sums = 51eae400033fab0ca0a4a292c9c725dd0da25809d037002130bc1e23fa6c0702
- sha256sums = 617349fb5f7ca9071e7d2465f5c0d1e01ad501edf3c2458a2ebcdca33d38b070
- sha256sums = ce406f8fe7db143a30a4c85cabfeeb0718c2d4521dc7ad2393743bdc9c9c59ec
- sha256sums = 9e88a8eeb2b3a9f2551ab204ee632d1ea03742c57f446ea63c9461c6b927082e
+ sha256sums = cda0f7cf511a527645a8a8f4d041888db34d03372a9a45bdecc2eb19133301b0
+ sha256sums = 18d624c454b452c4d39013c689f8f122774354657a320118601f11df942c15d8
+ sha256sums = 67f4464116d4e20c058f4b2b17dbfc7507cf5c0c626e88516b475efcab6e6233
+ sha256sums = 498f276ed8f7ddc75f3cdd525849ee5ef4c3285789e61250b844c38943dcac04
sha256sums = 69b98d923c08c6fb035c0c6905ec5e9c73273b694f8f3497777d44597dbe63e3
sha256sums = 762db1df07dfcf526fe634b4b589a08e8affefb2f79f02cff2624c70e0820422
sha256sums = 980d68abd6f4a662b69efd19145112e88f349044fa1ed5cb6d0a840a92cb42e4
diff --git a/PKGBUILD b/PKGBUILD
index 7aeb52420638..a41f30100a82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,12 @@
#Maintainer: Jernuh Zakalwe <jzakalwe1st@gmail.com>
pkgname=evesetup
pkgver=1747682
-pkgrel=3
+pkgrel=4
pkgdesc="An inofficial EVE Online Launcher Setup Tool."
arch=(x86_64)
url="https://forums.eveonline.com/t/eve-installing/71494"
license=('zlib/png')
-install=${pkgname}.install
-
depends=('icu'
'openssl'
'openssl-1.0'
@@ -107,9 +105,10 @@ package() {
rm -f ${srcdir}/evelauncher/*[Qq]t* ${srcdir}/evelauncher/libcrypto*
rm -f ${srcdir}/evelauncher/libicu* ${srcdir}/evelauncher/libssl*
rm -f ${srcdir}/evelauncher/libpng* ${srcdir}/evelauncher/libxcb*
+ rm -f ${srcdir}/evelauncher/roots.pem
cp -f ${srcdir}/evelauncher.sh.real ${srcdir}/evelauncher/evelauncher.sh
chmod 0755 ${srcdir}/evelauncher/*
- chmod 0644 ${srcdir}/evelauncher/*.qm ${srcdir}/evelauncher/roots.pem
+ chmod 0644 ${srcdir}/evelauncher/*.qm
chmod 0644 ${srcdir}/evelauncher/errorpage/*
ln -sf evelauncher.sh ${srcdir}/evelauncher/LogLite.sh
ln -sf libgpr.so.6.0.0 ${srcdir}/evelauncher/libgpr.so
@@ -140,10 +139,10 @@ sha256sums=('ce85defa2698ea72e88221d72424fb953f86836494ecc0e4006f41ec89682af4'
'261da84107168979d241c60cd7adbfee0f6675464675faaefd5f6140009d54d8'
'528fc6627e8893db5d7092194e9f3320067f2f1f4593a206aee8a5207956e563'
'd4610df883778f91e0ea5feba84720dfe814af0b9960677e3861809d70de24b2'
- '51eae400033fab0ca0a4a292c9c725dd0da25809d037002130bc1e23fa6c0702'
- '617349fb5f7ca9071e7d2465f5c0d1e01ad501edf3c2458a2ebcdca33d38b070'
- 'ce406f8fe7db143a30a4c85cabfeeb0718c2d4521dc7ad2393743bdc9c9c59ec'
- '9e88a8eeb2b3a9f2551ab204ee632d1ea03742c57f446ea63c9461c6b927082e'
+ 'cda0f7cf511a527645a8a8f4d041888db34d03372a9a45bdecc2eb19133301b0'
+ '18d624c454b452c4d39013c689f8f122774354657a320118601f11df942c15d8'
+ '67f4464116d4e20c058f4b2b17dbfc7507cf5c0c626e88516b475efcab6e6233'
+ '498f276ed8f7ddc75f3cdd525849ee5ef4c3285789e61250b844c38943dcac04'
'69b98d923c08c6fb035c0c6905ec5e9c73273b694f8f3497777d44597dbe63e3'
'762db1df07dfcf526fe634b4b589a08e8affefb2f79f02cff2624c70e0820422'
'980d68abd6f4a662b69efd19145112e88f349044fa1ed5cb6d0a840a92cb42e4'
diff --git a/build_installer.sh b/build_installer.sh
index b2816b5c0ce8..437c8fad3fcf 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -37,13 +37,14 @@ while read pline ;do
plc=$(expr $plc + 1)
done < PKGBUILD
+if [ ! -x "$(which curl 2>/dev/null)" ] ;then
+ printf "\nError: Curl not found. Curl are needed for downloading makeself build tool."
+ printf "\n\tPlease install curl with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0
+fi
+
if [ ! -f "./makeself-2.4.0.run" ] ;then
- if [ ! -x "$(which curl)" ] ;then
- echo "Curl not found. Curl are needed for downloading makeself build tool."
- echo " Please install curl with your Package Manager."
- printf "\nLeaving.\n\n"
- exit 0
- fi
printf "\nGet makeself...\n\n"
curl -L -O https://github.com/megastep/makeself/releases/download/release-2.4.0/makeself-2.4.0.run
fi
diff --git a/build_lite_installer.sh b/build_lite_installer.sh
index a353deccd629..210090776813 100755
--- a/build_lite_installer.sh
+++ b/build_lite_installer.sh
@@ -37,13 +37,14 @@ while read pline ;do
plc=$(expr $plc + 1)
done < PKGBUILD
+if [ ! -x "$(which curl 2>/dev/null)" ] ;then
+ printf "\nError: Curl not found. Curl are needed for downloading makeself build tool."
+ printf "\n\tPlease install curl with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0
+fi
+
if [ ! -f "./makeself-2.4.0.run" ] ;then
- if [ ! -x "$(which curl)" ] ;then
- echo "Curl not found. Curl are needed for downloading makeself build tool."
- echo " Please install curl with your Package Manager."
- printf "\nLeaving.\n\n"
- exit 0
- fi
printf "\nGet makeself...\n\n"
curl -L -O https://github.com/megastep/makeself/releases/download/release-2.4.0/makeself-2.4.0.run
fi
@@ -113,10 +114,10 @@ echo "done."
printf "\nClean up evelauncher directory..."
cd evelauncher/
rm -rf ./resources/ ./plugins/
-rm -f ./*.a ./*.la ./*.prl ./*[Qq]t* ./libicu* ./libpng* ./libxcb*
+rm -f ./*.a ./*.la ./*.pem ./*.prl ./*[Qq]t* ./libicu* ./libpng* ./libxcb*
cp -f ../../evelauncher.sh.real ./evelauncher.sh
chmod 0755 ./*
-chmod 0644 ./roots.pem ./*.qm ./errorpage/*
+chmod 0644 ./*.qm ./errorpage/*
echo "done."
printf "\nReplace identical files with symbolic links..."
diff --git a/evesetup.install b/evesetup.install
deleted file mode 100644
index 8a6567ebd769..000000000000
--- a/evesetup.install
+++ /dev/null
@@ -1,21 +0,0 @@
-post_install() {
- if [ ! -d /usr/local/share/grpc ] ;then
- printf "\nAdding workaround for missing roots.pem in /usr/local/share/grpc.\n\n"
- mkdir -p /usr/local/share/grpc
- touch /usr/local/share/grpc/needed_by_evelauncher
- tar -xf /opt/evesetup/lib/evelauncher-1747682.tar.gz \
- -C /opt/evesetup/lib --strip-components=1 \
- evelauncher/roots.pem
- ln -s /opt/evesetup/lib/roots.pem /usr/local/share/grpc/roots.pem
- fi
-}
-
-pre_remove() {
- if [ -d /usr/local/share/grpc ] ;then
- if [ -r /usr/local/share/grpc/needed_by_evelauncher ] ;then
- printf "\nRemove workaround for missing roots.pem in /usr/local/share/grpc.\n\n"
- rm /opt/evesetup/lib/roots.pem
- rm -rf /usr/local/share/grpc
- fi
- fi
-}
diff --git a/setup.sh.in b/setup.sh.in
index c5d341957c9f..119d767b9603 100644
--- a/setup.sh.in
+++ b/setup.sh.in
@@ -86,9 +86,9 @@ build_lib() {
echo "done."
printf "\nClean up evelauncher directory..."
cd evelauncher/
- rm -f ./*.a ./*.la ./*.prl ./libxcb*
+ rm -f ./*.a ./*.la ./*.pem ./*.prl ./libxcb*
chmod 0755 ./*
- chmod 0644 ./*.qm ./*.pem ./*.conf ./errorpage/*
+ chmod 0644 ./*.qm ./*.conf ./errorpage/*
echo "done."
printf "\nReplace identical files with symbolic links..."
ln -sf evelauncher.sh LogLite.sh
@@ -135,27 +135,24 @@ get_dxvk() {
check_req() {
if [ ! -r "$(find /usr/lib -type f -name 'libxcb-xinerama*' 2>/dev/null)" ] ;then
- printf "\nWarning: libxcb-xinerama needed by evelauncher not found."
- printf "\n\tPlease install libxcb-xinerama with your Package Manager.\n"
- key="nf"
+ req="${req}libxcb-xinerama\n"
fi
if [ ! -x "$(which 7z 2>/dev/null)" ] ;then
- printf "\nError: 7z needed by evebackup not found."
- printf "\n\tPlease install p7zip or p7zip-full with your Package Manager.\n"
- key="nf"
+ req="${req}7z\n"
fi
if [ ! -x "$(which curl 2>/dev/null)" ] ;then
- printf "\n\nError: Curl needed for downloading evelauncher binaries not found."
- printf "\n\tPlease install curl with your Package Manager.\n"
- key="nf"
+ req="${req}curl\n"
fi
if [ ! -x "$(which wine 2>/dev/null)" ] ;then
- printf "\n\nError: Wine not found."
- printf "\n\tPlease install wine with your Package Manager."
- printf "\n\tWineHQ or Developer Version are recommended.\n"
- key="nf"
+ req="${req}wine\n"
+ fi
+ if [ "x$req" != "x" ] ;then
+ printf "\nError: Following requirements are missed:\n"
+ printf "\n$req\n"
+ printf "Please install these requirements with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0
fi
- if [ "x$key" = "xnf" ] ;then printf "\n\nLeaving.\n\n" ;exit 0 ;fi
}
prefix="/usr"
diff --git a/setup_lite.sh.in b/setup_lite.sh.in
index 66007f2e73b1..9ab2258f0058 100644
--- a/setup_lite.sh.in
+++ b/setup_lite.sh.in
@@ -16,8 +16,8 @@ bootstrap_install() {
tar xf ./dxvk-$dvver.tar.gz -C $libdir/dxvk/ --no-same-owner \
--strip-components=1 dxvk-$dvver/x32 dxvk-$dvver/x64
fi
- install -pm 0644 "./evesetup.shlib" "$libdir"
- install -pm 0644 "./evelauncher-${elver}.tar.gz" "$libdir"
+ install -m 0644 "./evesetup.shlib" "$libdir"
+ install -m 0644 "./evelauncher-${elver}.tar.gz" "$libdir"
install -m 0644 "./evelauncher.kwinrule" "$docdir"
install -m 0644 "./evelauncher.lua" "$docdir"
sed -i s,SETUPDIR=\"\",SETUPDIR=\"$destdir\", ./evelauncher.sh
@@ -25,7 +25,7 @@ bootstrap_install() {
cmd=eve$cmd
if [ -f "./$cmd" ] ;then
sed -i s,./evesetup.shlib,$libdir/evesetup.shlib, ./$cmd
- install -p "./$cmd" "$bindir/"
+ install "./$cmd" "$bindir/"
else
if [ "$cmd" = "everestore" ] ;then
ln -s evebackup "$bindir/$cmd"
@@ -62,7 +62,8 @@ bootstrap_remove() {
rm -f "$prefix/share/applications/${cmd%.*}.desktop"
fi
done
- rm -rfv "$destdir"
+ printf "\nRemove $destdir...\n"
+ rm -rf "$destdir"
}
check_req() {
@@ -81,9 +82,9 @@ check_req() {
cd ../
rm -rf evelauncher/
if [ "x$req" != "x" ] ;then
- printf "\nFollowing requirements are missing:\n"
+ printf "\nError: Following requirements are missed:\n"
printf "\n$req\n"
- printf "\nPlease install these requirements with your Package Manager.\n"
+ printf "Please install these requirements with your Package Manager.\n"
printf "\nLeaving.\n\n"
exit 0
fi