summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Ingwersen2023-03-22 06:38:47 +0100
committerHauke Ingwersen2023-03-22 06:38:47 +0100
commitf754d7e85e9e903fdbaca9db8cbca2d063ce0a99 (patch)
treeb0d0bdaf74c2b465b94e853ef2667b5999deaf9f
parent0cfd8cc5a706712bb9bccce7f609a3919cce34c2 (diff)
downloadaur-evince-no-gnome.tar.gz
44.1-1 version update, change source from git to release tar to use sha256sums
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2d660180aee..8ead2267712c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = evince-no-gnome
pkgdesc = Document viewer, no gnome dependencies
- pkgver = 44.0
+ pkgver = 44.1
pkgrel = 1
url = https://wiki.gnome.org/Apps/Evince
arch = i686
@@ -37,7 +37,7 @@ pkgbase = evince-no-gnome
conflicts = libevdocument3.so
conflicts = libevview3.so
options = !emptydirs
- source = git+https://gitlab.gnome.org/GNOME/evince.git#commit=9912cf2cb589f493b3c193fb76e73d00c20fc1ba
- sha256sums = SKIP
+ source = https://download.gnome.org/sources/evince/44/evince-44.1.tar.xz
+ sha256sums = 15afd3bb15ffb38fecab34c23350950ad270ab03a85b94e333d9dd7ee6a74314
pkgname = evince-no-gnome
diff --git a/.gitignore b/.gitignore
index 373b8edc21fb..aef2802baca0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,3 @@
-evince
pkg/evince-no-gnome
-*.pkg.tar.zst
+*.tar.xz
+src
diff --git a/PKGBUILD b/PKGBUILD
index a4d3618fd599..221232ecd911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
-# Maintainer: Yiyao Yu <yyudevel at protonmail dot com>
+# Maintainer : Hauke Ingwersen <hauing@pm.me>
+# Contributor: Yiyao Yu <yyudevel at protonmail dot com>
# Contributor: GordonGR <ntheo1979@gmail.com>
# Contributor: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani at gmail dot com>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=evince-no-gnome
_pkgname=evince
-pkgver=44.0
+pkgver=44.1
+_milestone=44
pkgrel=1
pkgdesc="Document viewer, no gnome dependencies"
url="https://wiki.gnome.org/Apps/Evince"
@@ -18,17 +20,15 @@ optdepends=('texlive-bin: DVI support'
provides=("$_pkgname" libev{document,view}3.so)
conflicts=("$_pkgname" libev{document,view}3.so)
options=('!emptydirs')
-_commit=9912cf2cb589f493b3c193fb76e73d00c20fc1ba # tags/44.0^0
-source=("git+https://gitlab.gnome.org/GNOME/evince.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("https://download.gnome.org/sources/evince/${_milestone}/evince-${pkgver}.tar.xz")
+sha256sums=('15afd3bb15ffb38fecab34c23350950ad270ab03a85b94e333d9dd7ee6a74314')
-pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
+prepare () {
+ tar -xvf evince-${pkgver}.tar.xz
}
build() {
- arch-meson "$_pkgname" build \
+ arch-meson "$srcdir/evince-${pkgver}" build \
-D ps=enabled \
-D nautilus=false \
-D introspection=false \