summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-01-26 14:19:59 +0200
committerAdrian Perez de Castro2024-01-26 14:19:59 +0200
commitea911c85364ef926bcd84334ac30cd9f71abb894 (patch)
tree6faaffcd66a719bbd23985b17d1e01c875967412
parent24b89482aeff8a8c65b29e6b525877ef57389a59 (diff)
downloadaur-fuse-ext2.tar.gz
Bump to version 0.0.11
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e762a331f3ba..ec2ea20322bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fuse-ext2
pkgdesc = A multi OS FUSE module to mount ext2, ext3 and ext4 file system devices and/or images with read write support
- pkgver = 0.0.10
+ pkgver = 0.0.11
pkgrel = 1
url = https://github.com/alperakcan/fuse-ext2
arch = i686
@@ -8,12 +8,12 @@ pkgbase = fuse-ext2
arch = arm
arch = armv6h
arch = armv7h
- license = GPL2
+ license = GPL-2.0-only
depends = fuse2
depends = e2fsprogs
+ depends = glibc
conflicts = fuse-ext2-git
- source = https://github.com/alperakcan/fuse-ext2/archive/v0.0.10.tar.gz
- sha512sums = b884c0f92b706ae3f03dd75f489990e7cea31fd68526ade48ab5a11e1c9f78ec02a4dbb82450ce2aca12742a799c334a3ab8f2443a96ad003a76f0a86567fa24
+ source = https://github.com/alperakcan/fuse-ext2/archive/v0.0.11.tar.gz
+ sha512sums = 2307eb7db8a9f52cbab3fa4b0dfac0d6804d476002661cc0a97b870bbac1e80dfc92bf8759612e5fe2919af2214d921cc43764252739f336060cc91f08179b06
pkgname = fuse-ext2
-
diff --git a/PKGBUILD b/PKGBUILD
index f9e0ed72878b..66db8ee56f1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgname=fuse-ext2
-pkgver=0.0.10
+pkgver=0.0.11
pkgrel=1
pkgdesc='A multi OS FUSE module to mount ext2, ext3 and ext4 file system devices and/or images with read write support'
url='https://github.com/alperakcan/fuse-ext2'
-license=('GPL2')
+license=('GPL-2.0-only')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-depends=('fuse2' 'e2fsprogs')
+depends=('fuse2' 'e2fsprogs' 'glibc')
conflicts=("${pkgname}-git")
source=("${url}/archive/v${pkgver}.tar.gz")
-sha512sums=('b884c0f92b706ae3f03dd75f489990e7cea31fd68526ade48ab5a11e1c9f78ec02a4dbb82450ce2aca12742a799c334a3ab8f2443a96ad003a76f0a86567fa24')
+sha512sums=('2307eb7db8a9f52cbab3fa4b0dfac0d6804d476002661cc0a97b870bbac1e80dfc92bf8759612e5fe2919af2214d921cc43764252739f336060cc91f08179b06')
build() {
- cd "${pkgname}-${pkgver}"
- autoreconf --install --symlink
- CPPFLAGS='-include /usr/include/sys/sysmacros.h' ./configure --prefix=/usr --sbindir=/usr/bin
- make
+ cd "${pkgname}-${pkgver}"
+ autoreconf --install --symlink
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}