summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. Jung2022-02-26 16:18:45 +0000
committerP. Jung2022-02-26 16:18:45 +0000
commit7870c5f6d716405b853b3da3303055fa005a8e74 (patch)
tree6f4c75464409bd09f20fa917926b0fbe700f20ab
parent593465a79c8e4b7e6d8e49f9e3eb54a182b4a937 (diff)
downloadaur-7870c5f6d716405b853b3da3303055fa005a8e74.tar.gz
add libgccjit-git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25b9db366f6e..b0d0d7b387c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -122,3 +122,7 @@ pkgname = gcc-d-git
conflicts = gcc-d
replaces = gdc-git
options = staticlibs
+
+pkgname = libgccjit-git
+ pkgdesc = Just-In-Time Compilation with GCC backend
+ depends = gcc-git=12.0.1_r191804.gafeaaf4b352-1
diff --git a/PKGBUILD b/PKGBUILD
index 29ff2d9be9a0..bd55eb0f6416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Just edit the --enable-languages option as well as the pkgname array, and comment out the pkg functions :)
pkgbase=gcc-git
-pkgname=({gcc,gcc-libs,gcc-fortran,gcc-objc,gcc-ada,gcc-go,gcc-d}-git)
+pkgname=({gcc,gcc-libs,gcc-fortran,gcc-objc,gcc-ada,gcc-go,gcc-d,libgccjit}-git)
pkgver=12.0.1_r191804.gafeaaf4b352
_majorver=${pkgver%%.*}
_islver=0.24
@@ -461,9 +461,9 @@ package_gcc-d-git() {
"$pkgdir/usr/share/licenses/$pkgname/"
}
-package_libgccjit() {
+package_libgccjit-git() {
pkgdesc="Just-In-Time Compilation with GCC backend"
- depends=("gcc=$pkgver-$pkgrel")
+ depends=("gcc-git=$pkgver-$pkgrel")
cd gcc-build
make -C gcc DESTDIR="$pkgdir" jit.install-common jit.install-info