summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-12-13 09:36:28 +0000
committerJames Harvey2015-12-13 09:36:28 +0000
commita348fbc993db92b39f9d9905b260fc7173e9b75a (patch)
tree092bccd0f9d824dda9bbd55762c33ecc620ad08c
parent37f8b6af4a5c5c573c9ead45fb6fb6d97c1dc662 (diff)
downloadaur-a348fbc993db92b39f9d9905b260fc7173e9b75a.tar.gz
Mirrored core's changes from 5.1.0-5 to 5.3.0-2, as much as possible. Removed gcc.libstdc++-v3.python.dot.fix.patch, because it was added upstream in a71e2494. Added _CHOST variable, because GCC is expecting CHOST vendor to not be 'unknown' anymore, but a descriptive value such as 'pc'. If your system is seen as 'softfloat', 'hardfloat', or 'unknown', you may have to chnge the value set to _CHOST.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD103
-rw-r--r--gcc.isl.0.15.includes.patch127
-rw-r--r--gcc.isl.0.15.patch229
-rw-r--r--gcc.libstdc++-v3.python.dot.fix.patch33
5 files changed, 51 insertions, 451 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b4a32155c82..fb7315c81ab5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 09:35:38 UTC 2015
pkgbase = gcc-git
pkgdesc = The GNU Compiler Collection (developmental version)
pkgver = 6.0.0.r139654.12dcc3b
@@ -19,14 +21,8 @@ pkgbase = gcc-git
options = !emptydirs
source = git://gcc.gnu.org/git/gcc.git
source = http://isl.gforge.inria.fr/isl-0.15.tar.bz2
- source = gcc.libstdc++-v3.python.dot.fix.patch
- source = gcc.isl.0.15.patch
- source = gcc.isl.0.15.includes.patch
md5sums = SKIP
md5sums = 8428efbbc6f6e2810ce5c1ba73ecf98c
- md5sums = 7de06deb9ee0c10454219a319e62e4dc
- md5sums = 7069b4d1f9413a04ce4cfba039b1b0ba
- md5sums = 6daf2d3f9365a0e768bdaaa1595b18f6
pkgname = gcc-git
pkgdesc = The GNU Compiler Collection - C and C++ frontends (developmental version)
@@ -43,7 +39,7 @@ pkgname = gcc-libs-git
pkgdesc = Runtime libraries shipped by GCC (developmental version)
install = gcc-libs.install
groups = base
- depends = glibc>=2.21
+ depends = glibc>=2.22
provides = gcc-libs
conflicts = gcc-libs
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 8a6f8d4754c2..ec8c1f0f0ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,11 @@
# Modifications to Use Git Master Source
# ======================================
# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * This PKGBUILD as closely as possible matches core's gcc 5.1.0-5
-# * The many test suite failures ("UNRESOLVED:", "FAIL:") occur during building core's 5.1.0-5, so the problem is upstream from here
-# * Core's 5.1.0-5 pr65882.patch is omitted, because it is git commit 1774df35
-# * Core's 5.1.0-5 pr66647.patch is omitted, because it is git commit fa4f365b
-# * Core's 5.1.0-5 pr66035.patch is omitted, because it is git commit 635e1b2f, slightly modified
-# * gcc.libstdc++-v3.python.dot.fix.patch is added, to fix an accidentical misnaming of gdb.py
-# * All namcap warnings are identical, as of 6.0.0.r140049.cab0d20, except:
+# * This PKGBUILD as closely as possible matches core's gcc 5.3.0-2
+# * All namcap warnings are essentially identical, as of 6.0.0.r143486.3afbcf4, except:
# * Error of a missing custom license directory of /usr/share/licenses/gcc*-git
-# * Symlink /usr/lib/bfd-plugins/liblto_plugin.so points to non-existing /usr/lib/gcc/x86_64-unknown-linux-gnu/6.0.0.r140049.cab0d20/liblto_plugin.so
+# * Symlink /usr/lib/bfd-plugins/liblto_plugin.so points to non-existing /usr/lib/gcc/x86_64-pc-linux-gnu/6.0.0.r140049.cab0d20/liblto_plugin.so -- will be fixing this
+# * gcc-go-git gives a "Referenced library 'libgo.so.8' is an uninstalled dependency -- will be looking into this
# * _pkgver_base is hard coded at the moment to 6.0.0; can't parse from source at that point
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
@@ -36,19 +32,26 @@ makedepends=('binutils>=2.25' 'libmpc' 'gcc-ada' 'doxygen' 'git')
checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs')
source=(git://gcc.gnu.org/git/gcc.git
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- gcc.libstdc++-v3.python.dot.fix.patch
- gcc.isl.0.15.patch
- gcc.isl.0.15.includes.patch)
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
md5sums=('SKIP'
- '8428efbbc6f6e2810ce5c1ba73ecf98c'
- '7de06deb9ee0c10454219a319e62e4dc'
- '7069b4d1f9413a04ce4cfba039b1b0ba'
- '6daf2d3f9365a0e768bdaaa1595b18f6')
+ '8428efbbc6f6e2810ce5c1ba73ecf98c')
_basedir=${_pkgname}
-_libdir="usr/lib/gcc/$CHOST/$_pkgver_base"
+# CHOST is in the form <architecture>-<vendor>-<operatingSystem>-<cLibrary>
+# Arch currently reports CHOST with vendor "unknown". GCC expected this until recently, and on my machine is expecting "pc".
+# Core's gcc and this package define arch to only be 'i686' or 'x86_64', so this workaround should work for whatever architecture is expected to be given.
+# It is unknown to me if gcc will see everyone running arch as vendor "pc", or if it will see "softfloat", "hardfloat", or "unknown" here.
+# (You may have to change the value of _CHOST.)
+# Rather than having an else cause an error, I'm letting it go through, on the hopes that whatever is defined might work.
+_CHOST=${CHOST}
+if [[ "${CHOST}" == 'x86_64-unknown-linux-gnu' ]]; then
+ _CHOST='x86_64-pc-linux-gnu'
+elif [[ "${CHOST}" == 'i686-unknown-linux-gnu' ]]; then
+ _CHOST='i686-pc-linux-gnu'
+fi
+
+_libdir="usr/lib/gcc/$_CHOST/$_pkgver_base"
pkgver() {
cd ${srcdir}/gcc
@@ -70,15 +73,6 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- # Submitted upstream - Fixes misnaming of gdb.py file due to addition of libstdc++fs library
- patch -p0 -i ${srcdir}/gcc.libstdc++-v3.python.dot.fix.patch
-
- # https://gcc.gnu.org/ml/gcc-patches/2015-07/msg01162.html
- patch -p1 -i ${srcdir}/gcc.isl.0.15.patch
-
- # https://gcc.gnu.org/ml/gcc-patches/2015-07/msg01507.html
- patch -p1 -i ${srcdir}/gcc.isl.0.15.includes.patch
-
mkdir ${srcdir}/gcc-build
}
@@ -103,13 +97,12 @@ build() {
--enable-lto --enable-plugin --enable-install-libiberty \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \
- --enable-checking=release \
- --with-default-libstdcxx-abi=gcc4-compatible
+ --enable-checking=release
make
# make documentation
- make -C $CHOST/libstdc++-v3/doc doc-man-doxygen
+ make -C $_CHOST/libstdc++-v3/doc doc-man-doxygen
}
check() {
@@ -128,7 +121,7 @@ package_gcc-libs-git()
{
pkgdesc="Runtime libraries shipped by GCC (developmental version)"
groups=('base')
- depends=('glibc>=2.21')
+ depends=('glibc>=2.22')
provides=('gcc-libs')
conflicts=('gcc-libs')
options=('!emptydirs' '!strip')
@@ -136,7 +129,7 @@ package_gcc-libs-git()
cd ${srcdir}/gcc-build
- make -C $CHOST/libgcc DESTDIR=${pkgdir} install-shared
+ make -C $_CHOST/libgcc DESTDIR=${pkgdir} install-shared
rm ${pkgdir}/${_libdir}/libgcc_eh.a
for lib in libatomic \
@@ -148,23 +141,23 @@ package_gcc-libs-git()
libsanitizer/{a,l,ub}san \
libstdc++-v3/src \
libvtv; do
- make -C $CHOST/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
+ make -C $_CHOST/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
done
[[ $CARCH == "x86_64" ]] && \
- make -C $CHOST/libsanitizer/tsan DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
+ make -C $_CHOST/libsanitizer/tsan DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
- make -C $CHOST/libobjc DESTDIR=${pkgdir} install-libs
+ make -C $_CHOST/libobjc DESTDIR=${pkgdir} install-libs
- make -C $CHOST/libstdc++-v3/po DESTDIR=${pkgdir} install
+ make -C $_CHOST/libstdc++-v3/po DESTDIR=${pkgdir} install
- make -C $CHOST/libmpx DESTDIR=${pkgdir} install
+ make -C $_CHOST/libmpx DESTDIR=${pkgdir} install
rm ${pkgdir}/usr/lib/libmpx.spec
for lib in libgomp \
libitm \
libquadmath; do
- make -C $CHOST/$lib DESTDIR=${pkgdir} install-info
+ make -C $_CHOST/$lib DESTDIR=${pkgdir} install-info
done
# Install Runtime Library Exception
@@ -190,13 +183,13 @@ package_gcc-git()
install -m755 -t $pkgdir/usr/bin/ gcc/gcov{,-tool}
install -m755 -t $pkgdir/${_libdir}/ gcc/{cc1,cc1plus,collect2,lto1}
- make -C $CHOST/libgcc DESTDIR=${pkgdir} install
+ make -C $_CHOST/libgcc DESTDIR=${pkgdir} install
rm ${pkgdir}/usr/lib/libgcc_s.so*
- make -C $CHOST/libstdc++-v3/src DESTDIR=${pkgdir} install
- make -C $CHOST/libstdc++-v3/include DESTDIR=${pkgdir} install
- make -C $CHOST/libstdc++-v3/libsupc++ DESTDIR=${pkgdir} install
- make -C $CHOST/libstdc++-v3/python DESTDIR=${pkgdir} install
+ make -C $_CHOST/libstdc++-v3/src DESTDIR=${pkgdir} install
+ make -C $_CHOST/libstdc++-v3/include DESTDIR=${pkgdir} install
+ make -C $_CHOST/libstdc++-v3/libsupc++ DESTDIR=${pkgdir} install
+ make -C $_CHOST/libstdc++-v3/python DESTDIR=${pkgdir} install
make DESTDIR=${pkgdir} install-libcc1
install -d $pkgdir/usr/share/gdb/auto-load/usr/lib
@@ -209,18 +202,18 @@ package_gcc-git()
make -C lto-plugin DESTDIR=${pkgdir} install
install -dm755 ${pkgdir}/usr/lib/bfd-plugins/
- ln -s /usr/lib/gcc/$CHOST/${pkgver}/liblto_plugin.so \
+ ln -s /usr/lib/gcc/$_CHOST/${pkgver}/liblto_plugin.so \
${pkgdir}/usr/lib/bfd-plugins/
- make -C $CHOST/libcilkrts DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
+ make -C $_CHOST/libcilkrts DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
install-nodist_cilkincludeHEADERS
- make -C $CHOST/libgomp DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
+ make -C $_CHOST/libgomp DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
install-nodist_libsubincludeHEADERS
- make -C $CHOST/libitm DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
- make -C $CHOST/libquadmath DESTDIR=${pkgdir} install-nodist_libsubincludeHEADERS
- make -C $CHOST/libsanitizer DESTDIR=${pkgdir} install-nodist_{saninclude,toolexeclib}HEADERS
- make -C $CHOST/libsanitizer/asan DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
- make -C $CHOST/libmpx DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
+ make -C $_CHOST/libitm DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
+ make -C $_CHOST/libquadmath DESTDIR=${pkgdir} install-nodist_libsubincludeHEADERS
+ make -C $_CHOST/libsanitizer DESTDIR=${pkgdir} install-nodist_{saninclude,toolexeclib}HEADERS
+ make -C $_CHOST/libsanitizer/asan DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
+ make -C $_CHOST/libmpx DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
make -C libiberty DESTDIR=${pkgdir} install
# install PIC version of libiberty
@@ -266,7 +259,7 @@ EOF
chmod 755 $pkgdir/usr/bin/c{8,9}9
# install the libstdc++ man pages
- make -C $CHOST/libstdc++-v3/doc DESTDIR=$pkgdir doc-install-man
+ make -C $_CHOST/libstdc++-v3/doc DESTDIR=$pkgdir doc-install-man
# Install Runtime Library Exception
install -d ${pkgdir}/usr/share/licenses/gcc/
@@ -286,9 +279,9 @@ package_gcc-fortran-git()
cd ${srcdir}/gcc-build
# install-myexeclibLTLIBRARIES omitted because it was removed upstream
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=40267
- make -C $CHOST/libgfortran DESTDIR=$pkgdir install-cafexeclibLTLIBRARIES \
+ make -C $_CHOST/libgfortran DESTDIR=$pkgdir install-cafexeclibLTLIBRARIES \
install-{toolexeclibDATA,nodist_fincludeHEADERS}
- make -C $CHOST/libgomp DESTDIR=$pkgdir install-nodist_fincludeHEADERS
+ make -C $_CHOST/libgomp DESTDIR=$pkgdir install-nodist_fincludeHEADERS
make -C gcc DESTDIR=$pkgdir fortran.install-{common,man,info}
install -Dm755 gcc/f951 $pkgdir/${_libdir}/f951
@@ -308,7 +301,7 @@ package_gcc-objc-git()
conflicts=('gcc-objc')
cd ${srcdir}/gcc-build
- make DESTDIR=$pkgdir -C $CHOST/libobjc install-headers
+ make DESTDIR=$pkgdir -C $_CHOST/libobjc install-headers
install -dm755 $pkgdir/${_libdir}
install -m755 gcc/cc1obj{,plus} $pkgdir/${_libdir}/
@@ -355,7 +348,7 @@ package_gcc-go-git()
install=gcc-go.install
cd ${srcdir}/gcc-build
- make -C $CHOST/libgo DESTDIR=$pkgdir install-exec-am
+ make -C $_CHOST/libgo DESTDIR=$pkgdir install-exec-am
make -C gcc DESTDIR=$pkgdir go.install-{common,man,info}
install -Dm755 gcc/go1 $pkgdir/${_libdir}/go1
diff --git a/gcc.isl.0.15.includes.patch b/gcc.isl.0.15.includes.patch
deleted file mode 100644
index 162c5bf2cc14..000000000000
--- a/gcc.isl.0.15.includes.patch
+++ /dev/null
@@ -1,127 +0,0 @@
----
- gcc/graphite-blocking.c | 1 +
- gcc/graphite-dependences.c | 1 +
- gcc/graphite-interchange.c | 1 +
- gcc/graphite-isl-ast-to-gimple.c | 2 ++
- gcc/graphite-optimize-isl.c | 2 ++
- gcc/graphite-poly.c | 1 +
- gcc/graphite-scop-detection.c | 1 +
- gcc/graphite-sese-to-poly.c | 1 +
- gcc/graphite.c | 1 +
- 9 files changed, 11 insertions(+)
-
-diff --git a/gcc/graphite-blocking.c b/gcc/graphite-blocking.c
-index 73d7c59..172bdcd 100644
---- a/gcc/graphite-blocking.c
-+++ b/gcc/graphite-blocking.c
-@@ -27,6 +27,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
-diff --git a/gcc/graphite-dependences.c b/gcc/graphite-dependences.c
-index 9a0986d..df52e54 100644
---- a/gcc/graphite-dependences.c
-+++ b/gcc/graphite-dependences.c
-@@ -25,6 +25,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
-diff --git a/gcc/graphite-interchange.c b/gcc/graphite-interchange.c
-index aee51a8..bcf7f3b 100644
---- a/gcc/graphite-interchange.c
-+++ b/gcc/graphite-interchange.c
-@@ -27,6 +27,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/aff.h>
- #include <isl/set.h>
- #include <isl/map.h>
-diff --git a/gcc/graphite-isl-ast-to-gimple.c b/gcc/graphite-isl-ast-to-gimple.c
-index b32781a..7aafee2 100644
---- a/gcc/graphite-isl-ast-to-gimple.c
-+++ b/gcc/graphite-isl-ast-to-gimple.c
-@@ -24,7 +24,9 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
-+#include <isl/union_set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
- #include <isl/ast_build.h>
-diff --git a/gcc/graphite-optimize-isl.c b/gcc/graphite-optimize-isl.c
-index 388e25c..2b55783 100644
---- a/gcc/graphite-optimize-isl.c
-+++ b/gcc/graphite-optimize-isl.c
-@@ -24,7 +24,9 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
-+#include <isl/union_set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
- #include <isl/schedule.h>
-diff --git a/gcc/graphite-poly.c b/gcc/graphite-poly.c
-index bcd08d8..e3ddd57 100644
---- a/gcc/graphite-poly.c
-+++ b/gcc/graphite-poly.c
-@@ -25,6 +25,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
-diff --git a/gcc/graphite-scop-detection.c b/gcc/graphite-scop-detection.c
-index 47e0da0..22fdde3 100644
---- a/gcc/graphite-scop-detection.c
-+++ b/gcc/graphite-scop-detection.c
-@@ -25,6 +25,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
-diff --git a/gcc/graphite-sese-to-poly.c b/gcc/graphite-sese-to-poly.c
-index 5064247..7b10289 100644
---- a/gcc/graphite-sese-to-poly.c
-+++ b/gcc/graphite-sese-to-poly.c
-@@ -24,6 +24,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
- #include <isl/map.h>
- #include <isl/union_map.h>
-diff --git a/gcc/graphite.c b/gcc/graphite.c
-index a81ef6a..32f405a 100644
---- a/gcc/graphite.c
-+++ b/gcc/graphite.c
-@@ -38,6 +38,7 @@ along with GCC; see the file COPYING3. If not see
- /* Workaround for GMP 5.1.3 bug, see PR56019. */
- #include <stddef.h>
-
-+#include <isl/constraint.h>
- #include <isl/set.h>
- #include <isl/map.h>
- #include <isl/options.h>
---
-1.7.10.4
-
diff --git a/gcc.isl.0.15.patch b/gcc.isl.0.15.patch
deleted file mode 100644
index 12d42c719091..000000000000
--- a/gcc.isl.0.15.patch
+++ /dev/null
@@ -1,229 +0,0 @@
----
- gcc/config.in | 6 ++++++
- gcc/configure | 31 +++++++++++++++++++++++++++++++
- gcc/configure.ac | 14 ++++++++++++++
- gcc/graphite-dependences.c | 14 +++++++-------
- gcc/graphite-optimize-isl.c | 8 ++++++--
- gcc/graphite-poly.h | 5 +++++
- 6 files changed, 69 insertions(+), 9 deletions(-)
-
-diff --git a/gcc/config.in b/gcc/config.in
-index b031a62..23e1757 100644
---- a/gcc/config.in
-+++ b/gcc/config.in
-@@ -1326,6 +1326,12 @@
- #endif
-
-
-+/* Define if isl_options_set_schedule_serialize_sccs exists. */
-+#ifndef USED_FOR_TARGET
-+#undef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
-+#endif
-+
-+
- /* Define if isl_schedule_constraints_compute_schedule exists. */
- #ifndef USED_FOR_TARGET
- #undef HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE
-diff --git a/gcc/configure b/gcc/configure
-index 9561e5c..6e81298 100755
---- a/gcc/configure
-+++ b/gcc/configure
-@@ -28456,6 +28456,8 @@ fi
-
- # Check whether isl_schedule_constraints_compute_schedule is available;
- # it's new in ISL-0.13.
-+# Check whether isl_options_set_schedule_serialize_sccs is available;
-+# it's new in ISL-0.15.
- if test "x${ISLLIBS}" != "x" ; then
- saved_CXXFLAGS="$CXXFLAGS"
- CXXFLAGS="$CXXFLAGS $ISLINC"
-@@ -28485,6 +28487,29 @@ rm -f core conftest.err conftest.$ac_objext \
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_has_isl_schedule_constraints_compute_schedule" >&5
- $as_echo "$ac_has_isl_schedule_constraints_compute_schedule" >&6; }
-
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking Checking for isl_options_set_schedule_serialize_sccs" >&5
-+$as_echo_n "checking Checking for isl_options_set_schedule_serialize_sccs... " >&6; }
-+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-+/* end confdefs.h. */
-+#include <isl/schedule.h>
-+int
-+main ()
-+{
-+isl_options_set_schedule_serialize_sccs (NULL, 0);
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+if ac_fn_cxx_try_link "$LINENO"; then :
-+ ac_has_isl_options_set_schedule_serialize_sccs=yes
-+else
-+ ac_has_isl_options_set_schedule_serialize_sccs=no
-+fi
-+rm -f core conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_has_isl_options_set_schedule_serialize_sccs" >&5
-+$as_echo "$ac_has_isl_options_set_schedule_serialize_sccs" >&6; }
-+
- LIBS="$saved_LIBS"
- CXXFLAGS="$saved_CXXFLAGS"
-
-@@ -28493,6 +28518,12 @@ $as_echo "$ac_has_isl_schedule_constraints_compute_schedule" >&6; }
- $as_echo "#define HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE 1" >>confdefs.h
-
- fi
-+
-+ if test x"$ac_has_isl_options_set_schedule_serialize_sccs" = x"yes"; then
-+
-+$as_echo "#define HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS 1" >>confdefs.h
-+
-+ fi
- fi
-
- # Check for plugin support
-diff --git a/gcc/configure.ac b/gcc/configure.ac
-index cb14639..7fb964a 100644
---- a/gcc/configure.ac
-+++ b/gcc/configure.ac
-@@ -5725,6 +5725,8 @@ fi
-
- # Check whether isl_schedule_constraints_compute_schedule is available;
- # it's new in ISL-0.13.
-+# Check whether isl_options_set_schedule_serialize_sccs is available;
-+# it's new in ISL-0.15.
- if test "x${ISLLIBS}" != "x" ; then
- saved_CXXFLAGS="$CXXFLAGS"
- CXXFLAGS="$CXXFLAGS $ISLINC"
-@@ -5738,6 +5740,13 @@ if test "x${ISLLIBS}" != "x" ; then
- [ac_has_isl_schedule_constraints_compute_schedule=no])
- AC_MSG_RESULT($ac_has_isl_schedule_constraints_compute_schedule)
-
-+ AC_MSG_CHECKING([Checking for isl_options_set_schedule_serialize_sccs])
-+ AC_TRY_LINK([#include <isl/schedule.h>],
-+ [isl_options_set_schedule_serialize_sccs (NULL, 0);],
-+ [ac_has_isl_options_set_schedule_serialize_sccs=yes],
-+ [ac_has_isl_options_set_schedule_serialize_sccs=no])
-+ AC_MSG_RESULT($ac_has_isl_options_set_schedule_serialize_sccs)
-+
- LIBS="$saved_LIBS"
- CXXFLAGS="$saved_CXXFLAGS"
-
-@@ -5745,6 +5754,11 @@ if test "x${ISLLIBS}" != "x" ; then
- AC_DEFINE(HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE, 1,
- [Define if isl_schedule_constraints_compute_schedule exists.])
- fi
-+
-+ if test x"$ac_has_isl_options_set_schedule_serialize_sccs" = x"yes"; then
-+ AC_DEFINE(HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS, 1,
-+ [Define if isl_options_set_schedule_serialize_sccs exists.])
-+ fi
- fi
-
- GCC_ENABLE_PLUGINS
-diff --git a/gcc/graphite-dependences.c b/gcc/graphite-dependences.c
-index 50fe73e..9a0986d 100644
---- a/gcc/graphite-dependences.c
-+++ b/gcc/graphite-dependences.c
-@@ -205,7 +205,7 @@ scop_get_transformed_schedule (scop_p scop, vec<poly_bb_p> pbbs)
- /* Helper function used on each MAP of a isl_union_map. Computes the
- maximal output dimension. */
-
--static int
-+static isl_stat
- max_number_of_out_dimensions (__isl_take isl_map *map, void *user)
- {
- int global_max = *((int *) user);
-@@ -217,7 +217,7 @@ max_number_of_out_dimensions (__isl_take isl_map *map, void *user)
-
- isl_map_free (map);
- isl_space_free (space);
-- return 0;
-+ return isl_stat_ok;
- }
-
- /* Extends the output dimension of MAP to MAX dimensions. */
-@@ -241,12 +241,12 @@ struct extend_schedule_str {
-
- /* Helper function for extend_schedule. */
-
--static int
-+static isl_stat
- extend_schedule_1 (__isl_take isl_map *map, void *user)
- {
- struct extend_schedule_str *str = (struct extend_schedule_str *) user;
- str->umap = isl_union_map_add_map (str->umap, extend_map (map, str->max));
-- return 0;
-+ return isl_stat_ok;
- }
-
- /* Return a relation that has uniform output dimensions. */
-@@ -255,16 +255,16 @@ __isl_give isl_union_map *
- extend_schedule (__isl_take isl_union_map *x)
- {
- int max = 0;
-- int res;
-+ isl_stat res;
- struct extend_schedule_str str;
-
- res = isl_union_map_foreach_map (x, max_number_of_out_dimensions, (void *) &max);
-- gcc_assert (res == 0);
-+ gcc_assert (res == isl_stat_ok);
-
- str.max = max;
- str.umap = isl_union_map_empty (isl_union_map_get_space (x));
- res = isl_union_map_foreach_map (x, extend_schedule_1, (void *) &str);
-- gcc_assert (res == 0);
-+ gcc_assert (res == isl_stat_ok);
-
- isl_union_map_free (x);
- return str.umap;
-diff --git a/gcc/graphite-optimize-isl.c b/gcc/graphite-optimize-isl.c
-index f490401..388e25c 100644
---- a/gcc/graphite-optimize-isl.c
-+++ b/gcc/graphite-optimize-isl.c
-@@ -506,13 +506,13 @@ getScheduleMap (isl_schedule *Schedule, isl_union_map **map_sepcl)
- return ScheduleMap;
- }
-
--static int
-+static isl_stat
- getSingleMap (__isl_take isl_map *map, void *user)
- {
- isl_map **singleMap = (isl_map **) user;
- *singleMap = map;
-
-- return 0;
-+ return isl_stat_ok;
- }
-
- static void
-@@ -584,7 +584,11 @@ optimize_isl (scop_p scop)
-
- isl_options_set_schedule_max_constant_term (scop->ctx, CONSTANT_BOUND);
- isl_options_set_schedule_maximize_band_depth (scop->ctx, 1);
-+#ifdef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
-+ isl_options_set_schedule_serialize_sccs (scop->ctx, 1);
-+#else
- isl_options_set_schedule_fuse (scop->ctx, ISL_SCHEDULE_FUSE_MIN);
-+#endif
- isl_options_set_on_error (scop->ctx, ISL_ON_ERROR_CONTINUE);
-
- #ifdef HAVE_ISL_SCHED_CONSTRAINTS_COMPUTE_SCHEDULE
-diff --git a/gcc/graphite-poly.h b/gcc/graphite-poly.h
-index 7ffd18e..7022a1d 100644
---- a/gcc/graphite-poly.h
-+++ b/gcc/graphite-poly.h
-@@ -24,6 +24,11 @@ along with GCC; see the file COPYING3. If not see
-
- #include "sese.h"
-
-+#ifndef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
-+# define isl_stat int
-+# define isl_stat_ok 0
-+#endif
-+
- typedef struct poly_dr *poly_dr_p;
-
- typedef struct poly_bb *poly_bb_p;
---
-2.4.4
-
diff --git a/gcc.libstdc++-v3.python.dot.fix.patch b/gcc.libstdc++-v3.python.dot.fix.patch
deleted file mode 100644
index 59d8f49a0495..000000000000
--- a/gcc.libstdc++-v3.python.dot.fix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Index: libstdc++-v3/python/Makefile.am
-===================================================================
---- libstdc++-v3/python/Makefile.am (revision 225409)
-+++ libstdc++-v3/python/Makefile.am (working copy)
-@@ -45,11 +45,11 @@
- @$(mkdir_p) $(DESTDIR)$(toolexeclibdir)
- ## We want to install gdb.py as SOMETHING-gdb.py. SOMETHING is the
- ## full name of the final library. We want to ignore symlinks, the
--## .la file, and any previous -gdb.py file. This is inherently
--## fragile, but there does not seem to be a better option, because
--## libtool hides the real names from us.
-+## .la file, any previous -gdb.py file, and libstdc++fs*. This is
-+## inherently fragile, but there does not seem to be a better option,
-+## because libtool hides the real names from us.
- @here=`pwd`; cd $(DESTDIR)$(toolexeclibdir); \
-- for file in libstdc++*; do \
-+ for file in libstdc++.*; do \
- case $$file in \
- *-gdb.py) ;; \
- *.la) ;; \
-Index: libstdc++-v3/python/Makefile.in
-===================================================================
---- libstdc++-v3/python/Makefile.in (revision 225409)
-+++ libstdc++-v3/python/Makefile.in (working copy)
-@@ -547,7 +547,7 @@
- install-data-local: gdb.py
- @$(mkdir_p) $(DESTDIR)$(toolexeclibdir)
- @here=`pwd`; cd $(DESTDIR)$(toolexeclibdir); \
-- for file in libstdc++*; do \
-+ for file in libstdc++.*; do \
- case $$file in \
- *-gdb.py) ;; \
- *.la) ;; \