summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortilda2021-05-01 12:02:20 -0500
committertilda2021-05-01 12:04:23 -0500
commitea8de57ced8daf49e711336896cc666b83924117 (patch)
tree69c383fbe715f1c3c767800e725935d167e0fd1f
parent63c4c1021c954ff3bd5ed11b38e7b26aca91e56a (diff)
downloadaur-gdlauncher-appimage.tar.gz
1.1.5 (final update)
-rw-r--r--.SRCINFO4
-rw-r--r--.gitattributes1
-rw-r--r--PKGBUILD11
3 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef193cd2f121..5b4d5d29ace7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gdlauncher-appimage
pkgdesc = GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience
- pkgver = 1.0.11
+ pkgver = 1.1.5
pkgrel = 1
url = https://gdevs.io
install = gdlauncher-appimage.install
@@ -12,7 +12,7 @@ pkgbase = gdlauncher-appimage
depends = libxtst
depends = libindicator-gtk3
depends = libappindicator-gtk3
- source_x86_64 = GDLauncher-1.0.11.AppImage::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.0.11/GDLauncher-linux-setup.AppImage
+ source_x86_64 = GDLauncher-1.1.5.AppImage::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.1.5/GDLauncher-linux-setup.AppImage
md5sums_x86_64 = SKIP
pkgname = gdlauncher-appimage
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..7d07d70cc8d5
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+* text=lf
diff --git a/PKGBUILD b/PKGBUILD
index cc8bb48792d4..3ad06c154b08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Special thanks to RyanTheAllmighty for making hyper-appimage
pkgname="gdlauncher-appimage"
_pkgname="gdlauncher"
-pkgver="1.0.11"
+pkgver="1.1.5"
pkgrel=1
arch=('x86_64')
pkgdesc="GDLauncher is simple, yet powerful Minecraft custom launcher with a strong focus on the user experience"
@@ -19,12 +19,15 @@ source_x86_64=(
md5sums_x86_64=('SKIP')
-prepare() {
+
+prepare() {
+ # deprecation
+ echo -e "\e[36m>>>\e[0m \e[38;5;160mgdlauncher-appimage is \e[1mdeprecated.\e[0m\e[0m Please consider moving to \e[1mgdlauncher-bin\e[0m to continue receiving updates."
# make executable
- chmod +x "${srcdir}/GDLauncher-linux-setup.AppImage"
+ chmod +x "${srcdir}/GDLauncher-$pkgver.AppImage"
# extract appimage (didn't know this was possible)
- "${srcdir}/GDLauncher-linux-setup.AppImage" --appimage-extract
+ "${srcdir}/GDLauncher-$pkgver.AppImage" --appimage-extract
cd "${srcdir}"
gendesk --pkgname "GDLauncher" --pkgdesc "${pkgdesc}" --icon ${pkgname} --exec "/usr/bin/${pkgname}" -n -f
mv "GDLauncher.desktop" "${pkgname}.desktop"