summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2022-11-04 17:07:37 +0100
committerTorben2022-11-04 17:07:37 +0100
commit1bc326338c4b7ad9667aca2a87d55c9161de9b13 (patch)
tree56ebe26df8d48ffc7a0c2a4470b2814559b3c66c
parent4b0dfdb2457e0ebb57a35b9213067e67a625c018 (diff)
downloadaur-1bc326338c4b7ad9667aca2a87d55c9161de9b13.tar.gz
Remove libsoup2 patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--libsoup2.patch51
3 files changed, 5 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c57f11f802ac..b9c0491033c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = geary-git
pkgdesc = An email application built around conversations, for the GNOME 3 desktop.
- pkgver = 43.0.r9.g2b7bdbb94
+ pkgver = 43.0.r10.gdc2b87963
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/geary
arch = i686
@@ -35,8 +35,6 @@ pkgbase = geary-git
provides = geary
conflicts = geary
source = git+https://gitlab.gnome.org/GNOME/geary.git
- source = libsoup2.patch
sha256sums = SKIP
- sha256sums = fa8e8410350a5540226f4fa984641694680c09631df4b97fb87087933dc1aa04
pkgname = geary-git
diff --git a/PKGBUILD b/PKGBUILD
index 23ff4b9850ef..c39a73530945 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo at gmail dot com>
pkgname=geary-git
-pkgver=43.0.r9.g2b7bdbb94
+pkgver=43.0.r10.gdc2b87963
pkgrel=1
pkgdesc="An email application built around conversations, for the GNOME 3 desktop."
arch=(i686 x86_64)
@@ -17,10 +17,8 @@ depends=('appstream-glib' 'enchant' 'folks' 'gcr' 'gmime3' 'gtk3' 'gsound'
makedepends=('git' 'gobject-introspection' 'itstool' 'meson' 'vala')
provides=('geary')
conflicts=('geary')
-source=('git+https://gitlab.gnome.org/GNOME/geary.git'
- 'libsoup2.patch')
-sha256sums=('SKIP'
- 'fa8e8410350a5540226f4fa984641694680c09631df4b97fb87087933dc1aa04')
+source=('git+https://gitlab.gnome.org/GNOME/geary.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/geary"
@@ -30,7 +28,7 @@ pkgver() {
prepare() {
cd "$srcdir/geary"
rm -rf build
- patch -Np1 -i ../../libsoup2.patch
+ #patch -Np1 -i ../../libsoup2.patch
}
build() {
diff --git a/libsoup2.patch b/libsoup2.patch
deleted file mode 100644
index 2db8283aa2a1..000000000000
--- a/libsoup2.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/meson.build b/meson.build
-index d563dd084..c16ba583f 100644
---- a/meson.build
-+++ b/meson.build
-@@ -67,7 +67,7 @@ glib = dependency('glib-2.0', version: '>=' + target_glib)
- gmime = dependency('gmime-3.0', version: '>= 3.2.4')
- gtk = dependency('gtk+-3.0', version: '>=' + target_gtk)
- sqlite = dependency('sqlite3', version: '>= 3.24')
--webkit2gtk = dependency('webkit2gtk-4.1', version: '>=' + target_webkit)
-+webkit2gtk = dependency('webkit2gtk-4.0', version: '>=' + target_webkit)
-
- # Secondary deps - keep sorted alphabetically
- # We need appdata.its from appstream-glib:
-@@ -87,13 +87,13 @@ gspell = dependency('gspell-1')
- gthread = dependency('gthread-2.0', version: '>=' + target_glib)
- icu_uc = dependency('icu-uc', version: '>=60')
- iso_codes = dependency('iso-codes')
--javascriptcoregtk = dependency('javascriptcoregtk-4.1', version: '>=' + target_webkit)
-+javascriptcoregtk = dependency('javascriptcoregtk-4.0', version: '>=' + target_webkit)
- json_glib = dependency('json-glib-1.0', version: '>= 1.0')
- libhandy = dependency('libhandy-1', version: '>= 1.2.1', required: false)
- libmath = cc.find_library('m')
- libpeas = dependency('libpeas-1.0', version: '>= 1.24.0')
- libsecret = dependency('libsecret-1', version: '>= 0.11')
--libsoup = dependency('libsoup-3.0')
-+libsoup = dependency('libsoup-2.4')
- libstemmer_dep = cc.find_library('stemmer')
- libunwind_dep = dependency(
- 'libunwind', version: '>= 1.1', required: get_option('libunwind')
-@@ -104,7 +104,7 @@ libunwind_generic_dep = dependency(
- libxml = dependency('libxml-2.0', version: '>= 2.7.8')
- libytnef = dependency('libytnef', version: '>= 1.9.3', required: get_option('tnef'))
- posix = valac.find_library('posix')
--webkit2gtk_web_extension = dependency('webkit2gtk-web-extension-4.1', version: '>=' + target_webkit)
-+webkit2gtk_web_extension = dependency('webkit2gtk-web-extension-4.0', version: '>=' + target_webkit)
-
- # System dependencies above ensures appropriate versions for the
- # following libraries, but the declared dependency is what we actually
-diff --git a/src/client/accounts/accounts-autoconfig.vala b/src/client/accounts/accounts-autoconfig.vala
-index 58bd84636..72024eb5c 100644
---- a/src/client/accounts/accounts-autoconfig.vala
-+++ b/src/client/accounts/accounts-autoconfig.vala
-@@ -75,7 +75,7 @@ internal class Accounts.AutoConfig {
-
- try {
- stream = yield session.send_async(
-- msg, Priority.DEFAULT, this.cancellable
-+ msg, this.cancellable
- );
- } catch (GLib.Error err) {
- throw new AutoConfigError.ERROR(err.message);