summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorben2022-10-23 23:33:21 +0200
committerTorben2022-10-23 23:33:21 +0200
commitf92a44154891bbc608fe3acdcb537965a0111985 (patch)
treef21e22cdd2654318cf27ec621271fbec0d857279
parent51fafc81b69b5f235930fd78f1ff1a19edf6cdca (diff)
downloadaur-f92a44154891bbc608fe3acdcb537965a0111985.tar.gz
Add libsoup2 patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--libsoup2.patch51
3 files changed, 60 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67b78984c0d7..c57f11f802ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = geary-git
pkgdesc = An email application built around conversations, for the GNOME 3 desktop.
- pkgver = 40.0.r3.g7b8e41732
+ pkgver = 43.0.r9.g2b7bdbb94
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/geary
arch = i686
@@ -35,7 +35,8 @@ pkgbase = geary-git
provides = geary
conflicts = geary
source = git+https://gitlab.gnome.org/GNOME/geary.git
+ source = libsoup2.patch
sha256sums = SKIP
+ sha256sums = fa8e8410350a5540226f4fa984641694680c09631df4b97fb87087933dc1aa04
pkgname = geary-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f85c2831c86e..df0c47ec7d3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo at gmail dot com>
pkgname=geary-git
-pkgver=40.0.r3.g7b8e41732
+pkgver=43.0.r9.g2b7bdbb94
pkgrel=1
pkgdesc="An email application built around conversations, for the GNOME 3 desktop."
arch=(i686 x86_64)
@@ -17,8 +17,10 @@ depends=('appstream-glib' 'enchant' 'folks' 'gcr' 'gmime3' 'gtk3' 'gsound'
makedepends=('git' 'gobject-introspection' 'itstool' 'meson' 'vala')
provides=('geary')
conflicts=('geary')
-source=('git+https://gitlab.gnome.org/GNOME/geary.git')
-sha256sums=('SKIP')
+source=('git+https://gitlab.gnome.org/GNOME/geary.git'
+ 'libsoup2.patch')
+sha256sums=('SKIP'
+ 'fa8e8410350a5540226f4fa984641694680c09631df4b97fb87087933dc1aa04')
pkgver() {
cd "$srcdir/geary"
@@ -28,6 +30,7 @@ pkgver() {
prepare() {
cd "$srcdir/geary"
rm -rf build
+ patch -Np1 -i ../../libsoup2.patch
}
build() {
diff --git a/libsoup2.patch b/libsoup2.patch
new file mode 100644
index 000000000000..2db8283aa2a1
--- /dev/null
+++ b/libsoup2.patch
@@ -0,0 +1,51 @@
+diff --git a/meson.build b/meson.build
+index d563dd084..c16ba583f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -67,7 +67,7 @@ glib = dependency('glib-2.0', version: '>=' + target_glib)
+ gmime = dependency('gmime-3.0', version: '>= 3.2.4')
+ gtk = dependency('gtk+-3.0', version: '>=' + target_gtk)
+ sqlite = dependency('sqlite3', version: '>= 3.24')
+-webkit2gtk = dependency('webkit2gtk-4.1', version: '>=' + target_webkit)
++webkit2gtk = dependency('webkit2gtk-4.0', version: '>=' + target_webkit)
+
+ # Secondary deps - keep sorted alphabetically
+ # We need appdata.its from appstream-glib:
+@@ -87,13 +87,13 @@ gspell = dependency('gspell-1')
+ gthread = dependency('gthread-2.0', version: '>=' + target_glib)
+ icu_uc = dependency('icu-uc', version: '>=60')
+ iso_codes = dependency('iso-codes')
+-javascriptcoregtk = dependency('javascriptcoregtk-4.1', version: '>=' + target_webkit)
++javascriptcoregtk = dependency('javascriptcoregtk-4.0', version: '>=' + target_webkit)
+ json_glib = dependency('json-glib-1.0', version: '>= 1.0')
+ libhandy = dependency('libhandy-1', version: '>= 1.2.1', required: false)
+ libmath = cc.find_library('m')
+ libpeas = dependency('libpeas-1.0', version: '>= 1.24.0')
+ libsecret = dependency('libsecret-1', version: '>= 0.11')
+-libsoup = dependency('libsoup-3.0')
++libsoup = dependency('libsoup-2.4')
+ libstemmer_dep = cc.find_library('stemmer')
+ libunwind_dep = dependency(
+ 'libunwind', version: '>= 1.1', required: get_option('libunwind')
+@@ -104,7 +104,7 @@ libunwind_generic_dep = dependency(
+ libxml = dependency('libxml-2.0', version: '>= 2.7.8')
+ libytnef = dependency('libytnef', version: '>= 1.9.3', required: get_option('tnef'))
+ posix = valac.find_library('posix')
+-webkit2gtk_web_extension = dependency('webkit2gtk-web-extension-4.1', version: '>=' + target_webkit)
++webkit2gtk_web_extension = dependency('webkit2gtk-web-extension-4.0', version: '>=' + target_webkit)
+
+ # System dependencies above ensures appropriate versions for the
+ # following libraries, but the declared dependency is what we actually
+diff --git a/src/client/accounts/accounts-autoconfig.vala b/src/client/accounts/accounts-autoconfig.vala
+index 58bd84636..72024eb5c 100644
+--- a/src/client/accounts/accounts-autoconfig.vala
++++ b/src/client/accounts/accounts-autoconfig.vala
+@@ -75,7 +75,7 @@ internal class Accounts.AutoConfig {
+
+ try {
+ stream = yield session.send_async(
+- msg, Priority.DEFAULT, this.cancellable
++ msg, this.cancellable
+ );
+ } catch (GLib.Error err) {
+ throw new AutoConfigError.ERROR(err.message);