summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-12-13 12:41:42 +0300
committerCaleb Maclennan2023-12-13 12:47:14 +0300
commit523686354cb1cdc85dcf96a3cf0759032d43e44b (patch)
tree4a608e4bced99fc899a952a34a14919e3a62b980
parent5b7017019805059990f5b8270a8f7be22de2900b (diff)
downloadaur-gitahead.tar.gz
upgpkg: gitahead 2.7.0-1
upstream release Signed-off-by: Caleb Maclennan <caleb@alerque.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
-rw-r--r--gitahead.patch20
3 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5668c1bd49f..d63d3cc6df3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = gitahead
pkgdesc = Understand your Git history!
- pkgver = 2.6.3
- pkgrel = 5
+ pkgver = 2.7.0
+ pkgrel = 1
url = https://www.gitahead.com/
arch = x86_64
license = MIT
makedepends = cmake
- makedepends = qt5-tools
- makedepends = qt5-translations
+ makedepends = python
+ makedepends = qt6-tools
+ makedepends = qt6-translations
depends = desktop-file-utils
depends = git
depends = org.freedesktop.secrets
- depends = qt5-base
- source = git+https://github.com/gitahead/gitahead#tag=v2.6.3
+ depends = qt6-5compat
+ depends = qt6-base
+ source = git+https://github.com/gitahead/gitahead#tag=v2.7.0
source = gitahead.desktop
source = gitahead.patch
sha256sums = SKIP
sha256sums = 254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0
- sha256sums = 096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0
+ sha256sums = ab04ba1f49fbddc3a6df37319c744638f49a4114b688d2d71f0067c207487ff2
pkgname = gitahead
diff --git a/PKGBUILD b/PKGBUILD
index 0b0cdae37471..5424c83c8862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=gitahead
-pkgver=2.6.3
-pkgrel=5
+pkgver=2.7.0
+pkgrel=1
pkgdesc='Understand your Git history!'
url='https://www.gitahead.com/'
arch=(x86_64)
@@ -15,16 +15,18 @@ license=(MIT)
depends=(desktop-file-utils
git
org.freedesktop.secrets
- qt5-base)
+ qt6-5compat
+ qt6-base)
makedepends=(cmake
- qt5-tools
- qt5-translations)
+ python
+ qt6-tools
+ qt6-translations)
source=("git+https://github.com/$pkgname/$pkgname#tag=v$pkgver"
"$pkgname.desktop"
"$pkgname.patch")
sha256sums=('SKIP'
'254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0'
- '096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0')
+ 'ab04ba1f49fbddc3a6df37319c744638f49a4114b688d2d71f0067c207487ff2')
prepare() {
cd "$pkgname"
diff --git a/gitahead.patch b/gitahead.patch
index c57f8785dc8c..17f62a5bc5f2 100644
--- a/gitahead.patch
+++ b/gitahead.patch
@@ -1,18 +1,18 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b39f3a4..0b9b550 100644
+index 0dd8d38..c882a73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -61,7 +61,7 @@ endif()
+@@ -62,7 +62,7 @@ endif()
- find_package(Qt5 5.9 COMPONENTS ${QT_MODULES} LinguistTools REQUIRED)
+ find_package(Qt6 COMPONENTS ${QT_MODULES} LinguistTools REQUIRED)
--set(QT_TRANSLATIONS_DIR "${Qt5_DIR}/../../../translations")
+-set(QT_TRANSLATIONS_DIR "${Qt6_DIR}/../../../translations")
+set(QT_TRANSLATIONS_DIR "/usr/share/qt/translations")
if(APPLE)
foreach(QT_MODULE ${QT_MODULES})
diff --git a/dep/CMakeLists.txt b/dep/CMakeLists.txt
-index d589b6f..02e9035 100644
+index 16c7574..8295db2 100644
--- a/dep/CMakeLists.txt
+++ b/dep/CMakeLists.txt
@@ -1,6 +1,5 @@
@@ -23,7 +23,7 @@ index d589b6f..02e9035 100644
add_subdirectory(libgit2)
diff --git a/dep/libssh2/CMakeLists.txt b/dep/libssh2/CMakeLists.txt
-index d5ee005..6ca9e34 100644
+index 4062762..d4f2593 100644
--- a/dep/libssh2/CMakeLists.txt
+++ b/dep/libssh2/CMakeLists.txt
@@ -1,7 +1,7 @@
@@ -36,15 +36,15 @@ index d5ee005..6ca9e34 100644
set(BUILD_TESTING OFF CACHE BOOL "" FORCE)
diff --git a/pack/CMakeLists.txt b/pack/CMakeLists.txt
-index 61bd9fa..8338b7a 100644
+index dcb5964..df2d336 100644
--- a/pack/CMakeLists.txt
+++ b/pack/CMakeLists.txt
-@@ -139,7 +139,7 @@ if(UNIX AND NOT APPLE)
+@@ -145,7 +145,7 @@ if(UNIX AND NOT APPLE)
endif()
# Install SSL libraries.
-if(NOT APPLE)
+if(FALSE)
if(WIN32)
- if(CMAKE_SIZEOF_VOID_P EQUAL 8)
- set(SSL_LIB_SUFFIX "-1_1-x64.dll")
+ set(SSL_LIB_SUFFIX "-3-x64.dll")
+ else()