summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Johnson2021-08-22 15:13:19 -0600
committerDoug Johnson2021-08-22 15:13:19 -0600
commit9d4e2f6263cd634de211919c895c0fed9b406eff (patch)
tree106b8f941dcad3e843a2bc10a3d1c9c57905f18a
parentd44c0349fda72a294329976007b622c3a41f2ebc (diff)
downloadaur-gitlab-ci-local-git.tar.gz
Do not strip binaries, remove node-ts as that's bundled in the build
Fixes problem as described here for node packages: https://github.com/vercel/pkg/issues/389
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad648fe8cf1a..b3a5589ae921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitlab-ci-local-git
pkgdesc = Run gitlab pipelines locally as shell executor or docker executor
pkgver = 4.23.0.r0.g2195c19
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/firecow/gitlab-ci-local
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = gitlab-ci-local-git
makedepends = sed
makedepends = npm
makedepends = typescript
- depends = ts-node
+ options = !strip
source = gitlab-ci-local-git::git+https://github.com/firecow/gitlab-ci-local.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 49d874c52697..012c4d86eea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Doug Johnson <dougvj at dougvj dot net>
pkgname=gitlab-ci-local-git
pkgver=4.23.0.r0.g2195c19
-pkgrel=1
+pkgrel=2
source=('gitlab-ci-local-git::git+https://github.com/firecow/gitlab-ci-local.git')
md5sums=('SKIP')
pkgdesc="Run gitlab pipelines locally as shell executor or docker executor"
@@ -9,11 +9,15 @@ arch=('i686' 'x86_64')
url="https://github.com/firecow/gitlab-ci-local"
license=('MIT')
makedepends=('git' 'sed' 'npm' 'typescript')
-depends=('ts-node')
+
+# TODO Don't bundle ts-node with the build perhaps
+# so we can use the system's version
+#depends=('ts-node')
pkgver() {
cd "$pkgname"
git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+options=("!strip")
build() {
cd "$pkgname"