summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-20 15:29:40 -0700
committerMark Wagie2024-01-20 15:29:40 -0700
commitece2cebe9a94fd5307a28b71b9fcfa13acc350ee (patch)
tree2a7da88235df8f73021b188400c1c1775149b30b
parent4c59fb8e6ef4823360edc49a2732629de354c90e (diff)
downloadaur-gnome-shell-extension-gnome-ui-tune-git.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18b1482405a1..bcfa941f89bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = gnome-shell-extension-gnome-ui-tune-git
pkgrel = 1
url = https://github.com/axxapy/gnome-ui-tune
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = jq
depends = gnome-shell
diff --git a/PKGBUILD b/PKGBUILD
index fb6ad1d18e5c..7ec2a80fcd1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Tunes GNOME Overview UI to make it more usable."
arch=('any')
url="https://github.com/axxapy/gnome-ui-tune"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('gnome-shell')
makedepends=('git' 'jq')
provides=("${pkgname%-git}")
@@ -15,18 +15,18 @@ source=('git+https://github.com/axxapy/gnome-ui-tune.git')
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/gnome-ui-tune
+ cd gnome-ui-tune
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $srcdir/gnome-ui-tune
+ cd gnome-ui-tune
make gettext
make dist
}
package() {
- cd $srcdir/gnome-ui-tune
+ cd gnome-ui-tune
install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
bsdtar xvf "${_uuid}.shell-extension.zip" -C \
"$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/" --no-same-owner