summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-08-17 13:10:26 +0800
committerChocobo12022-08-17 13:35:29 +0800
commit2e6aa96b6c1f05f59d67588b7cde7fee4792687a (patch)
tree316e1a235df4c49af5617f35f51832e6d70dbec7
parentfd995df4d30a8e9ca9a665e5bcc6ee278d77bc83 (diff)
downloadaur-gnutls-git.tar.gz
upgpkg: gnutls-git 3.7.7.r21.g66f511895-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0518535348e..7d0247e15528 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnutls-git
pkgdesc = A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them
- pkgver = 3.6.13.r104.g52e78f1e3
+ pkgver = 3.7.7.r21.g66f511895
pkgrel = 1
url = https://www.gnutls.org/
arch = i686
@@ -9,9 +9,11 @@ pkgbase = gnutls-git
makedepends = git
makedepends = autogen
makedepends = gperf
+ makedepends = gtk-doc
makedepends = rsync
makedepends = wget
depends = glibc
+ depends = brotli
depends = libidn2
depends = libtasn1
depends = libunistring
@@ -19,10 +21,10 @@ pkgbase = gnutls-git
depends = p11-kit
depends = readline
depends = zlib
- provides = gnutls
+ provides = gnutls=3.7.7.r21.g66f511895
conflicts = gnutls
+ options = !zipman
source = git+https://gitlab.com/gnutls/gnutls.git
sha256sums = SKIP
pkgname = gnutls-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e44d34bf7b5..e3d76d859351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=gnutls-git
-pkgver=3.6.13.r104.g52e78f1e3
+pkgver=3.7.7.r21.g66f511895
pkgrel=1
pkgdesc="A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them"
arch=('i686' 'x86_64')
url="https://www.gnutls.org/"
license=('LGPL')
-depends=('glibc' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
-makedepends=('git' 'autogen' 'gperf' 'rsync' 'wget')
-provides=('gnutls')
+depends=('glibc' 'brotli' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
+makedepends=('git' 'autogen' 'gperf' 'gtk-doc' 'rsync' 'wget')
+provides=("gnutls=$pkgver")
conflicts=('gnutls')
+options=('!zipman')
source=("git+https://gitlab.com/gnutls/gnutls.git")
sha256sums=('SKIP')
@@ -27,14 +28,25 @@ build() {
./bootstrap
./configure \
--prefix="/usr" \
- --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit" \
--disable-full-test-suite \
- --disable-guile
+ --enable-openssl-compatibility \
+ --with-default-trust-store-pkcs11="pkcs11:"
make
}
+check() {
+ cd "gnutls"
+
+ #make check
+}
+
package() {
cd "gnutls"
make DESTDIR="$pkgdir" install
+
+ # lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
+ # gzip -9 all files in infodir and manpages manually
+ find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -n -9 {} \;
+ find "$pkgdir/usr/share/man" -exec gzip -n -9 {} \;
}