summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 13:45:12 +0200
committerChristian Hesse2015-06-30 13:45:12 +0200
commit877e13d518517c569a5e2b813547d414ea634a72 (patch)
tree954a0218442986d7bea6727d417e69b77e53f9cf
downloadaur-hardlinkpy-hg.tar.gz
initial import of hardlinkpy-hg 0.1be1ba7ea389-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..149bbd889d05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hardlinkpy-hg
+ pkgdesc = a tool to hardlink together identical files in order to save space
+ pkgver = 0.1be1ba7ea389
+ pkgrel = 1
+ url = https://code.google.com/p/hardlinkpy/
+ arch = any
+ license = GPL2
+ makedepends = mercurial
+ depends = python2
+ provides = hardlinkpy
+ conflicts = hardlinkpy
+ source = hg+https://code.google.com/p/hardlinkpy/
+ sha256sums = SKIP
+
+pkgname = hardlinkpy-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..381a3bf08ba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=hardlinkpy-hg
+pkgver=0.1be1ba7ea389
+pkgrel=1
+pkgdesc='a tool to hardlink together identical files in order to save space'
+arch=('any')
+url='https://code.google.com/p/hardlinkpy/'
+license=('GPL2')
+depends=('python2')
+makedepends=('mercurial')
+provides=('hardlinkpy')
+conflicts=('hardlinkpy')
+source=('hg+https://code.google.com/p/hardlinkpy/')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd hardlinkpy/
+
+ hg tip | head -n1 | tr -d ' ' | cut -d: --output-delimiter=. -f 2,3
+}
+
+package() {
+ cd hardlinkpy/
+
+ sed -i '1c #!/usr/bin/python2' hardlink.py
+
+ install -D -m0755 hardlink.py "${pkgdir}/usr/bin/hardlink.py"
+ install -D -m0644 COPYING "${pkgdir}/usr/share/licenses/hardlinkpy/COPYING"
+}
+