summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2024-05-02 20:28:33 +0300
committergesh2024-05-02 20:28:33 +0300
commit0b9ab3f9830c83fbe698ad8906346351a083297c (patch)
treed970f8e607168dbb498f868bc2db6f6ecdf66bfb
parente82062540063494df143e6e4ec53f9ab77277161 (diff)
downloadaur-hlint-static-git.tar.gz
Force building with ghc-9.6.5
The default makepkg configuration sets LDFLAGS but not LD. GHC used to take this as its cue to select its own choice of LD. However GHC would *not* check that its choice of LD supports LDFLAGS. This is a problem for dependencies with C components, which get linked using this LD. A fix[1] for this has landed in ghc 9.6.5 on 2024-04-16, and ghc's installed using the current ghcup HEAD (starting with 7a684ad[2]) will have `--disable-ld-override` passed, which also fixes the issue. [1] - https://gitlab.haskell.org/ghc/ghc/-/issues/24565 [2] - https://github.com/haskell/ghcup-hs/issues/1032
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75d8920307e6..a01301862ba5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hlint-static-git
pkgdesc = Haskell source code suggestions
- pkgver = 3.8.r17.gbaf62009
+ pkgver = 3.8.r19.g323eb45e
pkgrel = 1
url = https://github.com/ndmitchell/hlint
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index dbe2628461e1..5e7aad17e4ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dino Morelli <dino@ui3.info>
pkgname=hlint-static-git
-pkgver=3.8.r17.gbaf62009
+pkgver=3.8.r19.g323eb45e
pkgrel=1
pkgdesc='Haskell source code suggestions'
arch=('x86_64')
@@ -20,6 +20,12 @@ pkgver() {
git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$pkgname"
+
+ stack config set resolver lts-22.19 # ghc-9.6.4
+ echo 'compiler: ghc-9.6.5' >> stack.yaml
+}
build() {
cd "$pkgname"