summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiuseppe Sellaroli2015-06-15 13:22:48 -0400
committerGiuseppe Sellaroli2015-06-15 13:22:48 -0400
commit7082c84e55ee9971c748fcf71f7ed2209f213480 (patch)
tree70c5cf83d714c109db097e37b315330b1d1c0d98
downloadaur-7082c84e55ee9971c748fcf71f7ed2209f213480.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--blacklist-input-wacom-dkms.conf4
-rw-r--r--dkms.conf13
-rw-r--r--input-wacom-dkms.install26
5 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b421a6594ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = input-wacom-dkms
+ pkgdesc = Latest Kernel modules form Wacom tablets (DKMS). Useful if your wacom tablet is not supported upstream yet.
+ pkgver = 0.28.0
+ pkgrel = 1
+ url = http://linuxwacom.sourceforge.net/wiki/index.php/Input-wacom
+ install = input-wacom-dkms.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = dkms
+ optdepends = xf86-input-wacom: for actually using a Wacom tablet
+ source = http://downloads.sourceforge.net/project/linuxwacom/xf86-input-wacom/input-wacom/input-wacom-0.28.0.tar.bz2
+ source = dkms.conf
+ source = blacklist-input-wacom-dkms.conf
+ md5sums = 90e9288c461da864d28b62bc8b81165f
+ md5sums = 0ab5649289812c1666e3a802476364bb
+ md5sums = da99119208e69b9a611b1809e1f241f8
+
+pkgname = input-wacom-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76ce7b789150
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Giuseppe Sellaroli <g.sellaroli at yahoo dot it>
+pkgname=input-wacom-dkms
+_pkgname=input-wacom
+pkgver=0.28.0
+pkgrel=1
+pkgdesc="Latest Kernel modules form Wacom tablets (DKMS). Useful if your wacom tablet is not supported upstream yet."
+arch=('i686' 'x86_64')
+url="http://linuxwacom.sourceforge.net/wiki/index.php/Input-wacom"
+license=('GPL2')
+depends=('dkms')
+optdepends=('xf86-input-wacom: for actually using a Wacom tablet')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/project/linuxwacom/xf86-input-wacom/input-wacom/$_pkgname-$pkgver.tar.bz2"
+ "dkms.conf"
+ "blacklist-input-wacom-dkms.conf")
+noextract=()
+md5sums=('90e9288c461da864d28b62bc8b81165f'
+ '0ab5649289812c1666e3a802476364bb'
+ 'da99119208e69b9a611b1809e1f241f8')
+package() {
+
+ installdir="$pkgdir/usr/src/$_pkgname-$pkgver"
+
+ install -dm755 "$installdir"
+ install -m644 "$srcdir/dkms.conf" "$installdir"
+
+ install -dm755 "$pkgdir/etc/modprobe.d"
+ install -m644 "$srcdir/blacklist-input-wacom-dkms.conf" "$pkgdir/etc/modprobe.d"
+
+ cd "${srcdir}/${_pkgname}-${pkgver}/"
+
+ for d in `find . -type d`
+ do
+ install -dm755 "$installdir/$d"
+ done
+
+ for f in `find . -type f`
+ do
+ install -m644 "${srcdir}/${_pkgname}-${pkgver}/$f" "$installdir/$f"
+ done
+ chmod +x "$installdir/configure"
+}
diff --git a/blacklist-input-wacom-dkms.conf b/blacklist-input-wacom-dkms.conf
new file mode 100644
index 000000000000..8a7d2c64656c
--- /dev/null
+++ b/blacklist-input-wacom-dkms.conf
@@ -0,0 +1,4 @@
+blacklist wacom
+blacklist wacom_w8001
+
+
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..9d7cda7dc777
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,13 @@
+PACKAGE_NAME="input-wacom"
+PACKAGE_VERSION="0.28.0"
+MAKE[0]="./configure && make"
+BUILT_MODULE_NAME[0]="wacom"
+DEST_MODULE_NAME[0]="wacom_dkms"
+BUILT_MODULE_NAME[1]="wacom_w8001"
+DEST_MODULE_NAME[1]="wacom_w8001_dkms"
+BUILT_MODULE_LOCATION[0]="3.17/"
+BUILT_MODULE_LOCATION[1]="3.17/"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/input/tablet"
+DEST_MODULE_LOCATION[1]="/kernel/drivers/input/touchscreen"
+AUTOINSTALL="yes"
+
diff --git a/input-wacom-dkms.install b/input-wacom-dkms.install
new file mode 100644
index 000000000000..7844f4257ea7
--- /dev/null
+++ b/input-wacom-dkms.install
@@ -0,0 +1,26 @@
+post_install() {
+ local version=${1%%-*}
+ dkms=$(which dkms)
+ $dkms install -m input-wacom -v $version
+ echo -e "\n"
+ echo "#####################################"
+ echo -e "\n"
+ echo "To avoid conflict with the original modules provided by the kernel, the dkms modules were renamed to 'wacom_dkms' and 'wacom_w8001_dkms'."
+ echo "Should you need to manually load the module, use 'modprobe wacom_dkms' or 'modprobe wacom_w8001_dkms'."
+ echo "To remove the modules, use 'rmmod wacom' or 'rmmod wacom_w8001' instead."
+ echo -e "\n"
+}
+
+pre_upgrade() {
+ pre_remove $2
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ local version=${1%%-*}
+ dkms=$(which dkms)
+ $dkms remove -m input-wacom -v $version --all
+}