summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier C. Llano2023-06-27 11:04:08 -0700
committerXavier C. Llano2023-06-27 11:04:08 -0700
commit43588d8304e27a6526a89f890146a9468a194c05 (patch)
tree83e326ffc2c6db20ef3065460446fa35723d4393
parent502b5c1b66fb79bcc2f7b9e8b89e6e00e8a0c363 (diff)
downloadaur-jaziku.tar.gz
updates
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eed1b91ddbd..8fe36cd05b8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = jaziku
pkgdesc = Jaziku is statistical inference software for the teleconnections analysis
pkgver = 1.0.0
pkgrel = 2
- url = https://bitbucket.org/XavierCLL/jaziku
+ url = https://github.com/XavierCLL/Jaziku
arch = i686
arch = x86_64
license = GPLv3
@@ -18,8 +18,7 @@ pkgbase = jaziku
depends = dos2unix
optdepends = ncl: maps
optdepends = hpgl: interpolation
- source = jaziku-1.0.0.tar.bz2::https://bitbucket.org/XavierCLL/jaziku/get/py3.tar.bz2
- md5sums = SKIP
+ source = https://github.com/XavierCLL/Jaziku/archive/refs/heads/py3.zip
+ sha256sums = SKIP
pkgname = jaziku
-
diff --git a/PKGBUILD b/PKGBUILD
index 809096908914..9646c6cbd01a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@ pkgname=jaziku
pkgver=1.0.0
pkgrel=2
pkgdesc="Jaziku is statistical inference software for the teleconnections analysis"
-url="https://bitbucket.org/XavierCLL/jaziku"
+url="https://github.com/XavierCLL/Jaziku"
arch=('i686' 'x86_64')
license=('GPLv3')
depends=('python' 'python-distribute' 'python-scipy' 'python-dateutil' 'python-matplotlib' 'python-numpy' 'python-pillow' 'python-clint' 'imagemagick' 'dos2unix')
optdepends=('ncl: maps' 'hpgl: interpolation')
-source=("$pkgname-$pkgver.tar.bz2::https://bitbucket.org/XavierCLL/jaziku/get/py3.tar.bz2")
-md5sums=('SKIP')
+source=("https://github.com/XavierCLL/Jaziku/archive/refs/heads/py3.zip")
+sha256sums=('SKIP')
build() {
- cd XavierCLL-jaziku*
- python ./setup.py build || return 1
+ cd Jaziku-py3
+ python ./setup.py build
}
package(){
- cd XavierCLL-jaziku*
- python ./setup.py install --root=$pkgdir || return 1
+ cd Jaziku-py3
+ python ./setup.py install --root=$pkgdir
}