summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-11-28 01:52:39 +0800
committerdetiam2023-11-28 01:52:39 +0800
commit19df033fe149cacc600c8b0ec4a79ba5b72057d6 (patch)
tree8e1bb2bedbc4eb77c5b8bbcc0655e24a67ea2f21
parent4d76257fd52e9e343f8e6a24daf4fe6111960597 (diff)
downloadaur-junction-zhfix.tar.gz
v1.6.1 switch to my fork
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD37
2 files changed, 15 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d10599d94a9..a737164ed110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = junction-zhfix
- pkgdesc = Application/browser chooser
- pkgver = 1.6
- pkgrel = 4
- url = https://github.com/sonnyp/Junction
+ pkgdesc = Application/browser chooser (zhfix fork)
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/detiam/Junction-zhfix
arch = x86_64
arch = aarch64
license = GPL3
@@ -11,12 +11,13 @@ pkgbase = junction-zhfix
makedepends = meson
makedepends = python-gobject
makedepends = blueprint-compiler
+ makedepends = xdg-utils
depends = libadwaita
depends = libportal-gtk4
depends = gjs
provides = junction
conflicts = junction
- source = junction-1.6::git+https://github.com/sonnyp/Junction.git#commit=53ca01d7f3eca72a4a6bb0727ca6aa5eec3e63db
+ source = junction-1.6.1::git+https://github.com/detiam/Junction-zhfix.git#tag=v1.6.1
b2sums = SKIP
pkgname = junction-zhfix
diff --git a/PKGBUILD b/PKGBUILD
index 30dab433fb10..3ea9d3cd7ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,44 +3,25 @@
_pkgname=junction
pkgname=junction-zhfix
-pkgdesc="Application/browser chooser"
-pkgver=1.6
-pkgrel=4
-#_tag=v$pkgver
-_commit=53ca01d7f3eca72a4a6bb0727ca6aa5eec3e63db
+pkgdesc="Application/browser chooser (zhfix fork)"
+pkgver=1.6.1
+pkgrel=1
+_tag=v$pkgver
+#_commit=0343689c5bf835b27ff18a2490e74e5e4d361e1d
arch=('x86_64' 'aarch64')
-url="https://github.com/sonnyp/Junction"
+url="https://github.com/detiam/Junction-zhfix"
license=('GPL3')
conflicts=("$_pkgname")
provides=("$_pkgname")
depends=('libadwaita' 'libportal-gtk4' 'gjs')
-makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler')
+makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler' 'xdg-utils')
checkdepends=('appstream-glib')
-source=("${_pkgname}-${pkgver}::git+$url.git#commit=$_commit")
+source=("${_pkgname}-${pkgver}::git+${url}.git#tag=${_tag}")
b2sums=('SKIP')
prepare() {
- cd "$_pkgname-$pkgver"
-
+ cd "${_pkgname}-${pkgver}"
git -c protocol.file.allow=always submodule update --init --recursive
-
- # fix Simplified Chinese translation
- pushd po
- sed -i 's/zh_Hans/zh_CN\nzh_SG/' LINGUAS
- ln -v zh_Hans.po zh_CN.po
- ln -v zh_Hans.po zh_SG.po
- popd
-
- # fix crash that happened when not in flatpak environment
- pushd src
- sed -i 's|XDG_DATA_DIRS.*e ||' bin.js
- popd
-
- # redirect output
- # if not, when use `xdg-open` there will have annoying log printed to terminal
- pushd data
- sed -i '/^Exec=/ s|$| 2>/dev/null|' re.sonny.Junction.desktop
- popd
}
build() {