summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2015-08-09 17:36:58 +0200
committerLucas Werkmeister2015-08-09 17:41:46 +0200
commitf4d946824f2ee8a0ca5d95abc46e962a2e98b7eb (patch)
tree4ca33bbed86f9416a7003b602884631fc491e549
parent590fb680d23bf305c94739df9107f0629e7e1330 (diff)
downloadaur-libturpial-git.tar.gz
Add comment to pkgver()
We can’t change it to use git-describe now, since that would result in a lower version number.
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9730081e6876..0c376cbd7657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,8 @@ source=($pkgname::git://github.com/satanas/libturpial.git#branch=development)
md5sums=('SKIP')
pkgver() {
+ # TODO: with the next version bump, consider changing this to use `git describe`
+ # see https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git
cd $pkgname/
echo $(head -n1 ChangeLog | awk '{print $1}' | sed 's/v//;s/-/./').$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}