summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2022-06-16 20:31:32 -0400
committerseth2022-06-16 20:31:32 -0400
commitbd8676a2d9dae5fe3c53b276e700b3c1dfe5dbc2 (patch)
tree266684ed1fc3e18160f178ee42db658692b71bb7
parent004d3f10cc439da5c581c9147003ffe49f7c7007 (diff)
downloadaur-lightmaputil-git.tar.gz
remove cmath.patch
fixed upstream (thanks hurricane!) https://github.com/treacherousfiend/LightmapUtil/pull/4
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
-rw-r--r--cmath.patch12
4 files changed, 5 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca177d10a987..198b05f2d3f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lightmaputil-git
pkgdesc = A simple command line utility to tell you if your lightmaps are too high resolution
- pkgver = r27.0ec24fd
+ pkgver = r44.6b38f5d
pkgrel = 1
url = https://github.com/treacherousfiend/LightmapUtil
arch = x86_64
@@ -10,8 +10,6 @@ pkgbase = lightmaputil-git
provides = lightmaputil
conflicts = lightmaputil
source = lightmaputil::git+https://github.com/treacherousfiend/LightmapUtil
- source = cmath.patch
sha512sums = SKIP
- sha512sums = 2b306fa29c8d52f7b61b365e1009d9c335d30ad2584d89dcabbc3e0cdcf81ceebaa938f8184c3dbfc33ccce3f0381409adb13945d1526c0ab3748bd80a696615
pkgname = lightmaputil-git
diff --git a/.gitignore b/.gitignore
index 2bd5e5095a60..624e5f91e8cc 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,3 @@
*.tar*
*.log
-lightmaputil/
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 4daf438ddf18..8535920b50ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: seth <g3tchoo at proton dot me>
pkgname=lightmaputil-git
-pkgver=r27.0ec24fd
+pkgver=r44.6b38f5d
pkgrel=1
pkgdesc="A simple command line utility to tell you if your lightmaps are too high resolution"
arch=('x86_64')
@@ -10,10 +10,8 @@ license=('custom:none')
makedepends=('git' 'cmake') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/treacherousfiend/LightmapUtil"
- "cmath.patch")
-sha512sums=('SKIP'
- '2b306fa29c8d52f7b61b365e1009d9c335d30ad2584d89dcabbc3e0cdcf81ceebaa938f8184c3dbfc33ccce3f0381409adb13945d1526c0ab3748bd80a696615')
+source=("${pkgname%-git}::git+https://github.com/treacherousfiend/LightmapUtil")
+sha512sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -21,11 +19,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 -i "$srcdir/cmath.patch"
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
mkdir -p build
diff --git a/cmath.patch b/cmath.patch
deleted file mode 100644
index a62e29e77f6c..000000000000
--- a/cmath.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/LightmapUtil.cpp b/src/LightmapUtil.cpp
-index ce742e8..62371a9 100644
---- a/src/LightmapUtil.cpp
-+++ b/src/LightmapUtil.cpp
-@@ -5,6 +5,7 @@
- #include <vector>
- #include <filesystem>
- #include <cstring>
-+#include <cmath>
-
- #include "LightmapUtil.h"
-